Aeon Labs Minimote with SmartThings?

Is there information on how to write code for these?

The included SmartApp is… limited. It would be nice at the very least to turn on / off lights. If nothing else.

The Button Controller SmartApp can do everything you should need. Check it out.

1 Like

Cheers Ben - thank you for jumping in.

I need something a little more. All I can seem to do with the button app is pair it to some lights, or locks, etc

My use case is - Btn1 - Bathroom Lights to “Concentrate”, Btn2 - Bathroom Lights to Dim Soft Red, Btn3 - Force exhaust fan off, Btn4 - Set house asleep

I can do Btn4 as it’s a mode change, but I can’t do anything else.

As always - happy to write the code - but I can’t seem to find any information about handling button events.

You can create a Hello, Home action that turns your exhaust fan off then use a button on the remote to execute that action.

As far as setting bathroom lights to “Concentrate”, if you give me more information about what that means I’ll think about that as well.

Setting your lights to dim is also a function of a Hello, Home action but we don’t yet allow you to set color as well. You can tie a mode change into a color change with the “hue Mood Lighting” SmartThings Labs configuration and then set a Hello, Home action to change the mode as a workaround for the Minimote but that will only work for you if you don’t mind it executing that mode change as well.

That’s something we need to work on a bit to make it a more cohesive experience.

1 Like

'm still lost on how this is suppose to function. I’ve followed all the steps, the remote shows up and the “Button Controller” smartapp is attached. I tried adding a “light” to the Lights “Held” section for the “first button”. The “light” I have added is just a in-wall ge switch. However when I hold the “first” button nothing happens, either on or off. I’ve also tried associting locks via the smartapp to no effect.

There is no activity listed in the activity section of the app either. The remote has a Device Network ID of 23 in the Device List. The “Status” originally showed ACTIVE after being added but since then has remained INACTIVE no matter what button I press. I have tried removing and adding the remote back into the network with no change in behavour.

Did it somehow get disassociated? I use mine every night to change modes, among other things. Unpair and repair it to see. It seems that if you are not seeing anything in the activity log, then the remote is not connected to the hub.

As I mentioned, I already tried this.

Hi Guys

I just received the Lighting Automation Kit. It includes a Aeon Minimote. Mine has the same shape as the one in the store but the buttons under the cover are labeled quite differently (big-plus, big-minus, blank and join). I start the button controller smartapp. It does not see a button controller. I press the Join button. The hub detects the Minimote but the button controller smartapp says “a device has joined but the wrong type”. I have a button controller in the things panel with an exclamation point next to it.

What is going on? Did they ship the wrong minimote?

Frustrated especially as I bought the kit directly from Smartthings thinking I would avoid incompatibilities.

George

There are two button styles out there but they should work the same. So you have this one?

http://www.zwaveproducts.com/images/cache/1001x1220/AeonMinimote_V1_1.jpg

I haven’t seen these same symptoms before. Normally it is that the devices battery is dead on arrival and it needs to be charged for a while. It should join as device type “Aeon Minimote”. You can check this in the IDE site by going to My Devices and looking at the Minimote.

If it looks like the right device type then I would try removing it and re-joining it again. Let us know your results.

1 Like

According to this page, it sounds like you got version 1 and version 2 can be seen here with version 1 seen below the main product:

http://www.zwaveproducts.com/Zwave-Controllers/Zwave-Remotes/Aeon-Labs-Z-Wave-Minimote-DSA03202W-ZWUS-White.html

And here’s version 1 (and a nice comparison chart below it) and they state it has the same functionality if you flash the firmware:

http://www.zwaveproducts.com/Zwave-Controllers/Zwave-Remotes/Aeon-Labs-DSA03202-v1-Z-Wave-Minimote.html

http://aeotec.com/small-z-wave-remote-control/1265-minimote-firmware.html

2 Likes

Hi RichardH

Big Kudos for solving the problem!

Much thanks for taking the time

Best
George

Tyler: You may have already notice; but there’s a Thread that is entering charted and uncharted territory discussing the concept of Scenes and their relationship to Hello Home ™ Actions. I realize there’s a lot of overlap between the concepts, but I think it is too early to dismiss one way of thinking over the other.

In other words, for example: In Hello Home Actions you can turn on a set of lights and set them all to the SAME dimmer level. I’d much rather capture the set of lights along with their individually set dim levels (like Scene Machine does), and then have that “Scene Object” be activatable throughout the system (i.e., from a Hello Home Action or other Event / Virtual Button or Minimote Button).

This is pretty exciting news - being able to use a remote (secondary) to initiate ST actions. Has anyone tried doing this with the GE Keypad Controller (45631)? If so it would be a way around the node#32 limit on the 45631.

@ChuckV

Have you checked out this thread:

1 Like

I have released a beta SmartApp that uses the Aeon Labs Aeotec Minimote as a PIN entry device (“Security Keypad”). It will also work with other multi-button controllers like the ZWN-SC7 Enerwave 7 Button Scene Controller

As a side benefit, you could install multiple instances of the app and if each has a distinct PIN sequence, your minimote can now control 16 actions (2-button PIN), or 64 (3-button PIN), or 256 (4-button PIN), etc.

Read more, follow, test, and contribute here:

…CP / Terry.

2 Likes

I too was experiencing frustration with the minimote. I got a version 1 for $25 to control my living room lights. Out of the box it joined my ST network just fine. Smart app set up for button click and hold etc, etc, …and nothing…buttons did not turn on or off any of the 3 lights that I had set up.

I started looking into the issue and found these threads. I had already updated the firmware with the latest version I could find (minimote-US-1-19-A) as noted here and the problem persisted - I was about to send the thing back. It wasn’t until I read this that I realized that there was a version 2 of the minimote out there and that perhaps I flashed the wrong firmware. I went back and got version minimote-V1-18-US and updated again. Problem solved and it works great now.

So thanks for at least getting me thinking in the right direction and heads up to those updating the firmware.

Thanks!

p.s.
here is where you can get the v1-18 version of the firmware that fixed my problem with the version 1 minmote (the cheap one!):

http://www.zwaveproducts.com/Zwave-Controllers/Zwave-Remotes/Aeon-Labs-DSA03202-v1-Z-Wave-Minimote.html

Go to the DOCUMENTATION TAB next to the Description and Spec tabs and there is a link to download the file there.

Good Luck and let me know if it works for you.

Cheers,

4 Likes

Thanks MJW … this step really make it works for my case.

1 Like

Just got one of these and its great. I got the v1 as they are pretty cheap (just ordered 2 more) already set up to do 8 different actions dependent on long or short press.

Is there any advantage to upgrading the firmware?

1 Like

If it’s working with ST, you probably already have the newest firmware. I’m of the “ain’t broke, don’t fix it school” for most things. :wink: So if it’s working now, I’d leave it. If it’s not working, flash the firmware.

1 Like

Thanks for that I shall leave it alone as its working great.