Aeon Labs Aeotec Multifunction Doorbell

MP3 version of this…

http://soundbible.com/2084-Glass-Ping.html

It is also very strange the CoRE doesn’t seem to be saving when I edit, even thought it says it did and the Piston view reflects it. I guess what I am saying is that it looks like it save but doesn’t act like it. @ady624

I can’t easily look at it right now so how many seconds does it play for?

1 Like

2 seconds. It is just a ding.

Try a 2 second delay

Just to let you know, I was having inconsistent results with CoRE when using “Set Level” ADD TASK “Play Track”. Now using CoRE’s “Play Track and resume” with consistent results, will let you know if it changes.

Also, should I add a “Poll” action? I noticed when the OEM doorbell button is pushed, it also Polls. Thanks :sunglasses:

If you switch to my other DTH for this device (Aeotec Doorbell), you can use the Play Track at Volume command in CoRE and it will automatically set the volume, play the track and then restore the volume.

If you do switch to the other one, you may have to change some things because it uses “switch.on” to detect/ring the doorbell instead of button 1 pushed.

You may also want to try the other version.

1 Like

Just to let you know, I am currently trying the other version Aeotec Doorbell and it is working very reliably! However, I no longer have the use of the OEM button for other uses since I’m using a door contact mod.

I’m considering switching back to the Multifuction version to get the switch back. I don’t think you can add that into your new version and still hope to have it published. Is it possible to put the reliability of the new DH into the Mutifuction DH and keep the silent switch? :sunglasses:

Have you tried subscribing to the switch event or does it have to be a button?

To prevent it from making noise, just set the doorbell track to track 1 (assuming it’s a silent track) or set it to a track number that doesn’t have a corresponding sound file.

While fixing the Aeotec Doorbell DTH, I figured out some things that will allow me to eventually make this one more stable, but I just got an Amazon Echo so for a while, I’ll be spending most of my time playing around with that.

1 Like

You will have fun with her :wink: I have an Echo, Tap and Dot. I have become dependent on them for ST command, routines with virtual switches, music and shopping lists. I did have to name the bedroom to Echo, GF didn’t like me calling another girl’s name in there (it also eliminates one hearing the other). Heck, they kept Hue control working when ST had it’s recent meltdown and lost my bridge.

I will play around with the Aeotec DTH some more and let you know if the button is able to be used in CoRE.

I need help again. Before I updated the device handler to the latest version, I removed the doorbell from my list of devices so I could do a “fresh” install. I then updated the DTH, and tried to add the doorbell again, but now it can’t be added at all! I have a minimote, and was able to pair the doorbell that way, but it paired as a thing not a z wave switch. I changed the DT in the IDE and it shows the doorbell as Offline in the App and Not Present in the IDE. Now the only way to include/exclude is through the minimote, and it only pairs as a thing. It will not pair through the ST app anymore. I did a general device exclusion, and excluded succesfully through the minimote (only way I could get it to work), but like I said, it will no longer pair at all now. Any ideas?

Install and publish my other Aeon Doorbell DTH as a new DTH, unpair the device, and then hold the action button on the device for about 25 seconds to do a factory reset.

Use the SmartThings mobile app to pair it, don’t use the minimote.

Thanks for responding. I did the factory reset, and am trying to pair through the ST app, but it won’t do it. One press, two presses, multiple presses, next to hub, away from hub, no difference, it won’t pair.

When you choose “Connect New Device” in the mobile app, does it get stuck on the “I’m looking for your new Things…” or …?

I got it. I removed your DTH from the IDE, then it paired as a z wave switch again. From there I added your DTH back in, updated the device from switch to your doorbell, and it works again! Thank you my friend.

I’m just curious, did you try my other DTH like I originally suggested or did you just do the factory reset?

I did indeed try the other like you suggested, but switched back to this one so I can use the button that came with it, and Speaker Notify with Sound.

If you combine the DTH’s, please leave those two capabilities.

Do you have hub v2 or are you still on v1?

V1, but I do plan on getting V2.

I was wondering if you’d be willing to remove the device again, remove the multifunction DTH, install the latest version of the Aeotec Doorbell DTH, open live logging, try to add the device again, and if it doesn’t work, send me the live logging output?

If you’ve already added the device to SmartApps and that would be a big hassle, could you at least open live logging, open the device preferences from the mobile app, press done, and then send me the live logging output?

Thanks

I would love to, but will be “away” for the next two weeks. Sorry. :airplane_departure: