Aeon Home Energy Meter v1 -- Read Clamps Separately

I’m having the same issue. It’s showing same watt value in the bottom left/right as the total followed by an accurate timestamp.

Have you figured out a resolution?

Spent some time with the code and fixed the issues. I also set up the Line Voltage Value and Line Names as user preferences to avoid multiple handlers for more than one instances of deployment. I think I broke the Cost and kWH tiles but I’ll take a look at those tomorrow.


1 Like

Thanks!! Will update and try this today. Very cool to have this so customizable from the app.


Updated to your new version, edited settings to set the voltage and name the clamps, but for some reason the device page isnt updated when I return to it from settings in the app. The two clamp boxes are empty (no name/no usage) and the Total box shows “Total 10 watts.”

Thinking I may have to exclude and re-add the device to clear the cobwebs out.


I excluded the HEM, then added it back to the network and immediately changed the DTH to the updated (Omyn) version. Shut down and restarted ST app, and new DH is active for the device, and I hit Reset and then configured clamp names, voltage to 120, and set reporting to 5s.

The two clamp fields still remain blank (no clamp label or energy reading), total watts shows “Total 10 watts” and doesn’t change when I turn power on/off on the monitored device (washer).

Just for kicks I changed Voltage to 240 for a bit and the watts reading doubled (10 to 20) but nothing else changed, changed back to 120 and went back to 10 watts.

Any idea what’s up? Events log below for device

Hm… not too sure yet. I bought 5 of the power monitors to monitor high usage appliances at the breaker. So far I have 2 configured physical and both are working with the updated code. I also don’t have too much experience (less than 12 hours) programming in smartthings or parsing zwave so I’m kind of winging it there too. It looks like the issue, based on the event log, is it’s not sending the L1 and L2 wattage and if it is, it’s not sending it in an expected format.

Have you let the device sit for a bit in order to catch up with itself? I found sometimes it takes some time for that to occur. Also, try sending a higher load through the wires than 10 watts combined. All of my test lines have >100W loads while testing.

1 Like

Thank you. It’s been running all morning. So far it’s still showing the same reading as previously.

When I get back home, I’ll run a load in the dryer and see how that affects things. thanks for your help really appreciate it.

I think I accidentally copy and pasted a incomplete version of the code. I guess that’s what I get for working until 6AM on this…

Try this:


Thanks! I’ll give it a try now.


A little better results in some ways, but not quite there yet.

I can see results for both clamps now, but a few weird things still:

  • Clamp labels don’t appear - they are there (I entered them in settings and can see them in device info in IDE) but don’t appear in the device screen in the app.
  • Readings are still a little funny, see screen shots. The readings don’t seem to update when things change (turned off dryer on clamp 2 about 20 minutes ago and clamp 2 still reads 506 watts (though total current reading is 5, which is accurate). Is the last clamp reading supposed to persist?

It’s odd that it works for you and the same code won’t for me. For all we know this is an issue w/my meter and not your code - maybe we should wait until someone else tries it to confirm this isn’t a “just-me” issue.


Yes that is the correct device handler name. When working correctly, the bottom row should have a reset/refresh/configure button as shown in the original post but it seems to not be working properly. :frowning:

-Based on my understanding of how this code works, no. The voltage setting applies to both clamps.
-It’s certainly possible, but it would require a coder and I’m a far cry from a real coder. :wink:

Hi Omyn – Unfortunately it appears that this code is officially broken based on your and others feedback. I’m updating the original post as soon as I submit this reply. :frowning:

Omyn, thank you for taking the time to modify the code. Personally I’m not a programmer and simply borrowed the original code from another author (credit and links in the OP) so you’ve done us all a favor here. Thank you! :slight_smile:

Dana, I’ll go grab my HEMv1 and try this code and see what result I get. Just have to go find it and get it wired up. Will reply once done with what result I get using Omyn’s code.

1 Like

Great, thanks!!

No worries. I’m not really a programmer either and your commit was a great starting point. I was able to get this code to work on all 4 of my HEMv1’s. I may order a couple more to monitor some additional devices/zones that I’m interested in tracking. Cold weather is making my usage numbers scary…

Progress so far:

1 Like

Congrats, and…dammit, why won’t mine work!? :wink:

Hopefully @Jmtyra’s test will help me figure out why it won’t work for me.

I also have another HEM arriving this weekend (I think) so will have an additional device to test with.

Oh, and that installation is sweet, @Omyn! Gonna have to fly you out to make mine look so pro.

1 Like

Agreed. That’s a very nice setup @Omyn.

@Omyn NICE! That’s a clean setup, especially the 4-port USB hub for powering the devices. :smiley:

@Danabw So I tried the DH code that Omyn provided and it worked for me, although I did get a ‘null’ error if I didn’t manually set each variable. For example, if I didn’t set a name, I got:

Once I set the line 1 and line 2 variables, it gave me this:

And finally after setting the cost per kWh (even though 0.16 was already there):

Granted there was some “weirdness” with the variable names but I believe this was because the device was previously being used with a different DH (it would randomly show ‘Dryer’ instead of ‘Light’). So you might want to fully remove your HEMv1 from the hub, login to the ST IDE and remove the other DH, re-add the HEMv1 to the hub and re-assign it to Omyn’s custom DH. Then manually set all of the variables within the app and see how it goes.

Also, based on your phone screenshots I assume you’re using Android, correct?

1 Like

Great, thanks for the feedback, really appreciate it!

Yup, Android, correct guess. At a concert with the wife so I’ll have to wait to tomorrow AM to play, but I’m sure with this info I’ll get it working.

Thank you very much.

Awesome! Glad to see it works for you. I plan on cleaning up the quirkiness of the code once I get some free time. The code provided above sufficed as a proof of concept to justify setting everything up physically and potentially purchasing more HEMs…

I also need to see if there is a way to treat the 2 values as separate energy sensors from the viewpoint of things like SmartTiles. For example, I can only add the sum of both clamps as a tile. Ideally I would like to have a home energy dashboard where every value is it’s own tile in cases of where I’m using one HEM to monitor two devices.

Any thoughts on this?

Check this code out, dual clamp also, fires triggers of each clamp.


OK, now I’m pissed.

I excluded and re-added the HEM. Then immediate assigned the updated DTH.

Went to device screen in ST app and configured every setting.

And I still get below. It’s like I have a different DTH or something.

I even re-did the copy/paste of the code again into my IDE, just to make sure I had the right code.

So bizarre.

My settings (entered and re-entered).

Are you running on batteries? It does take awhile to populate the screen if you are. Try plugging the HEM via USB and it should start reporting much faster.

Thanks for the idea. Unfortunately I’ve been on USB power the whole time.

I just excluded it again, reset the HEM (10 sec holds action button - I actually did 20s).

Then re-added to my network and I’ll look at it tomorrow. Need to spend quality time now banging my head against the wall. :wink:

Same results/issues as above in terms of what the HEM reports. I’m going to put this one aside and wait for my other HEM (arriving Tuesday) and try with that one. This one clearly does not want to play with me! :slight_smile: Thanks for all the help.