ADT Hub - Workaround Needed to add Geopresence arming


(Ryan Guinn) #1

Hey People that are Smarter them me i need some help.

I am looking for a workaround for the activating the Alarm based on Geo Location.

when my wife and I phone have left home I want it to auto-activate the alarm just like SHM works.

Please help


(MarkTr) #2

Others are doing this using WebCore - see here:


(Ryan Guinn) #3

Thanks I’ll take a look


(Christopher) #4

I can confirm it works nicely with WebCoRE.


(Ryan Guinn) #5

Thanks I got it installed I just need to learn how to make it work or find someone with the code I can uses


(Brandon) #6

Sorry to revive this thread. I have searched and searched but I can not find an answer. How do you get the panel to show up in webcore? It does not show up as a device in my environment.


(Christopher) #7

Make sure you make the device available in the WebCORE smart app inside of SmartThings. Once it’s enabled there, it will show up in WebCORE as “Smartthings ADT Panel”


(Ryan Guinn) #8

You have to add the panel took me some time to figure out it’s listed as a tamper sensor. I still learning so if it’s listed somewhere else please let us know


(Brandon) #9

Thanks @Ryan_Guinn @seeharrison. I did find it. It is located in the webcore smartapp settings>available devices and contacts>available devices>Which battery powered devices.


#10

hi need help. i configured to change ADT Panel when SHM monitor changes. ArmStay and Armawy is working. When i disarm in SHM it is not disarming in ADT. May be i am not using right parameter value for disarm. if any one help much appreciated.

Please find the webcore i created


(Christopher) #11

Try using disarm(); for the parameter. That’s what I’ve got and it works fine.


#12

i tried with parameter disarm(); also disarm(‘disarmed’) it is not disarming when i disarmed from shm.

can you share your screenshot if possible
thanks,