Adding AEOTEC Range Extender 6 (zwave plus)

If you can get it cheaper than a pocket socket, then, sure, you can use it. But it’s no different then a pocket socket in terms of its repeating capabilities.

I can almost always find a less expensive pocket socket. Zwave products has one right now that’s eight dollars, although it’s classic zwave, not Z wave plus.

Monoprice Typically has one that includes a dumb USB port at the same price as the Aerotec extender:

I expect ring will probably add one for their security system later this year.

So it just depends on what you can find. But I’d rather have the switch options.

1 Like

I started my Smart Things setup about 9 months ago.

I bought a Samsung Smart Outlet for my Schlage, only to find out this week that the outlet didn’t support Z-Wave.

So I bought an Aeotec Extender. After having some (or numerous) random attempts, I got mine to pair with my v3 hub.

The Extender shows on the Samsung API website.

But then I unplugged the Extender to place it where I want, and there’s nothing on the Extender that shows that it’s working. I was expecting a green lit LED on the button or something.

Help? anyone?


If it’s on your network, it’s repeating. It’s really that simple.

Note that since you moved it physically, you should run a Z wave repair utility so that other devices on the network will be aware of its new location. :sunglasses:

I tried to add one of these yesterday multiple times, even 6 feet from my hub and it doesn’t show up…I’ve reset it twice, I’ve made sure it was excluded (how did it get included in the first place??) and it still doesn’t show up as added anywhere…the smartthings app stays at 30% of adding it. Any thoughts on this?

Not to beat a dead horse, but… I’m having the exact same problem! Per the Aeotec instructions, I first tried pairing my Aeotec Range Extender 6 (ZW117) at the location where I intended to use it. After multiple attempts, I determined that that wasn’t working. So … I moved it closer … and closer … and closer … to the SmartThings v3 Hub. Still no luck! Eventually, I tried pairing them with the Range Extender about a foot away from the Hub. No dice! Then, I remembered an article JD had written which discussed the internal placement of both the Z-Wave and ZigBee antennas in the ST Hub and the implications of same, so, in frustration, I tried pairing the Extender from all four sides of the Hub from various (fairly close) distances. Again, abject failure in all attempts!

BTW: I have successfully paired various other Z-Wave and ZigBee devices to my SmartThings v3 Hub, and everything works just great. So much so, that I have just launched in Phase 2 of my Smart Home project.

Now, I know JD IS NOT a big fan of range extenders, and I DO UNDERSTAND that any powered Z-Wave device will act as a repeater/extender; but sometimes Z-Wave Range Extenders do have their place as mentioned in some earlier posts to this conversation. In my own application, there is an existing dedicated duplex receptacle, that powers ONLY the wall wart for my SOHO phone system, which is located almost exactly midway between my Hub and two Z-Wave switches that, because of distance and intervening walls, seem just out of range of the Hub. (The receptacle is exactly 21’4" from the HUB with only air separating them and the phone system is about 7’ away from the receptacle on the floor above.) Because I don’t want to take a chance that the phone system might fall victim to some Z-Wave anomaly, I DO NOT want to replace the standard duplex receptacle with a Smart Z-Wave receptacle. Also, the phone system is all hard-wired, so there is no RF/EMI zinging around in that area.

After putting the Hub in pairing mode and pressing the button on the Extender, the LEDs on both the Hub and the Extender began blinking appropriately and the SmartThings app on my phone indicated that pairing was “30%” complete. Unfortunately, that little circle in the app never advanced past “30%” in any of my numerous attempts to pair these devices, and each attempt eventually timed out and the app told me that the attempt had “failed.”

Between pairing attempts, I meticulously followed the Aeotec instructions and suggestions from this blog regarding excluding the Aeotec Range Extender 6 from the network and also returning it to its factory settings.

During my various attempts at pairing, at least in my interpretation of the color and the blinking pattern, the LED on the Extender indicated that the Extender HAD PAIRED with the Hub. However, when I reviewed the devices connected to the Hub, the Extender was not listed among them (and I tried accessing the list of paired devices in various ways). Interestingly, when I went to “exclude” the Extender from the network to which is wasn’t paired before attempting another pairing, the app detected “one device” and eventually SUCCESSFULLY removed it from the network. What the heck?!?

During my numerous attempts to pair the Extender with the Hub, I tried all combinations I could think of to exclude the Extender, not exclude the Extender, reset the Extender to factory specs, not reset it, move to different distances and angles from the Hub, etc., etc., etc. I met defeat at every turn!

I even tried pairing the Extender to the Hub in “secure mode,” even though I know the SmartThings v3 Hub (GP-U999SJVLGDA) does not support the S2 security protocol. While attempting this “secure pairing,” I had a brief glimmer of hope. After pressing the LED on the Extender twice per the instructions, the Extender began blinking blue instead of green, briefly went out, then intermittently glowed blue again a few times over the course of about two minutes, then switched to blinking green, and eventually timed out again as before.

During all of my pairing attempts near the Hub, I was able to observe the blinking green LED in the Hub which confirmed that the Hub was in pairing mode. When the app timed out on my phone and stated that the pairing attempt had failed, the green LED on the HUB simultaneously stopped blinking and turned solid green.

I would greatly appreciate any and all knowledgeable suggestions as to how to successfully address this frustrating dilemma before I resolve this matter myself by taking a ball-peen hammer to my new Aeotec Range Extender 6 (ZW117)!!!

1 Like

Which version of the SmartThings mobile app are you using?

FAQ: how to tell which version of the SmartThings mobile app that you have

And did you run a Z wave repair after you added it? And if you did, what error messages did you get?

I am currently running Version 1.7.36-23 of the “SmartThings (Samsung Connect)” app on a Google Pixel 2 XL phone. According to the naming convention you suggest, this is the “V3 app.” I have this app set to “Auto update devices and services” automatically on my phone via WiFi. This app also states, “The latest version is already installed.”

I did not run a Z-Wave Repair after I attempted to add the Aeotec Range Extender 6 (ZW117) to my network because the SmartThings v3 Hub never did detect and pair with the Range Extender. Therefore, it was not in my list of connected devices in the app and was not available for repair in the network.

I am still a bit puzzled as to why, if the Range Extender was not reflected on the list of connected devices in the app, and I could not otherwise locate it anywhere else within the app, it was apparently repeatedly detected and successfully excluded numerous times when I initiated that process.

Do you have contact info for anyone in the tech department at Aeotec/Aeon Labs with whom I could speak to resolve this issue? I did identify three telephone numbers through Internet searches that were supposedly associated with that enterprise, but I quickly determined that none are currently working numbers.

OK, that’s the newer app. It still doesn’t support all the same devices that the older classic app does, so quite a few people are using both. You could try adding it through the classic app and see if it works that way. Once added to your network it will then appear in both apps.

As far as contacting aeotec, I don’t have any special information. The URL for their support channels should be listed on the user guide for the device. If I recall, they only take email, because their English isn’t always great.

Also note that the “repair“ process applies to your entire Z wave network, not an individual device. It just would’ve been interesting to see if you were getting any error messages there. But it’s not important.

Hmmm… Now that’s a thought! I never considered trying the “Classic” app on the premise that “newer is better.” I’ll give it a shot when I return home on Monday. Thanks for the suggestion.

1 Like

Just for the heck of it I’ll give the Repair process a try too. Thanks!

1 Like

Curious how this turns out for you. Seems like a bug in the app or hub? UI shows 30% but then later I can remove it? Since I had the same thing happen, I’m suspicious.

I am having the exact same issue as @BillZ and I am using the Classic app. Exactly the same, I try and pair the extender, the ST app never confirms pairing, but the LEDs on the extender confirm pairing and then I AM able to exclude the extender afterwards (app says an ‘unknown’ device was excluded).

Amazon tech support had me do a firmware upgrade on the extender but that did nothing (the firmware upgrade was a very complicated process requiring an Aeotec Z-Stick which Amazon sent me for free even though it cost double the extender!).

I give up.

maybe @Kianoosh_Karami can help us out

Are you aiming to use a custom DTH for the Aeotec Range Extender 6?

FYI: FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH

No, just trying to add it. It goes to 30% and just stays. I never see the device in my list but if I use z-wave exclude, it drops one device.

I guess I do have some custom DTH’s for the Iris z-wave extender but that shouldn’t be the same id as the aeotec, right? or wrong?

I have spent the past few days making additional attempts to pair the Aeotec Range Extender 6 (ZW117) with my SmartThings v3 Hub (GP-U999SJVLGDA), each time with less and less enthusiasm.

I have tried everything suggested … and more! NOTHING HAS WORKED!!!

I tried pairing (as did @dworkman) a number of times using the SmartThings Classic App. Each attempt to pair failed. I found using the Classic app in this application more problematic than the newer SmartThings app. I can see how the Classic app might appeal to those trying to set scenes, etc., but I failed to see how it would be helpful in pairing a device released well after the Classic app was replaced by the newer one … but I tried it anyway.

Then, as luck would have it, my Lutron GL-1000 (dumb but, until now, reliable) Dimmer controlling the kitchen lights failed on Tuesday. I took this opportunity to purchase and install a GE/Jasco #14295 In-Wall Smart Dimmer, as doing so would possibly obviate the need for a Range Extender by placing this powered Smart Dimmer (sort of) close to the location in which I had initially intended to install the Range Extender. Doing so would also allow me to implement the numerous suggestions to use a powered Z-Wave device as a repeater/extender instead of a dedicated Z-Wave repeater/extender which served no other function.

This Smart Dimmer is located about 11’1" from the ST Hub and 12’6" from where I would like to place the Aeotec Range Extender 6 (ZW117). Both the ST Hub and my ideal location for the Extender are in the basement, but mounted to the floor joists for the kitchen. Other than plywood, hardwood flooring, and drywall, there is nothing mechanical, electrical, or electronic in the intervening distances that might block the Z-Wave signal.

The whole point of my wanting to install a Z-Wave Range Extender was to enable the pairing of two (2) GE/Jasco Z-Wave #14292 In-Wall Smart Switches mounted in the mud room, adjacent to the kitchen, that seemed just out of range of my ST Hub. They are located approximately 34’ from the Hub, but with a greater number of walls and a tile floor intervening. Although my original location for the Range Extender in the basement just under the kitchen floor would have been more equidistant between these two (2) Smart Switches and my Hub, I figured that the location of the Smart Dimmer was close enough for government work.

The GE/Jasco #14295 In-Wall Smart Dimmer paired with my SmartThings v3 Hub without incident. It is located about 11’1" from my ST Hub and 20’10" from the two (2) Smart Switches in the mud room.

N.B. Any discrepancies in these measurement noted by those trying to add up the various distances I give are the result of devices mounted at different elevations (floors).

The two (2) Smart Switches in the mud room are mounted in positions #1 and #4 of a standard 6-gang electrical switch box, so they’re about 5½" apart. The other devices mounted in this switch box are normal old S.P.S.T. Leviton toggle switches.

This is where things get more interesting (frustrating)! … and also explains why I have been emphasizing that there are “two (2) Smart Switches” in the mud room that I am trying to pair with the Hub.

Initial attempts, made about two weeks ago, to pair either of these Smart Switches to my ST Hub failed, probably because of distance and intervening building materials. On Wednesday, when I tried pairing the Smart Switch in gang #4 with the Hub, probably routed through the newly-installed Smart Dimmer, it paired with no problem. However, when I then tried to pair its neighbor in gang #1, the pairing failed. Numerous additional attempts to pair this Smart Switch with the Hub also failed. Now, remember, this second switch is about 20’10" from the powered & paired Smart Dimmer and 5½" from the powered & paired Smart Switch to its immediate right. (Comments also welcome on this situation.) Oh, well. Back to the Range Extender.

Thinking that there might be some sort of manufacturing glitch at play here, I went out and purchased four (4) more of the Aeotec Range Extender 6 (ZW117) from two (2) separate sources. All five (5) failed to pair with the ST Hub despite numerous attempts to do so. In each instance, the ST app initially indicated that pairing was “30%” complete, then eventually timed out and stated that the pairing attempt had failed.

Per @JD’s suggestion, I ran a “Repair” function on my ST network. The only information revealed at the conclusion was that a Smart Switch in the living room (which is at the total opposite end of the house from the kitchen) was unable to establish a new route to the Hub. Since the Smart Switch in the living room has been working perfectly for the past few weeks, I didn’t think that this notification was of any consequence.

Per @Kianoosh_Karami’s question, there is no “custom DTH” installed on the Aeotec Range Extender 6 (ZW117). All I want it to do is extend the range of my Z-Wave signal from the Hub in the basement to the Smart Switches in the mud room.

(And, please, don’t anyone get hung up on the fact that the Hub is mounted in the basement; it’s only about 11" below the wooden floor above.)

I am reaching out to the folks at Aeotec (Aeon Labs) regarding the above issue with their Range Extender, and will let everyone know what they have to say.

1 Like

HOLD THE PHONE!!! After posting the above comments to this conversation, I was inspired to go to the mud room and make another attempt to pair the remaining unpaired GE/Jasco Z-Wave #14292 In-Wall Smart Switch with my SmartThings v3 Hub. I followed the same process as I did on Wednesday,; however, this time the Smart Switch paired immediately! It must be the phase of the moon or something!!!

This successful pairing of the two (2) Smart Switches in the mud room eliminates the need to pair the Aeotec Range Extender 6 (ZW117) with my SmartThings v3 Hub. However, as a matter of principle, I will continue attempts to successfully do so and advise results.


Would you please send me your hub ID to me via PM?

1 Like