ActionTiles Weather Radar and Traffic Information

Omaha, NE.

Wow yeah… tuff!

https://meanstreetsoma.com/omaha-area-traffic-cameras/

So I copied a couple links from here and pasted in my browser and hit refresh a few times. It refreshed.
So many cameras in that area are down or borken link or whatever.

But yeah… pasting those URLs in a tile with maybe a 10 second refresh rate might get you what you at least some sort of result.

That same technique seems to work from here: https://hb.511.nebraska.gov/#cameras/search?layers=cameras&timeFrame=TODAY

On my tiles, from some sources, I have to modify URLs a bit…

for instance:

http://www2.dor.state.ne.us/webcams/newimages/vid-US75-66Platts.jpg?1493919426293

a link like that may work, but sometimes it quits working, but works better for me if I remove the numbers after the ?, like
http://www2.dor.state.ne.us/webcams/newimages/vid-US75-66Platts.jpg?

ITt’s been a bit of experimneting for me

Hah yeah it’s weird that they aren’t streaming and half of them are down. Thanks for looking into it for me, the links you provided were better than the local news ones that I found.

1 Like

Any ideas on Northern VA? I found the site and entered the urls and everything worked perfect. Then 20 minutes later they all stopped video feed. It seems that the system will not let you stay on the cameras all day. I think it assigns a key to the ip and after 20min or so it kills the key. Any suggestions? Here is the site http://www.trafficland.com/city/WAS4

and here is a camera url, notice it says pubtoken I think that is the issue.

http://ie.trafficland.com/408025/full?system=trafficland-www&pubtoken=f23d47d86f0ac4bc7c6e6912b998b82dafb2557388aa74f957b4aa997a5398a4&refreshRate=2000&cache=62336

2 Likes

Great stuff, guys! Thanks for helping each other out. :grinning:.

A few links worth exploring (from ActionTiles’s Forum, etc).:

2 Likes

Anything happen if you dump the cache part of the URL? I tested that it loads… otherwise I’m not sure what to do… NOVA seems to keep pretty good control of their cams!

just set it up, watching it now, will let you know what happens in 30 minutes.

@tgauchat Question for you, last month I could not access AT from work and now I can. What did you guys change? I am asking because I want to access webcore and I cannot and am hoping you guys did something that ady624 can do?

You’re the second person to mention this, and I guess it has to do with some sort of firewall or web filtering implemented at your workplace.

There is a very slight possibility that some random networking change I made and don’t remember, (and didn’t document, shame on me!) may have done something; but that’s actually unlikely.

More likely is that the web filter used by your company receives a periodic “whitelist” database update, and ActionTiles.com finally got whitelisted through whatever automatic algorithms are used to determined safe / acceptable websites.


If you can please ask your IT department what web-filtering / firewall / virus protection brand(s) they use, that might be the clue to figuring out how to request whitelisting from the vendor.

My messages come up as SmartFilter … which looks like it’s owned by McAfee now

1 Like

yeah, if I do that they will question why I need access to that at work. I work for one of the largest telecom in the world. All I can tell you is when I try to access it, it says website blocked, category none.

Mine is 100% in house designed.

Dang, I thought I had it, 30 minutes exactly and there goes the traffic cam, this stinks.

Trying to input some weather and or traffic cams. For the life of me I can’t figure it out. I created a media action tile using various urls I got from various post but this is all I get on all browsers I have. What exact url am I looking for?

.1. Please include the full text of various URLs you’ve tried so we can check them and possibly make small edits. When posting, surround the URL with single back quotes to prevent expansion:

https://www.ActionTiles.com

.2. Weather URLs are not “video streams” Media… Always select “This Media is a still image or GIF” (unless it is a real live weather video camera).

So the traffic or weather formats that refresh every 10 or 20 seconds select as gif’s?

Do I just highlight the browser address and input into this location?

Do you happen to have a link to any feeds anywhere that you know work that I can just try for testing?

The Weather GIFs Topics in our ActionTiles Forum has a lot of examples and folks answering questions…

Here’s one that I know works on Windows Chrome; but

  • Works in Silk on Fire Tablet.
  • Works in Fully (on the same Tablet)
  • does not work on Android** when placed on a Panel (only the media preview works), in neither Chrome nor Firefox; One (likely!) problem may be that Chrome is blocking non-SSL (https) on our SSL protected app.

http://images.intellicast.com/WxImages/RadarLoop/usa_None_anim.gif

So we are aware this is an area of ActionTiles with complications and/or bugs.
This is not a high-priority to resolve because there are workarounds … i.e., use a different browser; possibly edit site settings to allowed “mixed content” (SSL + non-SSL), etc.

VICTORY…yusssss this is so sweet. Thanks for the guidance and can’t wait to set up a weather traffic panel.

It came down to finding the right gif online. But your instructions helped me out. Time to find a good traffic cam up in the NW

Oh ya I’m using a galaxy tab A on chrome and the standard Internet it comes with.

1 Like

Test the URL for any weather or traffic images in browser, it should show the image, if not it probably won’t work in ActionTiles

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.