Access denied - don't have authorization to edit devices


For some reason that I can’t recall anymore, when I started with ST I created my account on I’ve been using this IDE url since then, but recently I started having the following issue when trying to edit any device:

The only workaround I found so far is to launch the IDE using incognito mode. I’ve tried clearing cache, local session, everything on my browser, and I just can’t make it work.

Considering this issue, I’m thinking if this is the right time to start using the more global URL: . Does anyone know the difference between this and the one I was using? Also, is there any easy way to move my Home and Hub/Devices from one IDE to another without reconfiguring everything?

Any help would be appreciated! Thanks!

try using an incognito/private tab in your browser when logging into IDE. also, good to login at :slight_smile:

I did. I mentioned that this is my current workaround. It’s just not convenient, and besides that I want to understand the difference between these URLs and if I should go to a more “global” one. is the URL that will forward users to their appropriate shard. In your case, it appears it is NA04.

the graph url was the original url when there was only one shard but it does not automatically forward users to their shard so it can cause problems. You can get around that by clicking on Locations when you login and selecting your location. But again, not recommended because most users don’t realize they are on the wrong shard by default.


I actually tried a bit more based on your comment and I found a way to fix my normal browser. Thank you for that!
Basically, I cleared all cookies related to and After that, I went to the regular URL, clicked to sign in, and it redirected to to login in[...]. I manually removed the “us.” from the URL, forcing it to go to After that, I can finally edit my devices without going to incognito!

For the shards, I didn’t know how that was called so I couldn’t find much information here. I guess now it makes sense and there’s no problem to stick with my -na04-. Thanks again @jkp.

1 Like