Zigbee Discovery not triggering on Built-in TV Hub (April 2024)

I’m facing a similar issue, however for me it’s the zigbee-drivers that don’t scan. After I removed the single default lan-driver: “Hue”, the log is completely silent.

1 Like

Hi, @annitya. Welcome to the SmartThings Community!

I moved your post because the other thread was a year old, and the issue might be different now because we haven’t received more reports about this recently.

So, the LAN driver “Hue” is pre-downloaded in the Hubs because unlike the Zigbee and Z-Wave devices, it doesn’t have a fingerprint that can be identified as a match when trying to onboard a Hue device to be downloaded on demand. And, every time you start the “discovery process” in the Hub, you’ll see this driver starting, that’s why you stopped seeing it when you uninstalled it.

So, are you trying to onboard a device?

If you’re logging all the drivers’ events, and you have devices already using them, you should definitely see activity there, have you tried changing one of those device’s state?

Hi!

Thank you for your reply and for fixing my messy post! :slight_smile:

I tried for days to pair a couple of sensor from Nedis/Aqara. I read that these sensors occasionally were difficult to pair, but usually people would get them working.

What bothered me the most was the utter silence of the logs. Apart from the Hue-driver logging like its life depended on it, there was no information regarding my zigbee devices.

I removed the Hue-drivers to clean up the logs and then there was nothing. Not a single line. I have no idea if the builtin tv-hub is even scanning.

The lack of information bothered me so much that I acquired a zigbee-sniffer. Unfortunately I bought one pre-flashed with the wrong software. It turned out to be a hub instead.

At the moment I’m running Home Assistant. Installing it on WSL was horrific, but at least the devices paired on the first attempt. I also got some much wanted logs during the process.

That being said, I would prefer to use the Samsung-ecosystem if possible. Self-hosting is a lot of work and SmartThings from Samsung seems pretty nice.

Hey there,

Before we dive into troubleshooting, could you provide some additional details?

  1. If you’re unable to replicate the issue, could you let us know? If you happen to encounter it again, please provide us with the timestamp when it occurs.

  2. Also, could you kindly confirm the exact model of your Nedis/Aqara sensors?

  3. Additionally, we’ll need access to the hub logs to investigate further. Could you please enable support access to your SmartThings account? Here’s how:

    • Go to the SmartThings Web (my.smartthings.com)
    • Log in to your Samsung Account
    • Select Menu (⋮) and choose Settings
    • Toggle on Account Data Access
    • Select the time period and confirm. Please choose “Until turned off”. Once our team finishes, we’ll let you know so you can disable it again.

Once we have this information, we’ll be better equipped to assist you in resolving the issue.

1 Like

Access enabled for 7 days. Email address should be the same. Thanks!

2 Likes

Some Nedis devices use the same outer cases as some Aqara devices, but they are different companies and the firmware is quite different as are the fingerprints.

Most nedis devices use Tuya firmware, which can be quite tricky to get to work with SmartThings. If your devices say they use the “Smartlife“ app, then they are using Tuya firmware.

If your devices are Tuya based, start with the following community FAQ, and it may help.

FAQ: Using Tuya Zigbee Devices Directly With a SmartThings/Aeotec Hub (2024)

If they are actually aqara devices, then it should be much simpler and you just have to find an edge driver with the correct matching fingerprint.

2 Likes

When you say “built-in TV hub,” what is the model of the television, and do you have the optional Zigbee dongle installed?

Most Samsung smart television models Do have a built-in “SmartThings hub” but it only supports Wi-Fi and cloud to cloud connections. (As @orangebucket Notes below that began to change with a few of the high-end models in 2023 and is supposed to change for a number of other models in 2024, and those will have a built-in/Zigbee Chip. But that’s why the model number matters.)

If you have one of the models that doesn’t have a built in Zigbee radio, then In order to work with Zigbee, You have to add the optional “dongle” device, which has that radio.

In contrast, The standalone SmartThings “station” hub already has a Zigbee and thread radio, and the standalone Aeotec hub has Zigbee, thread, and Zwave.

So as always, even for hubs, the first rule of Home Automation applies: “the model number matters.”

1 Like

I have two devices. One is an actual Aqara. The other is very much a Tuya-device rebranded as “Nedis”.
The TV-model: TQ77S93CATXXC.

“About this TV” lists a mac-address for the zigbee-device and info on my.smartthings.com says “zigbeeRequiresExternalHardware: false”. I would be a little surprised if I did indeed need the dongle.

1 Like

They started including the Zigbee/Thread module in their 2023 range of TVs. Presumably the higher end ones.

1 Like

I’m seeing a few details on that, but not a lot of clarity. :thinking:

Samsung just turned its soundbar into a SmartThings hub - The Verge

The new built-in SmartThings Hub with Thread / Zigbee / Matter support is available on the following models, according to Samsung:
.

I looked at the product page for this specific television, but I can’t tell if it it has The right radio, or not. And the user manual just says that it varies by model. :man_shrugging:t2:

Anyway, if the sensor doesn’t at least add as a “Zigbee thing,” The first thing I would do is make sure that particular television has a functioning Zigbee radio.

Do you know if that shows up in the details on the “advanced“ page for the SmartThings account at

My.smartthings.com/advanced


It does have a firmware-version and zigbeeRequiresExternalHardware: false.

It sure looks, swims and quacks like a duck.

I tried my best to determine if there actually is a zigbee-radio inside, but the information is incredibly hard to verify. The generic manual gave nothing away.

Edit: Smartthings-settings says: “WiFi, ZigBee and Thread Module available.”

1 Like

Agreed— your account definitely thinks the TV has a Zigbee radio. :duck::duck::duck:

If you factory reset the aqara sensor, put it in pairing mode, and then use “scan nearby“ in the SmartThings app, it doesn’t even add as a “Zigbee thing“?

If it doesn’t, there’s definitely a problem because that’s a supported Zigbee device. :thinking:

What’s the model number of the aqara sensor?

Well, maybe… Might just be really unlucky with my choice of devices too.

I bought the last one in stock of the old version: [ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver - #774 by AurElHA by accident.

The model-number is: WSDCGQ11LM. Others in the thread seemed to at least get a “ZigBee thing” though.

1 Like

I believe that model is supported by Mariano’s humidity sensor driver, you should try installing that driver…

I can’t change the driver because none of the devices are detected at all :-/

1 Like

Hey there! It seems like you’re experiencing some issues with the zigbee drivers not scanning properly. To better assist you, could you please follow these steps to generate the hub logs? This will help us diagnose the problem more effectively. Thank you!

Provide the Hub logs through the my.smartthings.com:

  1. In the my.smartthings/advanced, enter “your hubs”
  2. Enter the corresponding Hub
  3. Click on “Dump Hub Logs”
  4. Change the reason for requesting hub logs if needed
  5. Click on “Dump Hub Logs”
  6. Confirm that the request is sumited
    Note: If you have more than one Hub, the name of the one involved in the issue.
1 Like

The logs should be available now! :slight_smile:

1 Like

Hello @annitya ! To move forward. We are continuing to investigate, but if you can replicate the issue and provide us with the exact timestamp along with updated logs from the facility, it would be of great help to us. Thank you!

1 Like

start: 1715631190269 (about 22:00, Oslo-time)

You granted the SmartThings Support team with access to your account for 1 måned on 13. mai. This will expire on 12. juni at 22:16 CEST.
Time Remaining on Authorization: 1 måned.

end: 1715631437597 (5-10 minutes later)

Sorry for the late reply. I’ve been having black-screen issues. Nvidia and Samsung really don’t get along, but that’s a different story.

I tried again to pair the device. Hue-drivers are logging like crazy, but nothing else happens. I first tried “find nearby device”. I then tried “add partner device”, scrolled all the way to the bottom and attempted pairing without qr-code for “I can’t find my device”. Still nothing.

Afterwards I had to re-pair with the HA-hub. Successful on the first attempt.

1 Like