Z-Wave Repair / Mesh Optimization


(Solardave1) #1

Use caution with this newly released feature in the IDE. It appears to be the root cause if a major system upset on my end, lost most functionality, needed to delete and re-enroll half my devices - it wasn’t pretty. Considering how important network optimization is, I’m now n a position where I’m terrified to do a repair/optimize until ST comes up with an explanation on what happened, what is supposed to happen and why what happened, happened. It was ugly. All I got back was basically, yeah it was screwed up but we fixed it, reboot and you should be fine. Sorry, not quite good enough. Not by a long shot. Hy ST - don’t alienate your cheerleaders. It’s easy enough to put the hub back in the box and liven Vera land.


(Chrisb) #2

Did they just recently update/change this? I think I’ve used that function before without issue.


(Solardave1) #3

Actually the button was there in the IDE but didn’t do anything until Friday. I knew I had a problem with mesh optimization and the routing table so it was an issue for me but the repair did more harm than good although I’m now assured the issue has been fixed. I’m just scared to try it - I don’t want a repeat of what happened over the weekend.


(Justin Novack) #4

Give it a shot! Where’s your sense of adventure?

If it doesn’t work, then reopen the case. Worst case, like planets, if you find a bug, you get to name it. :slight_smile:


(Solardave1) #5

I ran the optimization. The logs show some ping activity and some other data but by ST’s own admission, there’s no facility to visualize the mesh or determine the topology and number of hops required to efficiently reach a device. Not exactly a bug but certainly a design issue. So, my system hasn’t crashed, I seem to be able to access my devices, my apps seem to run but I have no idea what’s going on under the hood, or for that matter whether the system actually did anything - for all I know, they turned the function back off and left the button on the IDE screen for placebo effect. I think if you’re going to base your system on z-wave and its clearly a system that’s not a plugs play consumer product, you need to have the tools in place to do the basic stuff, like optimize the mesh and have some indication of the status of a network optimization effort. I’ve never seen a company try so hard to alienate users that are so motivated about their product. This is really frustrating. My Vera’s are starting to look better and better. And what’s up with the app push? Aside from some cosmetic changes, I don’t see any significant anything and it crashed on my 4 times last night and I clicked on “send report”. But if you want an escort in Dehli, he forums a great place to look.


(Duncan) #6

I was just pointed to this topic.

@solardave1 What firmware version does your hub show? Z-Wave Repair was never implemented at all in the currently released hub firmware version.

The button isn’t supposed to show up at all in the Z-Wave Utilities unless your hub is running pre-release firmware, but there’s a bug that is causing it to show up all the time. Sometimes when you try to send a command that the hub doesn’t support the server connection will half lock up and no commands will get down to the hub until it’s power cycled.


(Solardave1) #7

Firmware Version 000.010.00246


(Duncan) #8

Yes, it looks like you got prerelease firmware somehow. Because this is stuff we haven’t finished testing yet, some issues can be expected.

Z-Wave isn’t our system’s primary protocol; it was added to the hub later in development than ZigBee and it’s just now getting to a mature state. I understand it’s frustrating to use our system right now when it still needs so much work, but I hope you’ll have the patience to stick with it and stay optimistic about the platform’s future.


(Solardave1) #9

I’ve been working with Ullman on this. That’s how I got access and last week he wrote to tell me the bugs were worked out and I should be able to optimize.


(Justin Novack) #10

You are newer than I am! I have Firmware version: 000.009.00004, and yes, I have

General Utilities

  • ZWave Exclude
  • Join/Leave another Z-Wave network
  • Repair Z-Wave network

(Solardave1) #11

@duncan - does this mean you’re turning off the functionality that I FINALLY got to work?


(Duncan) #12

I’m not sure what you mean. We’re waiting until 0.10 firmware is rolled out before making a proper UI for network repair with feedback and stuff.

Unfortunately 0.10 still doesn’t send a map of the network topology to the server, but that should be available in the next version.


(Solardave1) #13

What I’m asking is, sine you rolled out v 0.10 to my hub and the optimization appears to work in my environment and Ullman said it should be stable, are you leaving that functionality in my system or doing something to disable my ability to optimize the mesh /routing table?


(Dan Lieberman) #14

@solardave1 – They won’t be rolling back the firmware deployment to your hub unless you want them to, so whatever functionality you have now will continue to work as it does.

I think what @Duncan is saying is that since it’s pre-release firmware, it hasn’t been fully tested so there may well be some issues that pop up.


(Justin Novack) #15

I had to install another Zwave switch (about ~10 feet away) for my furthest device (~30 feet total) to respond more accurately more often. I just did the Zwave repair on the new firmware (Thanks Ryan).

I’ll let you how it goes.