Z-Wave Performance in Cold Weather?


(Mike Coscia) #1

Does Z-Wave performance degrade in cold weather? I have a switch outside that was working perfectly up until yesterday. The switch turns on no problems, but does not turn off reliably. Only change was temperatures dropped at night to mid 20s and it’s only about 35 today. I only installed it a few weeks ago and this has been the first time its been lower than 40 outside. So not sure if it’s the temperature, switch failing, or the recent issues with smart things

I have a rule in RM that notifies when the switch is on or off. It is also delayed by about a minute when the switch is on/off. Does that sound like a connection issue? I have another switch near it and its working fine. I also have a z-wave power plug close by as well. It works fine too, but it’s lagging more than usual.


(Beckwith) #2

I have several outside and don’t see any degradation when cold. Seasonally, however, it is generally better during winter because of less vegetation. Rain, snow and fog seems to degrade the signal to varying degrees.


#3

Check the manufacturer specs, there is a lot of difference in engineering quality between one brand another but it’s usually reflected in the operating specs.

Any battery-powered device will show degradation once you get a few degrees above freezing, but if it’s mains-powered there’s no particular reason why cold should affect an RF device. Just depends on what’s built around it. :sunglasses:

As @beckwith mentioned, weather, however, can definitely be a problem particularly anything that raises moisture in the air. zigbee tends to work a bit better through rain (because it uses DSSS) than Z wave (which uses FSK), which is why more devices intended for outdoors tend to be Zigbee. But if the switch is against the wall of the building that the hub is inside, that won’t likely be an issue.

As for the delay, yes, that does sound like a connection issue. Did you run the zwave repair utility after you installed the switch in its final position so that it would have the correct neighbor tables? Given all the problems with the platform this past week, it may not have built correctly. You might want to run it again.


(Mike Coscia) #4

Thanks guys. JD, this is the intermatic module that I installed a few weeks ago. It worked great up until yesterday. I haven’t changed a thing, so not sure what could be causing the issue. All of a sudden RM started having issues reporting if it was on or not and I couldn’t turn the switch off if it was on. If I open up RM it shows the correct state, but it’s not running the actions for that state.

I noticed all the issues ST is currently having, the site lists degraded SmartApps and Device control. I am hoping that is the cause of my problems and things will improve in the next day or two. I also ordered another dragontech z-wave plus power plug. I’ll put it on one of my outside outlets and see if it strengths the connection and rectify the issue. Just don’t get it, everything was working fine.


#5

Ah, didn’t realize it was the same switch.

It’s probably the platform issues. :scream: All kinds of things going goofy. For example, there is some database corruption which means some rules for some people are now missing pieces.

You can go through everything and repair any problems that you see, and remove problematic devices and re-add them and run network repairs, which might help for well, but then it may just break again. It might be easier to just wait until smartthings says the issues are fixed.


(Mike Coscia) #6

I was playing around with it this afternoon. It just seems like everything is slower. For instance, if I turn on my dragontech power plug in the shed, it lags on the initial turn on/off. After a few on/off cycles it speeds up and works as normal…at least for awhile. It’s the same with the intermatic, but the lag is MUCH worse. Oddly, turning it on always works fine. If I turn it off, it shows its off, but its still running. If I open up the device it also still shows its on. If I hit it on/off a few times, it will finally turn off with some lag. Usually after that, it starts working normally again…for a short while at least. Rule Machine is a whole other story. I have a simple rule that notifies me when it’s on an off. Sometimes it works, but usually it doesn’t. So, hoping its just issues with ST and not my devices or network.

I would exclude/re-include it on the z-wave network to test things out more, but it’s such a royal PITA to remove it from all the rules/smart apps then adding it again. Wish there was an easier way. I’ll just wait a few days and see if this resolve themselves once ST fixes everything.


(Mike Coscia) #8

Seems to be working better today. When my 10am rule did not fire, I deleted it and recreated in RM. Worked with no issues. Also, turning it on/off seems to be working as well.

I did look up the specs for the intermatic and its rated down to -4F. The dragontech, which is basically my repeater for reaching the intermatic, says normal operating temperature of 77F. Not sure if that means it won’t work in colder temps, maybe that is the reason I was having issues? That or it was on ST’s side…who knows. I’ll just have to keep an eye on it.

In the meantime, I need to find a zwave plus device that can tolerate colder temps.