Z-Wave Fingerprinting Problems

I occasionally run into an issue with getting a Z-Wave fingerprint working. Even doing exactly as is stated in the documentation has unexpected results. I have found workarounds up until this point, but am stuck on a device. I have opened a ticket with SmartThings developer support but have not heard back.

No matter what, the device is detected as a Z-Wave Relay. Here is the RAW Description from the IDE:

0 0 0x1001 0 0 0 d 0x5E 0x72 0x86 0x85 0x59 0x5A 0x73 0x70 0x25 0x27 0x71 0x32 0x20

This is what I have for the fingerprint:

fingerprint deviceId:“0x1001”, inClusters:“0x5E,0x72,0x86,0x85,0x59,0x5A,0x73,0x70,0x25,0x27,0x71,0x32,0x20”

Am I just totally overlooking something? Is there anyone else with a similar problem or a solution?


Thoughts here?

1 Like

Below is the fingerprint information for the Z-Wave relay with the same (but fewer) clusters, and for some reason is finding this device handler first during the paring, probably because it’s a ST DH ?!?!

definition (name: “Z-Wave Relay”, namespace: “smartthings”, author: “SmartThings”) {

  fingerprint deviceId: "0x1001", inClusters: "0x20,0x25,0x27,0x72,0x86,0x70,0x85"
  fingerprint deviceId: "0x1003", inClusters: "0x25,0x2B,0x2C,0x27,0x75,0x73,0x70,0x86,0x72"


Have you had success pairing this same device before with your custom DH?

It is a new device, and I have not been able to get the fingerprint to match ever. I have removed it and added it to the network multiple times and every time it is coming in as a Z-Wave Relay. I have even tried giving it the same fingerprint as the Z-Wave Relay just as a test, and it still doesn’t use my handler. I have done many Z-Wave handlers and usually the fingerprinting works as documented. The only other time that I have had problems is with an Aeon Multisensor 6.

Any other advice on this? It seems like a platform bug, but I would love to have a resolution before I post the device handler for this new device. I would prefer for those that purchase it to not have to go through extra steps to get it working. Thanks for everyone’s help!

Edit: Well, it seems like my ticket with developer support was closed as “solved” without any response or feedback. Looking back at some of the other cases I have opened, they have been treated the same way. The problem is that the issue has not been solved. It is still occurring. How do I get resolution on these platform / developer issues?

I’ve been digging into fingerprints as well due to similar issues. From what I read, if there are more that one DTH with matching fingerprints (including subsets of classes), the one with the most matching classes will win, however, if there is even one that is incorrect then it does not get selected. I would review the fingerprint in the DTH for the Zwave relay and you will see it likely shares all the classes with your device. Try to find one for your device that is not listed in the zwave relay fingerprint and add just that. Having one extra matching class should force the system to pick your DTH.

I think I tried adding an extra cluster to the Z-Wave Relay fingerprint, but I will check again just to make sure.

Well, I am not sure if something has changed on the backend, but this device now pairs correctly with the fingerprint that I posted above. Really strange, but I am glad it is working now.

1 Like