WTH happened to my great SmartThings system?

Well… I believe them too.

But, daaammmn this is depressing to hear. :crying_cat_face:

2 Likes

My lights which are mostly GE/Jasco switches or dimmers say “unavailable” all the time. I then have to go in on the App and refresh, press on/off multiple times to get it working again. Sometimes I do have to unplug. And my Evolve garage door opener stopped working completely so I had to delete it and re-add it. Problem is my system now won’t detect it so I cannot even use it anymore. This also happened to a wall dimmer switch of mine. My two thermostats once were rock solid now aren’t reliably responsive anymore.

And this “unavailable” message happens multiple times a day. It’s frustrating and support hasn’t helped. This has been my experience the past couple months.

You’ve probably already tried this, but just in case, have you tried turning off the device health check? That’s a fairly new feature, and it has caused some problems for some people.

2 Likes

Turning device health offmdefinitely stablized my system. With it on my ST motion sensors kept disconnecting… and I had to readd them.

3 Likes

My issues with device health has been with mosting z-wave going offline but it is zigbee devices more often. But it is more than just devices going offline, the system is just randomly goes slow on smartapp execution some days, I have had routines have devices go unselected (like it used an old configuration maybe?), Smart Home Monitor randomly lost its audible sound notification for alarm, etc It has just been a big bag of random and annoying issues that I am just riding out to see when it gets stable again.

Edit: 06/10 Device Health turned off yesterday, as of today I now have another simple SmartLighting automation that didn’t execute automatically from motion (it is my “canary bird” that shows me daily how slow an execution is occurring with ST, and 4 more zigbee GE bulbs that went offline and not able to control them from ST mobile app and a Schlage 469 lock that “died” out of three of the identical Schlage locks and failed in a Good Night routine to lock down. I need to reset each of the Ge Bulbs and then do a “Add a Thing” to do a “hot add” so the good news all my existing smartapp do not have to be reconfigured. All zigbee devices get rediscovered and connected with the same networkID again. It still annoys that all my 11 GE zigbee bulbs had been very stable for a year and then this started offline started happening actually about a month BEFORE the device health release came out. I have four new zigbee devices that are brand new to market with custom device handlers and troubleshooting the new device handlers and device hardware/firmware is exasperating with ST platform issues right now. @stephack has a killer ABC button control smartapp that is ready for beta publishing but is holding back right now because of ST instability.

So the good news / bad news is with Device Health turned off it is harder to find which ones had “died” since I have to manually search and command and physically verify operation.

3 Likes

Same problem here. My Z-wave in-wall dimmer is literally 15 feet from the Hub and it is showing unavailable right now. Yesterday, it was a different switch.

How is that? Why would it not affect all systems if the assumption is that it is software related? Possibly new software not installed throughout user base?

Sometimes it has to do with software which hasn’t been applied to every account, but more often it’s one of three things:

One) an issue with database “hotspots” which can cause timeouts of various conditions. This is like a traffic jam on the freeway. Whether you get caught in it or not is partly a matter of luck and where you live. Areas of higher traffic are more likely to have traffic jams, but whether you yourself get stuck in a line that isn’t moving depends on a lot of random factors. These can be really difficult to reproduce. (Google “Cassandra hotspots” for more details.)

Two) configuration differences. If you happen to be using a specific device model or a specific device type handler that is affected by a change, you might see failures that someone else would not.

A recent example had to do with A few specific models of Schlage zwave locks. The manufacturer introduced some advanced features before they were codified in the standard. So some particular models consider certain features optional which are required in the newest standard. That caused those locks to stop working reliably after the SmartThings cloud was updated to the new standard.

However, that’s not what supposed to happen with Z wave. The third-party standard says that they will always be backwards compatibility for previous versions. So a patch has already been announced for a future release that will change the cloud yet again and again support these Schlage models.

If you had a Schlage zigbee lock, or a different brand of zwave lock, you wouldn’t have seen any problems at the same time that your neighbor might have a lock that had “just stopped working.”

Smartthings is very unusual for a low-cost system in allowing a huge variety of devices to be used with the platform. That’s normally a strength. But it does mean when these kind of “edge cases” occur it can take a while to figure out both what the problem is and what the fix should be. Where a platform that only allowed for three different models of locks would probably find all these issues before releasing new changes.

Another possibility is that changes are made to a stock device type handler and a bug is introduced. Only customers using that particular DTH would be affected. This has happened a number of times.

Three) bugs which only show up when The network is busy. This is technically different than the hotspot problem, in part because it’s often reproducible once you know that it’s happening. It doesn’t necessarily have to do with having a lot of devices, though – – just with having a lot of message traffic. The classic example is automations that don’t work right around sunset because you happen to have a lot of sunset – based automations set up and they all try to run at the same time. It’s not sunset itself that’s the problem; it’s the increase in local traffic.

Anyway, you put all of that together and you end up with problems that affect some accounts but not others.

2 Likes

Hi,

I echo your sentiments… I thought ST was stable and solid, but as I added new devices through out the weeks, its starting to fall apart at the seams. Its firing off routines even though i’m “at home” in bed, its executing “Johnny” just arrived, lets turn off the alarm and open the garage door… that’s twice in the past week already…

I have motion sensors through out, but it seems I have 3-4 ghosts walking around the house during the day as I get 2-3 alerts of motion on a daily basis.
Another funny thing it does, when the garage door opens while the alarm is set… I get notified but it also turns on a light in my family room and I can’t seem to figure out where its set LOL.

I’ve just installed 3 halo fire/CO2 devices, I’m now worried that these will false trigger or not give correct status notifications.

The only thing that actually works are the switches.

edit
Ohhh… don’t get me started on the incorrect status’ of various sensors and devices…

I’ve also heard the same tune from support…

My ST setup has also went to hell in reliability after the last update. Door sensors are reporting door open or close hours later, motion sensors randomly work. I have resorted to putting a mechanical light timer to reboot the hub every night at 2am to get some reliability back. This past weekend I finally decided to give up. I’m keeping my Zwave stuff and moving over to OpenHAB. I am completely done with any cloud based Automation. It’s not reliable and when you get a stable system you are at the mercy of random updates that break things.

I really wanted ST to be something I could recommend. But it’s not, and honestly it has became worse after Samsung bought them I just wish someone would have hacked the hardware and gained access to the linux inside so I could use it’s Zigbee and Zwave radios to interface to open Hab.

I’ve got to agree with everything that is being said. The system seemed to be stable-ish, and now I have lights that become unresponsive, motion detectors that no longer work, and automations that fire very, very late. I’ve been holding on, just don’t know for how much longer.

Actually guys I just did something that seems to have stabilized my system. Someone earlier mentioned turning the “device health” button off. I had turned it on several weeks ago and in thinking about it the problems had really started after turning that on. So I turned it off and it seems to have helped a great deal. The only problem is I am having trouble adding two of my “things” that I had previously deleted. The Evolve garage door opener and a GE wall dimmer switch and both are not found when I try to add them. I’m going to keep trying and hopefully I can get them re-added. Thanks to everyone that responded.

Marc

2 Likes

So what does one do when the ST system lets you down? I woke up this morning with almost a quarter of my devices with the red exclamation marks next to them. And as a result, a cold shower, because my hot water heaters were not turned on.
I’ve rebooted the SH hub; turned of Device Health; switched those devices that can be manually switched - nothing helps. I can’t turn on my heaters; hot water heaters; many of my lights…
What else can I do?
This is a bad wake-up call - realising that if the system fails, you’re stuck with many unusable devices. There is e.g. no way to turn on my hot water heaters (which are (not!!) controlled by Aeon Heavy Duty switches, which don’t have backup switches to turn them on. It seems I’ll have to get manual switches wired into the setup…)

Disable “Health Check”.

It sure sounds like the root cause here!

Thanks, @tgauchat - I should have added that that was the first thing I did. When that did not help, I rebooted the Hub, but as I have already indicated, that did not make a difference either.
Not a nice position to be in. I had to leave home with many devices “dead”, as they can’t be turned on (most important of which is the water heater.)
This puts the whole smart home concept in a new perspective. It’s like an electricity interruption - all of a sudden one does not take it for granted and realise how helpless one is without it.

1 Like

Issues here too! Rock solid for 10 months since I got the system. As of 2 days ago when I put 2 new GE switches in NONE of my Leviton Dimmers work but my Leviton switches do. They show as connected and receive the command but nothing happens.

I also get the device unavailable on certain devices randomly but they operate normally still.

Frustrating…

And there is nothing we can do? Seems like I have to start calling the Sparky to bypass my water heater switches … :worried:

Personally I’m not having any issues at the moment, touch wood, but have you tried turning device health off?
Just a thought as other people have suggested that this improves things.

1 Like

Yes, turning Device Health off, removes the Red Exclamation Points, but the devices still don’t respond.
I have tried the following:

  1. Rebooted internet router;
  2. Rebooted ST hub;
  3. Turned Device Health Off
  4. Did a Z-Wave repair (although I’ve never been able to tell if this does anything - I never get any messages or confirmation that the process has completed;
  5. Tried to switch the devices which have physical wall switches on/off to see if I can get the z-wave network to realise the device is still there;
  6. Switched the main breaker of the devices which do not have wall switches (like the Aeon Heavy Duty switches connected to my hot water heaters).

Current symptoms: I have lost control of the Aeon Heavy Duty Switches; Some of the Fibaro Single Switches; Some of the Fibaro Double switches; One Harmony Hub; 2 of the 4 Aeon Smart Wall Outlets. Funny thing is, some of the dead devices are located within 5m from the hub - others are at the other end of the home. In between, there are many devices working fine. A wide variety of devices in other words.

I did all of the above a second time, and I have most of my devices back online. Still missing 1 or 2 though.