Wrong eventTime being sent when event is triggered

I’ve just noticed that when an event is fired, SmartThings is now sending the wrong “eventTime” in the JSON payload. It’s always sending “1970-01-01T00:00:00Z”.

Has anyone seen this? I’m seeing this on two SmartThings Multipurpose sensors on the same hub.

1 Like

Yes, we are receiving the same eventTime on several devices. It started around 1:11 PM CST on Oct, 26. We have tried to power cycle the hub at each location, but the eventTime is still coming in as “1970-01-01T00:00:00Z”.

1 Like

It looks like this has now been fixed.

1 Like

I am still getting this behaviour from multiple v2 hubs and devices.

Did you do anything that might have fixed it? eg Cycle the power on the hubs?

I saw it had automatically fixed itself, and now it’s back to the wrong bheaviour. Power cycling had no effect.

As a workaround I ended up just changing my code to look at the time the request came in, instead of relying on the JSON content for the timestamp. Not ideal… but suitable for now.

1 Like

Thanks Dave.

We’ll do something similar and report back here if we notice any change at the SmartThings end over the coming days.

1 Like

I know it’s been a while on this post, but I just got through writing my first SmartApp and I am also seing this problem. Is this a known thing, or am I doing something wrong?

Hey @josep1972, no you’re not doing anything wrong.

In fact it’s getting even worst.

Until yesterday, all our SmartThings events had an eventTime of “1970-01-01T00:00:00Z” which is the first EPOCH time.

But, since yesterday, without any warning, the connections are not supposedly sending the correct eventTime.

Unfortunately, this only works for some sensors (like the Fibaro door ones and the samsungs power plugs), but now we have some sensors (like the Aeotec multi sensor or Aoetec door sensors) that are sending dates like “1970-01-20T07:00:17Z” or “1970-01-20T07:01:33Z” looks close but it’s not the first EPOCH time.

Took us ages to figure out what was going on.

1 Like

2 years later, I got same problem.
writing code to add timestamp manually at smartapp is not a bad solution for me