What's Going On?

Every time I click on anything in the app, it pops up the following message at the top of the app with a red background…
“an unexpected error has occurred”.
Once that pops up, I then have to tap somewhere on the screen to get it to go away before any other tap on the screen does anything in the app.

Also, the SmartApp that I am working on suddenly isn’t working properly either.

It’s simple, worked previously, and no longer works. All it does is monitor two temp sensors and turn on a switch when one of them is higher than the other.

As of right now, both temp sensors are giving exactly the same temp reading, but the switch is ON!

Also, the ‘Rooms’ tab never shows up now. It just keeps spinning.
On Day 1 of the new app, I went in there and managed to create all of my ‘rooms’, but now it’s just blank with the spinner all the time.

Almost every time I go to scroll a list (like while viewing the ‘Things’ tab), it freezes and won’t let me scroll for a number of seconds. Then, after waiting a while, I try again and it scrolls. Then when I try it again, same thing…constantly freezing when I attempt to scroll.

It was working at one time, but even when it was ‘working’, it wouldn’t refresh to get latest data until I went in there and refreshed it manually. What’s up with that? It’s not helpful at all for home automation if the user is required to go into the app and refresh it manually every time they want it to have an accurate read of the temp. Why wouldn’t it be configured to check automatically? Now it’s not even refreshing when I go in there and click the refresh button manually. So, even as a neat little tool to use to manually check the weather, it’s a big FAIL for me right now.

What’s going on?

Hey @sgnihttrams, sorry to hear you are having such problems. If you haven’t already, please reach out to support at support@smartthings.com.

Thanks Jim.
Done :slight_smile:

OK, not freaking out, but getting concerned about whether or not my messages are actually getting through on the other side.

I got an e-mail a couple days after starting the case in the support system.
I responded that day to that e-mail message.
Then, haven’t heard back from support for two weeks.

If anyone here has any connection to the Support Team, is there any chance anyone could look at my case, and send me any sort of message to let me know you’re still there? :wink:

Again, not freaking out.
It’s just that two weeks seems a bit long to wait to simply get a response. :smile:

Having the exact same problem, app pretty much does nothing but tell me there was an unexpected error. Brand new out of the box worked for about an hour, now pretty much just a $100 paperweight. Hue interaction mysteriously stopped working, can’t even delete the location to start over from scratch. I get that HA still has some rough edges etc, but seriously, this is pretty much the worst consumer experience I think I’ve had with a tech product.


For me, the main issues I had with getting mine all up and running initially were either trivial or were due to my almost complete ignorance regarding how SmartThings itself works. No fault. I was just expecting something completely different, and was able to adapt. :slight_smile:

It has been working just fine for many months.

It has only been since the big update last week or whenever it was that it has been going crazy.

I’m still a big fan, and am willing, for now, to continue being patient, because I know they are most likely getting bombarded right now.

I just simply want to hear from them so that I know that they are aware of the fact that I still need help.

You are the best for being patient! We all are trying to be! But please do open a ticket with support as it helps them prioritize issues! We all believe!

I did open a ticket, 3 or so hours later was able to sort out (most of) the issues on my own & closed the ticket out. Eventually got a response from support but only after I closed the ticket, sigh.

Even after sorting out my first issues I’ve uncovered a number of other small quirks that make it pretty much unreliable. ST is an interesting platform, but feels more like a needlessly cloud dependent toy, and not something ready for prime time. Tonight soured me on ST and likely HA as a whole, suspect I’ll return the gear and give up on HA for a few years.


I know it looks bad and I know they SHOULD be responding in a more timely manor. While we don’t owe it to them, I’ll ask you for them, please try and have as much patience as possible and stick it out.

Why? No, I don’t work for ST and no I’m not a fanboy (I’ll happily point out faults where they are deserved) BUT, I do work in a support team that works from a support queue which probably works in similar ways. Anyway, I know what it’s like to work a struggling queue and trust me, we see the tickets, all of them and we DO get round to them.

I suspect the support team is still trying to cope with the launch of the V2 hub, the V2 apps and officially going global. They’ll get back on top of it I’m sure, it’s just going to take some time and sadly ticket response times and consequently we suffer too which I know they hate doing to us just as much as I hate how it affects our customers.

1 Like

DING-DING-DING!!! :slight_smile:

Suddenly, it appears as though things may be back to working properly now…i.e. perhaps all of the issues described above may have been taken care of by the ST fairies in one fell swoop…

This is how it goes. This morning for 15 minutes or so, my entire system was dead. Now it’s fine. Somedays things are just weird. Hard to tell which. This is especially frustrating when you are developing code. My first suspicion is that I blew it in the code (even if it’s been working fine for a while). Frantic debugging ensues (which was impossible because they broke Live Logging until this afternoon), only for things to start working again around the time I’ve convinced myself it’s not a bug.

UPDATE: At least one problem is back (if I should put this elsewhere, in a completely new thread, or whatever, please just let me know, and I would be happy to move it)…

I have a SmartApp that monitors garage temps and kicks on an exhaust fan if the outside temp is x-degrees lower than the temp in the garage. Well, after ST got some major problems taken care of following the Big Upgrade recently, it’s been working just fine. However, it has gone back to a broken state now in the past couple days.

First off, this Garage Cooling system actually has three different SmartApps involved.
Here they are…

  1. Garage Vent Fans by bravenel (here)
    This is the main thing. It monitors outside temp (provided by #2 below) and the temp inside the garage, and turns on the exhaust fan if the temp is lower outside.

  2. SmartWeather Station Tile by SmartThings I think (here)
    This app is connected to Weather Underground, and monitors the specific PWS of my choice (eventually, I’ll have my own, but for now, I’m tracking another one in my area). It is also used by a number of other SmartApps in my home, like the Weather Alert app, etc.

  3. SmartWeather Station Controller by SmartThings w/bugfix by RBoy (here)

Bruce helped me configure a way of temporarily disabling my garage fans app (#1 above) using a Mode restriction. That was working (or so I assumed) along with everything else for over a week, but now it’s not (i.e. I change the Mode/s for this SmartApp to only have the new ‘disabled’ Mode selected, but it still keeps working; no way to disable it without uninstalling it or physically disconnecting the Smart devices it is interacting with).

Beyond that, the ‘SmartWeather Station Tile’ SmartApp (#2 above) - which is where my Garage Vents app gets the outside temp from - is no longer refreshing, and the add-on SmartApp that is supposed to force it to refresh every 5 minutes (#3 above) is no longer doing its job.

I’m not even sure where to look or what might be needed here.

help? :slight_smile:

There have been problems off and on for the past few months with things happening in the wrong mode. If this app runs when it has a mode restriction placed on it, such that it’s running when it shouldn’t, you should report that to Support with as much supporting documentation as possible. Confirm, for example, the mode the system is in, the time the misfire happened, logs showing what happened, etc. The Garage Vent Fans is what’s called a Single Page SmartApp; that means the mode restriction is handled by the ST backend, not by the app. And, that is why it is important to report the failure to ST Support.

Thanks, Bruce.
Will do.
I’ll report back after I have more to go on from them…

They should simply tell you that it’s a known problem and that they are working on it. We have to keep reporting these “known problems” that they are “working on”, or they won’t ever get fixed. They may never get fixed anyway, but squeaky wheels get greased more than silent ones. :grinning:

got it :slight_smile: