Wattvision device broken? htmlTile issue?


(Andreas A.) #1

Some time today the Wattvision device shows up completely blank in the app - data is still updated as shown in the “Recently” feed but the “Right Now” view is completely blank.

This is the official device installed via “Wattvision Manager” from ST:

Did today’s update break this? Anyone else no longer seeing the current status for Wattvision devices? This is the only device I have that uses the htmlTile - could something been broken in the htmlTile and do other device handlers using the htmlTile have issues as well?


Platform Update - Release Notes - 4/13/16
Device.statesSince() documentation incomplete?
(Tim Slagle) #2

When did this start happening?


(Andreas A.) #3

It was working OK yesterday - when I checked today around 5:30pm PDT it showed blank. I’m not sure I checked earlier today.


(Tim Slagle) #4

Hmmmmm, it could be the platform update.

Nothing changed around htmlTile though.


(Andreas A.) #5

I checked in the IDE - “Current State” lists current power and powerContent URI - loading that URI shows what is supposed to be displayed in the htmlTile just fine (note the time stamp which shows that it is recent):


(Tim Slagle) #6

Is this the official device? Or a custom one?


(Andreas A.) #7

Official device with fixes outlined in

and

to fix obvious bugs (though those are in the Manager which obviously is not the issue as it still updates the data). In the device handler I changed the logging to be a little less chatty and added unit and backgroundColors properties to the “power” valueTile. No display issues at all until today.


(Tim Slagle) #8

I really wish I had one so I could test.

Force close mobile app?


(Andreas A.) #9

Is there a way for me to give you my api_key and api_id so you can set up up somehow without going through the OAuth process (i.e., don’t have to give you access to my Google account)? I’d be happy to do so!

No change :cry:


(Tim Slagle) #10

Nah, I wouldn’t want to be trusted with that, but I appreciate you trusting me enough to offer haha. I am reaching out to the developer now.


(Andreas A.) #11

Does this help?

<Critical>: 2016-04-13 20:10:13:607 -0700 [com.apple.main-thread] __39-[STClient enqueueRequest:resultClass:]_block_invoke272(369) ERROR GET https://graph.api.smartthings.com:443/api/devices/[REDACTED]/tiles {
	    Accept = "application/json";
	    "Accept-Language" = "en-US";
	    Authorization = "Bearer [REDACTED]";
	    "User-Agent" = "SmartThings/2.1.0 (iPhone; iOS 9.3.1; Scale/2.00)";
	    "X-ST-Api-Version" = "2.5";
	    "X-ST-Client-AppVersion" = "2.1.0";
	    "X-ST-Client-DeviceModel" = iPhone;
	    "X-ST-Client-OS" = "iOS 9.3.1";
	} => FAILED WITH 500

(this is the console output from my phone when opening the device in the app).

I assume that the “Internal Server Error” will generate a more detailed log somewhere in the cloud?


(Tim Slagle) #12

Would you mind sending me your the DTH id in a PM?


(Andreas A.) #13

Done - thanks for looking into it!


(Yaima Valdivia) #14

@ahndee we are investigating internally what’s going. I will keep you updated. I also shared with Tim the test account that I use.


(Andreas A.) #15

Thanks for the update. Out of curiosity: does your test account show the same issue?


(Yaima Valdivia) #16

Yes @ahndee, mine is not showing either.


(Yaima Valdivia) #17

Hi @ahndee: Is wattvision working for you?


(Andreas A.) #18

Wattvision itself yes (I still get power data once a minute and can load the powerContent URI just fine in a browser. The DTH in ST still displays blank.

EDIT: in case it matters - I am not actually using a Wattvision device but rather a rainforest EAGLE set to automatically upload data to Wattvision. (It shouldn’t matter though as long as the data is available and accessible on Wattvision through the API - which does not seem to be the problem here.)


(Yaima Valdivia) #19

@ahndee are you running the code locally? If so, take a look at my PR: https://github.com/SmartThingsCommunity/SmartThingsPublic/pull/783


(Andreas A.) #20

Yes - I had modified that code to be less chatty in the logs and add backgroundColors. Adding the brackets as in your pull request fixed it - thanks!