VLAN with SmartThings Hub?

Okay, so I got my first smart switch for Christmas and I’m trying to figure out how to separate my IoT devices using VLANs. I have everything EXCEPT my SmartThings hub figured out for the most part. Whenever I try to transition my hub over to VLAN20, I get a blue light and no connection. I have some non-zigbee/z-wave devices I would like to migrate over to VLAN20 that are connected to SmartThings, so it would be nice if I could figure this out. I’m not all that experienced with VLANs, so I might need a little extra help…

Try asking the folks in the following thread, most of them have done it one way or another. ( this is a clickable link)

3 Likes

Sounds like that VLAN doesn’t have Internet access, either due to firewall rules or the subnet used in that VLAN isn’t being NAT’d properly.

Just to make sure… you are using a different IP range in that VLAN right?

EDIT: What’s your full setup, i.e. what router and switch are you using and how are they configured logically and physically…

1 Like

Hey, thanks for responding. The VLAN does have internet access. I got several devices set up on it last night. I did have some issues with it, but I got 2 amazon fire TVs and 2 echos on it, so it’s definitely working. I did have some issues with my phone though…which was rather strange. My IP range in that is 195.168.20.*** (all last numbers have 3 digits) and my other VLANs use a different 3rd number, so yes.

My router is a Ubiquiti EdgeRouter X with a Ubiquiti 8 port POE smart switch (I can’t remember the exact model number). Physically, I have a Netgear modem hooked up directly to the ERX, then the ERX is hooked up to the switch and then the SmartThings is hooked up to a port on the smart switch. For some reason, I did have issues hooking up the VLANs to any single port on my router, but I got switch0 (all 4 ports) allow multiple VLANs. The only devices that are using the VLANs are attached to the switch, so my AP, Home Assistant, and I have a phone on a separate VLAN as well. I’m not sure if you’re looking for something else…I could probably post my config when I get home if you want though.

Firstly:

Please make sure that’s a typo and you meant 192.168.20.xxx (/24).

You could do all VLANs on a single cable to the ERX but you’d have to make sure the ERX is configured correctly with sub interfaces (for each VLAN) that are correctly tagged with the right VLAN numbers. Not sure how comfortable you are with the command line because I’m not sure how configurable that is in the GUI for the ERX.

Good news like you said some devices in that VLAN have Internet access so that’s a start. Do you have any firewall rules configured outbound at all?

I didn’t realize that stars or xes mattered, but I guess it’s a typo. And yes, it is /24.

I do have a few…not entirely sure I did them right. I was following a video tutorial and making some guesses. Currently, I have it set to do the following:

  • Drop access when destination is any other VLAN or my main network - direction in
  • Accept VLAN20 DNS for TCP and UDP - direction local
  • Drop destination 192.168.1.0/24 locally - direction local

I have other firewalls set up for other VLANs, but they’re mostly fairly similar. I’m sure there is a better way to set this up, but I’m a complete novice…I’d like to learn how to do this with some practice, but I’m currently more interested in getting this VLAN network up and running, then trying to break into it later, lol. I could probably figure out how to post a full config if you think it would be useful.

I ended up getting it…I think it may not have been requesting a new IP address, but I did reset a lot of my firewall settings, so I’m not entirely sure! But it’s working now…

1 Like

It was more the fact that you wrote 195 for the first octet, just wanted to make sure it’s 192!

If you do not have another DHCP ‘server’/scope in VLAN 20 for the 192.168.20.0/24 segment then you’d need to configure a DHCP relay in VLAN 20 to get to the DHCP server.

Oh, yes, it is 192…Sorry, I’ve had a few late nights recently :wink:

I set up DHCP server, but it just wasn’t searching for a new IP address…I didn’t really think to unplug it for 20 seconds and plug it back in because I thought most devices searched for a new IP address after about a minute anymore…Also, It’s kinda weird, my DHCP server just completely crashed yesterday and I had to rebuild the whole thing. Thankfully it didn’t take too long this time around. Now I just have to figure out what’s going on with port forwarding for my Home Assistant, but that’s for a different forum, I think. Cheers and thanks!

Not an issue you seem to be experiencing but just an FYI in the event you do - a lot of home automation devices rely heavily on L2 discovery protocols and will not work across VLANs. I originally had a ‘home’ VLAN for our phones, as an example, and couldn’t control the Sonos and a few other devices from them. Some of our media devices were in a media VLAN and couldn’t be seen by ST on the control VLAN, etc… Probably good if you don’t get overly granular on the FW rules and VLANs like I did.

Just a PSA in the event anything seems sideways. :slight_smile:

1 Like

Thanks for letting me know. Right now, I’m just having an issue forwarding a port from Home Assistant. Something in this firewall setup is throwing me for a loop and I have no idea what it is…

Yes, good point. SSDP/UPnP/DLNA routed between subnets isn’t really a thing, you could get a bit hacky with some relays or fudging some NATs between subnets but in short, expect problems.

This IS a little concerning, potentially a bug. Any device that uses IP should always send a DHCP request whenever the interface comes up, no matter how long it may have been down for as far as I am aware. Obviously it should also send a DHCP renew whenever the lease is going to expire but that’s another story.

Now if you were changing the VLANs/subnets/switch ports on the fly and the ST hub was never physically disconnected or rebooted, that’s a different story and it’s unlikely it would have reached out to the DHCP server to get a new IP.

In theory, just unplugging the Ethernet cable for a few seconds and plugging it back in again should have triggered it to reach out to the DHCP server again.

1 Like

I haven’t found this to be true. I just switched the vlan on my router and it while it appears to be requesting for a new IP, it does not DHCPACK the new offered address. So here we are, with no connectivity :slight_smile:

1 Like

Interesting… Thanks for testing!

Any hints? I’m struggling with this too.

I have an Orbi > Netgear GS305E > ST

I think what I did to make this work was disconnect the ethernet from the SmartThings hub for 30+ seconds to reset the IP address. I’m not really sure which part you’re having a hard time with yet, but the issue I think I was running into a year and a half ago was that the IP address wasn’t changing from the former network setup.

Thanks. So you left the hub powered up and just unplugged the Ethernet to kick that?

I get my VLAN setup and instantly it says the hub is disconnected. Sounds similar to the issue you had.

Yup! Just make sure you leave the ethernet disconnected for long enough for SmartThings to realize it needs a new IP address. Should be 30 seconds, but you can leave it unplugged for longer with the same results. Hope that works.