Using Smart LIghting to turn on my lights when I arrive, but not keep turning them on


(Big Hoss) #1

I set up an automation using my phone as a presence, so that when my phone comes into range, my lighting, specifically my driveway light, patio lights, and front hallway lights come on automatically. But there is some finesse I want to put into it and I am not sure how.

How to I insure this rule only runs after sundown and ends at sunrise? I don’t need my lights coming on if I come home mid afternoon after all.

How do I keep the presence of the phone from turning the lights back on AFTER I have arrived home. Once I get settled in I tell Alexa to turn off those light groups, but within a half hour, all the same lights are back on. How do I stop this?


#2

Please post screenshots of the automation you have set up to turn the lights on.


(Kenneth Eriksen) #3

I use my phone as a presence sensor and runs the routine “I’m Back!” when i come home.
“I’m Back!” disarms the Smart Home monitor and change the mode to “Home”.
The routine also triggers a virtual switch that activates a scene (you can also turn on individual lights).
I have configured that virtual switch to only turn on, if it’s after sundown -30 min.

So instead of having the lights turning on directly associated with you phone is detected as being home, the running of a routine only happens once… :slight_smile:


(Big Hoss) #4

I will recreate it, I got fed up with the lights coming on last night.


(Jimmy) #5

create the rule with Smart Lights and at the bottom you can add a time restriction. As far as coming back on, if you look at the history for mobile presence, is your phone coming and going as you are physically home the whole time?


(Hal) #6

Agree. The Smart Lighting smartapp has what you need.

Restrict by time, including tying to sunset/sunrise. Or even lux level.


(Big Hoss) #7

I removed and rebuilt the rule yesterday and it seems to be working so far I will keep you posted to let you know success or failure thanks for your help so far.


(Big Hoss) #8

Not sure what happened here my response just went into the wrong thread. Never mind…

For those that have been following my threads the issue was taking place at the same time that I was having the issue with the touchscreen. I reboot it the hub removed the rule and recreated it and all seems to be well I’m not sure if it’s the hub Needing to be rebooted being the issue or what…