Updates to the SmartThings Platform

:100: thank you


There were a couple of issues with the HomeSeer switch and dimmer device handlers on the new app. I’ve received a couple of updates for several of the handlers from a user, but haven’t fully tested them. They are available at the links below if you want to give them a try:

200 series:


Good catch on the voiceover issue. I can see how that got confusing. Usability can be a huge legal liability for Samsung. They should fix this (which is very easy to do).

Also, consistent design principles will help with usability for everyone. Circles are commonly used for “radio buttons” (mutually exclusive selections), and squares are usually used for checkboxes (multiple possible selections). It would be wise for Samsung to keep things simple and stick with the standards. You can still make those elements more attractive than the norm without losing the user’s comprehension.


Yep, have noticed the child button action issue as well.

It seems that in the last week my very functional SmartThings based home automation system has lost a massive amount of its prior functionality. Many of my devices that were recently working in the new app no longer work. I can no longer choose which ST connected devices to expose to Alexa or Google. My virtual ST sensors no longer trigger Alexa routines. I haven’t had time to create the virtual switches and webCoRE pistons needed to recreate the functionality I lost by “upgrading” from SHM to STHM, but it seems to me this really shouldn’t be necessary. About 10% of my devices randomly show as not being connected on a regular basis in the new app, and when they show this I often lose the ability to control them through anything other than the classic app. They show as connected when I log into the IDE, and they respond to commands from the classic app just fine, they just don’t respond to the new app or ActionTiles or to the new ST skill for Alexa or to the new Google integration. And more recently I’m seeing devices with this behavior except the new app shows that they’re connected, it just times out if I try to control it. This was previously limited to devices using cloud based DTH’s, but in the past few days I’ve noticed it with two devices using stock DTH’s.

The last straw for me came the other night when I had to get out a ladder to unplug some bistro lights from a zigbee plug. Family was complaining that Alexa commands weren’t working. So I tried the new app, shows as connected, but times out if I try to turn it off. Try ActionTiles, doesn’t work. Log in to the IDE, the device shows as online, everything looks normal, great LQI/RSSI numbers, and I even see regular check-ins from the device during the time I was trying to control it without success.

I’ve been a SmartThings fan for a few years now, and have regularly defended it against its detractors. With these recent changes, I can no longer do that. I’m not sure yet what I will use for my home automation platform going forward, but it doesn’t look like it will be SmartThings. The thought of moving ~150 devices to a new platform is daunting, but I just can’t live with this reduced functionality any more.

Thank you to the amazing community here for the help, support, ideas, and insight over the years. And thanks to the ST staff who regularly post here and offer great assistance and insight. Will be sad to lose all of that.


Thanks for the response @blake.arnold.

Hopefully, yes, that does clear up that issue.

Shall I give you the list of other issues I have been having? I am happy to do that - because I have been keeping a list. I want to be patient, but this has not been a very pleasant transition for quite a few of us.

1 Like

New community FAQ. (The topic title is a clickable link.)


I updated the custom handler yesterday to that code. I didn’t see any difference in the behavior in Smartthings, but I didn’t get a chance to remove any of the devices and reinstall them to see if that made any difference. Sounds like I shouldn’t have to remove them, but I’m not sure if anyone else has had any luck getting it to work.

So I clicked “Migrate this site” in my classic app. It went through 6 out of 11 applications (I’m not a heavy user), and then rendered message saying something like “some applications can’t be migrated, check flagged issues in the classic app”
I’ve re-opened the classic application, now it says “this site has been migrated”. That’s it. No idea what the issues were and where to find it. Are you kidding? What am I suppose to do? Have you even tested this, once?

What region are you in?

If you are using ST’s smart locks and in a region where smart lock guest access in the new app is not available… that could be one of the error messages.

At least IFTTT and Ecobee are missing. How am I supposed to have it working without IFTTT?

Look in menu > settings > linked services

1 Like

Thank you. I guess it’s some other apps that are missing. The problem is I can’t find out which (my custom apps are here…) Was that message about 5 non-migrated apps just an error?

Ok, technically migration does nothing with custom or other apps you added nor devices. They would show in the new app whether you migrated or not (except in the case of sync issues)

Migration only converts SHM and SHM custom rules over to STHM and automations and scenes. It converts routines over to automations and scenes. It converts smart locks to smart lock guest access.

Without a screenshot I have no clue what went on. You may want to check if your routines and shm custom rules were converted.

Plus, you can still open the Classic app and view all the apps you have previously installed. They are still there.

You will see a message now that the migration has occurred and to use the new app but you can still use the Classic app except for SHM, routines and scenes.

Some users have gotten really crappy error messages after migrating. It sucks!

1 Like

[ This was in response to a question higher up in the thread, not sure why this was placed at the end]

Question: How are timed based notifications from the old app handled in the new app.

If I understand the issue, it is working for me under smart apps, under “Custom Monitors”,

When I did the migration from the old App, a couple of days ago, my notification rules, like 120m garage is left open notify, were copied over to this section.

I migrated my account manually - do you know how to manually set this up in the app? I don’t see “Custom Monitors” when I add a new SmartApp.

1 Like

Contact support. Best bet is to call them.

And what if they get the support tech who MIGHT say custom device handlers and custom Smartapps are no longer supported after oct 14th? :wink:

How many times has that happened in the past few weeks.

Please note: I was making a back-handed comment. Custom device handlers and groovy does not end on oct 14th but in fact, are scheduled to end sometime in 2021.

Sometimes after I’ve vented about the month plus turnaround of UK support, I read some of the rapid answers you get from US support and think “We’ll call that a draw.”


You shouldn’t need to re-install, but the device does need to be refreshed for the new supportedButtonValue mappings to take effect - by either pulling down on the device once it’s selected in the new mobile app (ie to get spinner for a few seconds) or by hitting config in the old app. I would have expected SmartLighting to work better with the new app with this change, but the new automation capability would still not be working…

Also, as a test trial in the hopes of more fully supporting the new automation capability of the new app (and hopefully SmartLighting as well), I put together a quick very beta (alpha really) version of the WD200+ dimmer device handler that implements a single button with all 12 actions (eg downx3, upx4, hold_up, etc) instead of the old approach that implemented 12 different push buttons. Note: This approach will break any old automations that you have that are working, so I’m not sure I would test this update if things are working now for you. I’m not sure how many SmartApps fully support the new-ish supportedButtonValue mappings, so your rule/automation options may be limited with this new code… I’ll try to post future updates in the WD200+ thread…

1 Like

Yup. Support is hit or miss. But getting an opened ticket matters.

I’m working on the belief that somewhere someone at Samsung pays attention to the number of support tickets as an indication of platform stability and quality.