[Updated V2.5] Generic Media Renderer (DLNA Speakers). Party Group (multi room)


(Jonathan Nguyen) #22

I too have one Fabriq working fine as alexa, but smartapp can’t find it. Just got it yesterday and connect it app, and update speaker, I hope not because of speaker software update.


(Tom Quinn) #23

So I finally got this to work… the Fabriq speakers like the ip 10.10.10.254, that was also my gateway IP, I had to move my network gateway, so the speakers could use that address, then they found a firmware update 3.8.something, and once updated, are found and work great!

so! yay!


(Simon) #24

Hi all. This has been working well for me for 2 years now, but 2-4 weeks ago the speaker device stopped being linked to the speaker itself (Denon HEOS 7).
So in the ST App, I’m no longer able to control the speaker.

Is anyone aware of any changes in SmartThings setup or elsewhere that would have made this stop working for me?


(Hendre) #25

Did you manage to resolve your issue? I’m experiencing the same with my Heos speakers, after they were working fine for month.
The App shows the speakers as “not connected”.
I have tried discovery, but none of the speakers show up.


(Simon) #26

Hi
No, not yet. I asked Ule in this thread, RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

I have tried rebooting and also unplugging the hub (power off for 5 minutes, incl batterier), but nothing has worked so far.

I also did discovery in the smartapp, and the speaker DID appear, BUT I dont think the process ever finished correctly.

I have thought my next step will be to remove the device/the speaker from ST, and do the discovery thing again and hope that makes a difference.

A thought since you say you have HEOS 7 also, it could be a bad firmware update?!


(Simon) #27

I can see a firmware was released May 31st. That sounds like about the time it stopped working for me.

I have now create a ticket with Denon, about the issue.

Also I have actually had another issue with HEOS. When streaming from Spotify, for the past 2-5 months or so, I have experienced that in about every 3rd song, the song restarts!
It happens on all my HEOS speakers I think, but when listening to spotify on my computer, on bluetooth headsets and more, I have no problems. Only when streaming to HEOS.


(Hendre) #28

I was going to check when the the last firmware update was done when I get home. Thanks for the info. I was away for a few days. Left on the 31st and all speakers were working fine. When I got back, they had stopped working (via SmartThings), showing this:

I’m sure you’re correct about the firmware update.


(Hendre) #29

I managed to get my speakers going again.
I first removed the individual devices in the SmartThings App.
Next I removed the MediaRenderer (Connect) app from the SmartApps section.
I rebooted by Samsung hub and speakers
Finally I re-added the MediaRenderer app from My Apps under SmartApps in Marketplace.
All 5 Heos speakers were detected almost immediately.

Hope this helps.


(Alex R) #30

@ule

First of all thank you for excellent application.
I have a question. Recently I bought pretty good and very cheap Varo WiFi speakers and they appear in your application after discovery as the media renderer. I use them for various announcements and they are working perfectly. The only problem with this speakers is that they shutdown after 30 min of inactivity regardless whether they are buttery operated or on electric power. After they shutdown the only way to bring them back is to press the power button. Is there any way to periodically send some specific command to the speaker to prevent it from shutdown due to inactivity.


(Ule) #31

Hi talkinghead.

The connect manager check the status frequently, it must to avoid the turn off, but your speaker still turn off.

I think , you can try to check if the speaker support Wake-on-Lan and try to use some technique to send the command periodically .

Other way is to verify the speaker status and if is not playing you can send a silence audio to play frequently.

Some devices with battery needs to press button to tun on, but if you remove the battery they tun on when power is connected , if your speaker works in this way you can add a power switch to turn on the speaker when no audio is playing.

good look


#32

I cannot get the Media Renderer Connect app to detect any of my various HEOS devices. I’ve checked that uPnP is enabled but can’t think what else to change. Any advice most welcome.


(Ule) #33

Hi, are your speakers visble in Mediarenderer mode? try to check with some upnp apps to verify they are visible


#34

Thanks @ule. I installed BubbleUPnP on my mobile and this sees all my HEOS devices (and Google devices) just fine. I’m most likely doing something wrong in SmartThings. In the Classic app, I go to SmartApps, then “Add a SmartApp”, then “My Apps”, then “MediaRenderer (Connect)”. Then I “tap to start searching”, see “Discovery Started!” but no devices ever show. Is that the right process I wonder? I’m probably doing something obviously wrong.

Update: I’ve removed and reinstalled the SmartApp and DH and still can’t detect any devices. Meanwhile BubbleUPnP is working fine and I’m using that to play through my HEOS speakers now. Still baffled…


#35

I’m still baffled here and would love some advice if anyone has any ideas.

I have managed network switches in the house and noticed than two weren’t using DHCP so had the same default IP address. So far as I know, this hadn’t caused me any other issues, and hadn’t stopped BubbleUPnP from working, but having fixed this, MediaRenderer (Connect) could finally see all my HEOS devices.

However, realising that MediaRenderer (Connect) added “Speaker” to the end of the device names in SmartThings, I renamed all my speakers in HEOS, deleted them from SmartThings and then tried to add then once more. However despite many attempts, rebooting the hub, wifi & network switches, reinstalling MediaRenderer (Connect), and forcing an IP address change on a speaker, I just can’t get the discovery process to work again. Meanwhile BubbleUPnP keeps working. Most odd.

Not sure if @ule or anyone else has any ideas, as I can’t think what else to do. Thanks in advance.


#36

All resolved now. I unplugged the SmartThings hub for half an hour to force a ZigBee repair and when I tried MediaRenderer (Connect) again afterwards, it found all my HEOS devices.