Updated : GE Link Bulbs - FINALLY getting ON status after manually turning on!

The GitHub code has been updated for the fix for dimming below 7, thanks @Sticks18.

2 Likes

Hi @Drewbert34, as long as any device type you are using has Polling as a capability it will show up, and it doesn’t matter if it’s zwave, zigbee, etc.

When you created your new custom device type, I’m assuming you saved and published it, but did you change the device to use your new device type you just created?

When you installed the Pollster app, under Convenience I think (or the GitHub source), you didn’t see any switches when tapping in any polling group (1 through 4), or don’t you have any of those yet?

I know the bulbs will show up, so please check things again.

@johnconstantelo

You should submit this to STs to have it officially updated on the STs side.

3 Likes

@johnconstantelo

[quote=“johnconstantelo, post:22, topic:8000”]
When you created your new custom device type, I’m assuming you saved and published it, but did you change the device to use your new device type you just created?[/quote]

I’m a newbie so please forgive my ignorance. I did publish it but I don’t believe I don’t know how to change the device to use the new device type.

I saw all of my door locks but I will look again as you suggested.

I really appreciate your response!

@Drewbert34, no problem at all!

Now that you’ve published it, all you have to do is edit your actual device. Go back into the IDE (developer tool) and go to “My Devices”. It’s 2 tabs to the left of “My Device Types” where you created the new one for the bulb.

Click on your GE Link Bulb, and then in the next screen that comes up select “Edit” all the way towards the bottom of the screen. When the next screen comes up, scroll down to “Type”, and select the device type you created, and then click on “Update”.

That’s it! Now I recommend logging out of the app, and then back in. On my Android devices I also close all active apps.

You know the bulb is using your new device type when the Pollster app see it (doesn’t matter what group in the app you select), or you manually turn on the bulb and tap Refresh in the app.

Hope that helps.

@tslagle13, yes good idea. I’ll get that done tonight. Wife and kids are gone for the night, so I’ll be geeking out on ST stuff I haven’t gotten to for a while…

1 Like

@johnconstantelo

I experimented a little after your last post and found what it was you directed in this post. I changed all my bulbs to the new device type. Does it matter that the new device type is named the same as the previous device type?

I will reinstall pollster and give it a whirl.

I need to learn a little more. I’m very savy with VBA coding. Maybe I can learn to code this too!

Once again, thank you for your time!

@Drewbert34,It shouldn’t matter, but I would change it so there’s no confusion, and just to be safe. If you change the name of your new device type, it will also change it on the device.

If I can muddle through this, so can others. I’m sure you’ll catch on quickly.

I believe I got it covered now. it appears that Smart Things is a little slow to respond at times. That being said, it appears I’m on the right track now.

Excellent, glad to hear!

So,if I’m understanding Pollster correctly, the updat on bulb status can be no timelier than per the 1 minute mark?

@johnconstantelo Thank you! I have been waiting / hoping for this fix.

That’s true, a minute is the shortest, which is acceptable for my needs. As @SparkyXI said, for $15 you can’t beat what this bulb does.

1 Like

This might be a solution to a non-existent issue, but is anyone having trouble with this bulb in conjunction with SmartApps or getting annoyed at the way the level skips around when adjusting level or turning off/on?

We seem to get a lot of level responses from the bulb. When changing level, we send a level change event in the command for the new level, then we get two responses in the parse: the prior level then the new level. This is why it will usually go to the new level, then skip back to the old, then update to the new again. When turning on/off we get a parse for 0 level then the current level again. I wasn’t sure if this could cause issues with subscribers by creating a lot of quick level event changes.

I was thinking we could tell it to ignore certain incoming messages that we expect when the on/off/setLevel commands are triggered.

1 Like

Loaded this up today. Well done. Thanks very much!! ST should adopt this version.

EDIT: My original comment stands, however: I’m still noticing that while manually setting the level, the slider still jumps around. Say I set the bulb from 70% to 30% - the actual level does go to 30%, but it jumps back to reading at 70%. Backing out of the device and going back in then shows it at 30%, as set.

Any other ideas on this?

My comment was misleading. I didn’t fix that yet. Was polling the community if it was necessary. I’m hesitant to tell it to ignore messages because sometimes (if ST is slow), it doesn’t get all those messages and we could miss ones we want.

I’ll try to work a solution today and get it to this group for testing.

Yes @Sticks18, I saw that happen as well. I wasn’t sure at first if it was something going on with ST or the device type.

@Sticks18: didn’t read the post above. Derp.

For what it is worth I’m not seeing the level skips on my GE links. However, I did see it on someone else’s system I was trying to help them with. I’m using the generic ST device type and I believe they are too.

Planning on trying this device type out today.
Edit - I updated to this device type but I’m not getting on corrections when using the manual switch. Also it made the icon look weird. I’m not sure if it is related but there seems to be two inputs for 1. Device Image and 2. Update Icon inside the preferences?

@greg we still can’t get the status to automatically update when the bulb is turned on using the manual switch (yet at least). The enhancement in this device type is that the refresh() command will properly update the on/off status if it gets out of sync (bulb has to have power), so if the bulb shows as “off” in ST and the switch is manually turned on, it will update to “on” at the next refresh().

@johnconstantelo also added the poll() command, so this can be used with the pollster SmartApp. That allows polling every minute. Combined this device type can fix out of sync issues much faster than the stock device type.

Not sure what’s up with the icon looking weird. There is no code for preferences, so it should use the stock UI for that. I’m surprised to see the Device Image option as usually I’ve only seen it for Groups and Presence Sensors.