[UPDATED 3/27/18] GCal Search

Just thinking out loud…

  1. Internet latency of late.
  2. How rapidly is your piston firing with “back-to-back” calendar entries?

Thank you for the reply. Interestingly the problem seems to get worse throughout the day; reminders fire on schedule in the morning, but by late afternoon they are eight minutes late (and so far never more than eight minutes behind). The delay seems to be in the GCal app itself vs. webcore (i.e. the device “opens” late in the smartthings app).

Thinking much like a bunch of other apps this one is going to bite the dust in the near future with the sunset of classic app. None of my triggers have updated since I migrated and removed the classic app. Just making sure someone else is seeing the same thing or has come up with a (temp) work around?

Mine works fine in both classic and new. This fortunately does not rely on custom device presentations so the app version has basically no effect on its operation.

So we troubleshoot why the triggers dont work independently of which app you use.

That said. Whats your filter and can you get to the base Google calendar that supports your trigger through an Ical?

Well thats good news!

Just a word search. I use this to read football games off of a Google calendar that I have populated.

Not sure what you mean here. From the app I can see the particular calendar that I want to reference. But the way I read your question is whether I can populate an Apple Calendar with my active google one?

Couple more notes.

  • In the new app I cannot delete an old trigger/search. After having clicked delete it does nothing. Which makes me weary about if I make any changes to existing searches whether that really takes effect or not.
  • I also appear to not be able to make any new searches, after the final step of creating a new search it just sits and spins at the processing page.
  • In the new app it only displays power and switch data for each search. The extra data such as the result of the search can only be viewed in the IDE.

For first two of the last three points, mine isn’t doing that. I’ll go back and check if something’s changed.

For the LAST one to see THAT stuff the custom device handler will have to be modified to show it. The beta that enables that is going on now. So give that a couple weeks… But it shouldn’t stop your trigger from working.

ok there is a new behavior here. Mine hung on creating a new event (test in a calendar I already had access to) during the device creation process. I’ll take a look and see why. BUT if I canceled out and came back in to edit the new trigger it worked just fine. AND I verified it triggered properly.

EDIT: I ran through it again to test and capture the logs and it flew through no problem…

So I made a new one, got to the processing page, let it sit for a minute, backed out and came back into the app. You are correct that the new search is now there. And when looking in the IDE I see it has the correct data. So thats good.

I tried deleting another one and after hitting delete let it sit for a second. The app then went back to the main list of searches/triggers with the deleted item not showing. Backing out of the app and closing it, I waited a few minutes and reopened the app and smartapp, deleted search is now back.

1 Like

Are you familiar with live logging in the IDE? What happens in Livelogging when you try to delete and it fails / hangs. do you see any errors?

This is what I get from that device when trying to delete it;

So based on that I went to that device in my IDE because it wasnt showing in the app besides in the list within that smartapp. From the IDE is said Alexa (somehow?) was still using it. Weird because I dont push anything through Alexa. Back to the device in the device list, deleted it there, back to the smartapp, deleted it there again. Closed everything, reopened and it appears that we are all good.

1 Like

Something else I have now noticed. Making changes to existing searches in the smartapp didnt seem to take. So then going to that device in the IDE still showed the outdated data (calendar to reference for example). Clicked on edit for that device, made zero changes, hit save and the device now had the correct calendar/data.

So it seems that it is sending the new info from the smartapp somewhere but have to edit/refresh the device in the IDE for it take effect.

1 Like

Hi,

I’ve found this as a result of the new limitations within IFTTT. I’ve been trying to install it using the new SmartThings app, but am receiving the Error 403 when I try to do the Google authentication. I’ve checked all my settings within the web client OAuth and they are correct. The only thing that I can think of is that the new app forces authentication to take place inside the app rather than a browser. Reading through this thread, I see that this was corrected back in 2017 using ‘external’ but this doesn’t seem to work with the new app. Any ideas?

Thanks

Guyan

1 Like

Maybe refresh your tokens? You may have already tried that? I think it’s mentioned around post 50. I haven’t touched this in ages and it’s hardly ever messed up, so I’m not sure how much help I can be.

It was definitely the new app. I found that I still had the old version installed on my iPad. I didn’t think that I’d be able to use it as it had previously only given me options to speak to support to upgrade to the new app. However, it did allow me to authenticate and its now all working successfully.

1 Like

Hi there!
I just try to install the Gcal-search app and I get an error when I try to enter credentials…something like: google cant log you inside this app…

Everything is looking fine ( api enabled for calendar, oauth is set for web app, client secret and id entered in the setings (ST)… Any clue on how to fix that?

Is your issue similar to the post above yours? Did you try the old app? Not that I think it’s functional anymore? Possibly that is now the only way to setup this old app?

Having the same issue (Error 403). Running the latest app on iOS. Do not have an older app. Any other way around this?

also having the 403 error.

does anything special have to be done for the OAuth Consent Screen on Google? Published status? Test Users?

Resurrecting the post… Has anybody found an answer to this error yet? It seems like the GCal Search app would be really useful, but I get stuck with the 403 disallowed_useragent error. Has anybody got this to work off the new app yet?