Unknown Tile?

devicetype
ide

(Timothy Martin) #1

I’m trying to write my first Device Handler, and i’m following the quickstart from the docs, but no matter what I try i just get an “Unknown” tile in the simulator. I’m just trying my own Hello World for goodness sake!

I was using just templates from simple switches or dimmers assuming they would work in the simulator.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Paste the code or GitHub / Gist link and myself or someone is likely to spot a possible syntax error or SmartThings quirk.

Be sure to surround pasted code here using the </> format button.


(Sergey Stoma) #3

Yeah, I ran into the same issue, tiles work in the mobile app, but it looks like simulator tile handling is broken or something.

For example ST’s own example for arduino shield: https://gist.github.com/aurman/6862503


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Oh…

Lots of stuff doesn’t work in the simulator. I hardly ever bother to use it.


(Richard) #5

Hi there, I’m having exactly the same problem as instanttim - using any of the pre-made device handlers seems to give me a device handler that just shows (and seems completely stuck on) the grey ‘unknown’ tile in the simulator.

To reproduce:

  • Go to ‘My Device Handlers’
  • Click ‘Create New Device Handler’
  • Click the ‘From Template’ tab
  • Pick any template e.g ‘Z-Wave switch’
  • Click ‘Save’
  • In right hand column, select location and click ‘Set Location’
  • Select virtual device and click ‘Install’
  • Get grey Unknown panel as per instanttim’s screengrab above
  • Clicking on/off buttons etc below the grey unknown panel seem to have no effect (although log messages are getting produced)

It’s possible I’ve misunderstood how this is supposed to work, but it seems a bit broken to me. Has anyone successfully used this in the past?

Richard


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

Yes … I do recall having more success with the IDE Simulator in the past. I was working on some reasonable modifications to a DTH this week and the Simulator exhibited the behavior you describe.

I suggest contacting: Support@SmartThings.com for the record as I believe this is a bug.
But @Dianoga might know more (or @slagle, @jody.albritton).


(Richard) #7

Thanks @tgauchat I’ve emailed support and will post on here with any news.

I could’ve sworn I saw the simulator working with a device handler when I first looked at SmartThings last year so maybe I’m not going mad after all…


(Matthew Burton) #8

I’m seeing the same thing. I have tried to make several different Device handlers from templates and all of them are giving me the “UNKNOWN” tile. Including device templates for Smartthing devices.


(Matthew Burton) #9

I just got an email back from support stating that this is a know issue that they are working on.
No ETA. At least a know it’s not just me and I’m not crazy or doing something wrong.


(Jakeholland) #10

Glad to see I’m not the only one having this problem… I hope it gets fixed soon.