Unable to control Fibaro The Heat Controller


Since a month or 2 (but only took the time recently to try and fix the problem) Fibaro The Heat Controllers are unable to be controlled directly.
I can view the the temperature and battery level, but I’m unable to switch heating modes and heating temperature, while the options show under “supported modes” in Groovy.

Changing to another DTH in Groovy, like the generic Z-Wave Battery Thermostat, does not work either.

I have tried removing and adding them to the hub again, with no success.
All phones in the household are unable to control them directly, but as far as I noticed routines and scenes do allow to change the mode and heating temperature.

Does anyone know of a solution so the thermostats can be directly controlled again?

What is the fingerprint for your device? The beta ST edge driver for z-wave thermostats appears to support The Heat Controller, with fingerprints 010F/1301/1000 and 010F/1301/1001 currently included in the driver. If yours is one of those (or even if it isn’t, it’s something else to try) then you can try enrolling your hub in the ST beta channel, installing the “Z-wave Thermostat” driver, and then removing/adding your device so that it hopefully rejoins the hub using the driver instead of the DTH. See the first post in the topic below:

1 Like

My device does indeed have 010F/1301/1001 as fingerprint. Readding it with the Edge driver worked like a charm, thanks!

Sadly it doesn’t seem to include a way to read current room temperature, nor is it the drive able to read the extra temperature sensor’s temperature (just a disconnected logo on temperature, but it does report battery percentage).

1 Like

Could you post a screenshot of what you’re seeing in the app now? I’m not familiar with this device, but it sounds like it should have two temperature readings - one from the thermostat itself and another from the separate sensor?

It’s possible that the device just hasn’t reported temperature back to the hub yet. Many devices only report every few hours, or when there is a change that exceeds some threshold. You could try blowing hot or cold air on it to see if that triggers enough of a change to be reported, or just wait and see if it updates over the course of the next day.

Also, that driver is currently in beta and hasn’t been moved to production yet. It’s possible that there will be some changes/improvements to it still before ST considers it to be in final form.

1 Like

Yup, that was exactly the case. After 30 minutes I saw a temperature reading from the “ExtraTemperatureSensor” part, so seems I was a little too quick to jump the gun.

I have yet to transfer the only thermostat without an extra temperature sensor, so I don’t know how the driver behaves without one.
If you want, I’ll report back with my findings.

Got an error while trying to upload the screenshot, so here’s the link to imgur:

1 Like

Should there be another Temperature reading in the Main section? When you have the extra sensor hooked up, should it continue reporting the temperature at the thermostat or does the extra sensor completely take over?

1 Like

The thermostat will only use the extra sensor’s temperature, that’s how Fibaro advertises it and how it always worked with the Groovy DTH. So it’s completely fine not seeing a temperature reading from the thermostat with an extra temperature hooked up directly (if I recall correctly, the thermostat and sensor communicate directly with eachother via bluetooh).

The only difference with the Groovy DTH is that with the sensor used to have it’s own entity and card in SmartThings (being a child entity to the thermostat in the Groovy IDE).
The thermostat would still report a temperature reading in the app, but it was always the same as the sensor. (I tested it by holding the sensor in my hand to compare.)

1 Like

Hello, I just purchased one of these and I can not for the life of me get it to pair. I have tried both EDGE and then removed the EDGE driver, regardless of any driver or DTH I only (sometimes) get the app to see a “Z-wave device”, but after completing the security setup, or even if I try to skip secure setup, the device does not show in the app, nor in the IDE or in the CLI edge devices… Not even as “Z-wave device”… it seems to never complete the pairing process.

Any tips? This is frustrating.

I’m sorry, it pairs like a dream for me, even with the beta Edge driver.
Do you maybe have another Edge driver that looks for the same fingerprint as the Fibaro thermostat that hijacks it from the Beta Edge driver?