Turn off Lighting option in airconditioner with SmartThings Automations

Does anyone know how to turn off the LED lights from the air conditioner when it is turned on by an automation?

I have the Lighting option turned to off, but every time the automation runs or if I change a setting (e.g. less temperature), the lights turn back on.

This is very annoying.

In this topic @JRFabbi did an extensive research on those Samsung OCF ACs, he can give definitely an answer for you, as he struggled with the same light issue.

1 Like

It would be great to get some help on this topic! @JRFabbi do you think you can help?

Hello @fbleitao, unfortunately automations can’t trigger OCF (the “execute” command are not available for automations because it depends on device’s hardware as it is a way to send command directly to the hardware’s device).

If you are using SmartThings API you can send this command to your device just after you set anything, this command will turn off device’s light.

{
   "commands":[
      {
         "component":"main",
         "capability":"execute",
         "command":"execute",
         "arguments":[
            "mode/vs/0",
            {
               "x.com.samsung.da.options":[
                  "Light_On"
               ]
            }
         ]
      }
   ]
}

Heere is the original post, you can get more information: REST API for display/light on Samsung Windfree AC

With an SmartApp you can subscribe to “execute” command and your app will know when light turns on, you can send a command to turn off (I’ve done this, also checking status of room lights and TV, if all above is off and A/C lights turn on it will turn off again using that command)

Please note that “Light_On” is to turn off and “Light_Off” is to turn on (or your SmartApp will receive this when your device light turn on.

1 Like

I had the same problem. I had to call an expert…