Tp-link devices stopped working in SmartThings (Jan 2023)

so as of saturday evening, all of my edge connected tp link devices show offline even tho they are connected in the Kasa app. about 20 devices and 30 or so routines and sub-routines(i.e button 2 pressed=___). i tried deleting and reconnecting the link and only the non edge version is being found. on top of that, after deciding to update the IOS app, i notice that some/most routines crash upon edit/saving. not sure if these troubles are related to the edge migration but this is such a screwy process. when devices are offline, you cant even tell what driver it was connected to. with over 40 drivers installed, how does one organize this crap. are any of the other hub options this cumbersome for the slightly above average but far from advanced user?

I would suggest using @TAustin “API Browser+” you can look at and possibly change drivers when a device is marked offline. If it is truly offline you won’t be able to change the driver.

this part confuses me. You are going to linked services and removing the Kasa integration, then go to Add Device > by brand > TP-Link Kasa? on top of that you say you get the non edge version?

or are you doing something else?

if you go to Add Device > by brand > TP-Link Kasa to add your Kasa devices - since they are a cloud to cloud integration… Driver would not appear under the 3 dots for the devices since they are not directly connected but they are using the new architecture (Placeholder shows in IDE). So how did you determine they are non edge version?

Not sure if you may be using a community developed edge driver for Kasa?

1 Like


Now that you mention it, it’s been a few months since I started switching over to the edge drivers and I remember I would get duplicate devices and never knew why or how to stop them even when deleting so I just stuck them in a room called duplicates. After unlinking this morning, I didn’t check the edge versions to see if they deleted, I just re-linked via the mentioned method , then I saw the non edge version (I assumed because they didn’t have driver option)and assumed they were the newly linked. when i spoke earlier, i had not checked the IDE, was just looking for the driver option. Hope I explained clearly and thanks for the help. yes, all of the devices now show placeholder in the IDE. but the old ones are still not connected. so, since they say placeholder and they are edge driven, how do you change drivers if the option is not there (the old ones i could change drivers).

Keep in mind that the official c2c integration and Edge Driver are both listed as Placeholder in the IDE.

1 Like

thanks Paul, this browser seems pretty valuable. Any thoughts on smartthings routines crashing when saving. Not all just most (some with the check and some without) are causing this crash. example, go in to a routine, change it slightly by backing out the last letter in the name of the routine and replacing it then hit save. the app closes and you have to reopen.

stupid auto correct, Thanks jkp

What model hub do you have?

a V2 and a connect home with devices formerly connected to both

iOS or Android app?

I have iOS (iPad but not iPhone) and have been experiencing frequent crashes lately but not editing Routines.

iphone ios v14.6

How many drivers on each hub?

And which hub are the Kasa devices on if they are Edge?

Paul, both hubs have hit the 50 limit and its a mix of devices to each hub, but after some trial and error, the reason for the app crashing seems to have something to do with the offline devices. I was trying to add virtual switches while the offline devices were still assigned to the routine. when doing this the app would crash. so, if i deleted the old device from the routine, then added the new device to the routine it would work fine. this stuff gets frustrating sometime.

From what I have read must hubs have memory issues long before they get to the 50 driver limit.

I have two v2 hubs. One currently has 30 drivers. When I was up around 34 drivers I would get low memory warning when adding hub based devices by Brand. At 30 drivers I get no warnings.

I wonder if low memory could be causing problems.

Although most things I read were that people with v3 hubs were getting repeated hub reboots when they had low memory.