[ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer, Monoprice and Zooz models

Yep, it has the screw terminals and that part was straightforward. The challenge I’m having is that once that’s all connected, the menu options for programming the Aeotec into SmartThings for the final steps in the Step by Step Tutorial don’t quite match up with the options in the Ecolink.

I’m sure it’s something I can do using the command class configuration parameter…things on the pictured Ecolink instructions, but I’m just too new to adapt this all myself.

So I might just return the Ecolink and get an Aeotec so I can follow the tutorial exactly, they are similarly priced, but I thought I’d check first if anyone knew how I can do this on the Ecolink! :slight_smile:

There isn’t anything to program in the ecolinks to use the screw terminals. There’s not a “second input” to select or choose. The screw terminals are just wired parallel to the magnet reed switch (on the door sensor) or the tilt switch (on the garage sensor).

Just close across the screw terminals to test. It’s designed to use a reed switch or a micro switch, any dry contact.

Well darn, it came up in a bunch of lists as having dry contacts, but your clarification certainly solves the mystery of why I couldn’t figure it out on my own–it’s just not possible.

Thanks for confirming, I’ll be returning it and getting the Aoetec!

Most models came with the dry contact terminals. Maybe at some point they decided they weren’t worth installing anymore as most users never used them or knew they were there.

My point was that if equipped, there isn’t anything to change software wise. No setting to change or parameter to update. If the dry contact terminals are there, then they just work in parallel with the other switch (be it a magnetic reed switch on the door sensor or the tilt switch on the garage door sensor).

Photo of the 2.5ECO model with the terminals on board:

How can I remove one of these drivers? I tried to use uninstall but get the error show in the screen shot. I’ve gone through and excluded the 2 devices that were using this, but it still won’t uninstall. The wierd thing is that it shows these devices were using a DTH in the IDE. I still have 4 more of these devices using that DTH successfully. When I try to include the device I excluded, It automatically uses Z Wave Sensor PH. Thoughts??

You can use the API Browser+ to see if any devices are using this driver. You can’t delete a driver if any devices are using it.

1 Like

Thanks Paul!!!
I found a door sensor using that driver and was able to uninstall that driver after I switched the door sensor to another. I had no clue it was using it.

1 Like

@philh30 and @csstup

I have a Schlage Home Door and Window Sensor (model RS100HC) which is also listed as the Schlage_DWZWAVE1 on the Z-Wave Alliance website. I’m 99.9% sure it is equivalent to the Ecolink DWZWAVE1 in form factor and functionality. The fingerprint is 011F-0001-0002

Raw Description zw:S type:2001 mfr:011F prod:0001 model:0002 ver:2.00 zwv:3.40 lib:06 cc:30,71,72,86,85,84,80,70 ccOut:20

Edit: Looking up manufacturer ID 011F, it says it is assigned to “Ingersoll Rand (formerly Ecolink)” and this news release says it was so that they could partner with Ecolink to create Schlage branded devices.

Do you think you could add its fingerprint to the Z-Wave Sensor PH Edge driver?

Also, while I have your ear, there is a typo in the settings page under Send Sensor Binary Reports. The word “supplimental” should be “supplemental”

Update: One last request would be a setting to invert the states (Open/Closed) similar to what your masquerade driver does.

Looking to see if this supports the Ecolink PIR-ZWAVE2 Motion sensor as I didnt see any details and with Smartthings debacle yesterday deleted device from users when I add it back it updates status oddly.

When Motion is sensed it sets as motion correctectly, but also updates the contact as open… I dont believe this has multi sensors so the other features (i.e. Illuminance, Top, Humidity,Battery) are not reporting status.

What driver is it using? I would try @philh30 driver

It is using the Z-Wave Sensor PH from @philh30

That would have been my suggestion. It sounds like the capabilities associated with you fingerprints need to be modified.

@philh30 how can this be added to manage the capabilities accurately?

You could also try Phil’s Z-Wave Masquerade. That might solve your problem.

You have 2 others choices. Ask Phil to make a change or down load the file from GitHub make the change and add it to you hub using the CLI.

Hey guys,
I’m having trouble adding ecolink motion sensor (pir-zwave2.5-eco) to ST. I installed the new edge drivers. My process:
-i add new device in ST and select “scan for nearby devices”
-i then insert the battery into motion sensor and it starts blinking slowly

It never gets discovered. I also tried adding ecolink sensor, but ST says it’s looking for ecolink zigbee sensor, not sure if it’s a typo? I also tried adding as generic z-wave device, no luck. I tried excluding the devices, but ST exclusion mode can’t see them neither.

Both of the devices are brand new and haven’t been included in any zwave network before. I’m clueless at this point, what am I doing wrong?

Thanks in advance

For mine I had to press the learn button on the back with a pin.

Thought it was the same as resetting battery, but let me tey!

I just tried that and still no reaponse from ST whatsoever. Are you adding by searching for available devices or another way?

Try an exclude first, I am adding with the manufacturer.

I tried excluding, ST doesn’t find anything to exclude