[ST Edge] •• Tasmota Edge •• for Sonoff, Tuya & many other ESP WiFi & HTTP devices - over 2000 Tasmota supported devices

Same problem here. ST v2 hub and recent firmware update (last 5 days) and now none of my Tasmota devices are available to ST.

1 Like

@hongtat hardware version Hub v3 US

two other community drivers install

Aeotec Group - Aeotec Edge Drivers
TAustin Shared Projects = vEdge Creator V2.7 (not currently in use - no vDevices configured)

Another one with issues here (just started today)… The and just the Tasmota devices don’t respont (and the URL page doesn’t load) - they need a HUB reset to start responding

HUB v3 software 000.048.00003 and Tasmota Edge driver 2023-06-18T14:55:55:881083491


Hi, im had the same problem. All devices doesnt work and i cant reinstall tasmota edge drivers. My Hub is V2 @hongtat

I’m having the same issue as everyone else I have to reset my hub to get Tasmota Edge devices to work. Thinking it was my hub, I bought a Smartthings Station. Can I get my Tasmota Edge license transferred to that device?

same I have tried the hub reset a few times still doesn’t work I am also unable to create new devices in the tasmota edge app. STv2 hub

Same here, STv2, need to reset every morning.

I now have 2 hubs

Samsung Smartthings Hub v3:
Locks up and needs reset to work

Smartthings Smartthings Station:
Works as expected

The problem is that my license is on my hub v3


Sorry for the problems.
This is an odd issue, and is not happening to me, which makes it difficult to troubleshoot.

For those having issues, can I get more details from you please?

  1. Hub model
  2. Number of Tasmota devices
  3. Any other community drivers installed
  4. Does this happen after the ST firmware released .048.0003

And for those without issues, can I also have your Hub model, and number of Tasmota devices please?


Hub Model : hub v2, US customer Rev E
Number of Tasmota Devices : 25

  1. Any other community drivers installed:
    These are all the drivers I have installed
    |1|Aeotec MultiSensor 6|
    |2|Aplicaciones Virtuales Mc-(SOS)|
    |4|Envisalink 2.1|
    |5|GE Z-Wave Motion Switch/Dimmer|
    |6|GE Z-Wave Switch/Dimmer/Fan/Outlet|
    |7|Honeywell-Ademco Envisalink|
    |8|MQTT Devices V1.7|
    |9|MQTT Handler V1|
    |10|Onkyo Receiver|
    |11|RTCOA Radio Thermostat|
    |13|Tasmota Edge|
    |14|Virtual Devices|
    |15|Virtual Devices V2|
    |16|Virtual Energy Meter|
    |17|Virtual Things Edge Driver [YG]|
    |18|Virtual WOL Switch V1|
    |20|Z-Wave Bulb|
    |21|Z-Wave Button|
    |22|Z-Wave Fan|
    |23|Z-Wave Garage Door Opener|
    |24|Z-Wave Sensor|
    |25|Z-Wave Siren|
    |26|Z-Wave Smoke Alarm|
    |27|Z-Wave Switch|
    |28|Z-Wave Switch and Child Mc|
    |29|Z-Wave Valve|
    |30|Zigbee Switch|
    |31|Zooz Double Switch ZEN30|
    |32|Zooz Multichannel Switch|
    |33|Zooz Switch|

  2. Does this happen after the ST firmware released .048.0003: Yes, Ithink so, when was this released?

Sharing here that similar problems have been occuring on my harmony device

Mine is one having issues that seem to be hub model specific, but here’s my details:

  1. Hub: Hub v2 US
  2. 7 tasmota devices
  3. No other community drivers installed
  4. 000.048.00003

Hi, I’ve been having issues for the last week or so. Been having to restart the ST Hub almost daily to get these tasmota devices working again. I thought it was just my hub until I search this forum and saw other people are having issues too. Here are my details

  1. SmartThings v3 Hub
  2. About 28 tasmota devices
  3. The driver channels I am subscribed to are:
    AwfullySmart Drivers
    BA LAN Drivers
    BA LAN Drivers - Beta
    GE/Jasco Devices - philh30
    Mariano Shared Beta Driver
    SmartThings Drivers (Beta)
    TAustin Shared Projects
  4. Firmware Version : 000.048.00003

I do not know when that firmware was installed

Thanks in advance for the help

Hi All,

It appears a potential ST firmware hotfix will be rolling out to address this issue.

Release Notes

Fixed a rare issue where LAN Drivers/Devices become unresponsive. If you had encountered this issue, you would have needed to reboot your Hub to fix the problem.


@hongtat Thanks for helping to pursue this issue with smartthings. I appreciate the work you have done and as you continue to enhance the driver.

1 Like

does anyone know if this tasmota device will work with smartthings? Im not familiar with tasmota firmware and am out of my comfort zone here so wanted to check before buying

Using Tasmota Edge to replace Konnected for SmartThings, keeping the ADT system functional. and Building SmartThings status display using Tasmota Edge

  1. I used Tasmota Edge to migrate my ADT alarm system from Konnected to Tasmota Edge for SmartThings. Many people in this group have done this and I am grateful for the advice I have received from this group.

  2. To interface my ADT alarm system to SmartThings I wanted to keep the ADT system operational. I connected the HI and LO ADT alarm system terminals to comparators (LM393 Op Amps). The outputs from the comparators go to PC817 optocouplers which connect to the ESP8266. Op amps have very high input impedance which ensures that there will be minimal impact on the alarm system. Attached is a picture of the interface board mounted in the ADT panel.


  1. Seeing what Tasmota Edge was capable of, I wanted to use it to display the status highlights of my SmartThings system. I set up aTasmotized ESP8266 with 6 different coloured LEDs, 1 DHT2, 1 Piezo Buzzer, and one momentary switch. The buzzer is glued to the bottom of the board and most of the wiring is also on the bottom side. I programmed the LEDs for various conditions. For example when my gate is open the yellow light comes on, when the garage door is open the blue light comes on, etc. I programmed the buzzer to come on if any of the water leak sensors detect a leak. Attached is a picture of one of 2 identical units that I made, one for my office, and another for my shop.



As I previously reported, I have my virtual air conditioner Temperature Unit setting set to Fahrenheit, and the device display keeps showing in Celsius.

I was looking at the new ST Advanced web UI and I noticed that the Preferences temperatureUnit always shows enumeration “Celsius” despite changing it in the app UI (and it reflecting in the UI). Perhaps there’s some issue in your driver that’s not setting the preference, and that’s why the device shows in Celsius rather than reflecting the setting?

When the Temperature Unit is set to Fahrenheit, do you get “Celsius”:“Off” in the Tasmota console log? And if you set to Celsius, does it show “Celsius”:“On” in the Tasmota console log when you trigger in the app UI.

As long as the IRHVAC log in the Tasmota console log matches the selection in your phone app; from the Tasmota Edge driver aspect, it is correct.

04:31:16.988 RSL: RESULT = {"IRHVAC":{"Vendor":"CARRIER_AC64","Model":1,"Mode":"Cool","Power":"On","Celsius":"Off","Temp":20,"FanSpeed":"Auto","SwingV":"Auto","SwingH":"Auto","Quiet":"On","Turbo":"On","Econo":"On","Light":"On","Filter":"Off","Clean":"Off","Beep":"Off","Sleep":-1}}
  1. Hub: Hub v3 AU
  2. 4 tasmota devices (according to tasmota, 3 actually in smartthings because I deleted one during testing, and can’t get it back)
  3. No other community drivers installed
  4. 000.048.00003

Can’t access the tasmota edge ip to check created devices, just times out.