[ST Edge] Roku Driver

Hi all -
For those into advanced networking who want to put your Roku on a separate VLAN/subnet/network/wifi/ssid from your smartthings hub I’ve figured out how to make that work.

  1. In Roku Settings, go to System/Advanced System Settings/Control by mobile apps/Network Access and set to Permissive.
  2. In your router/firewall, permit traffic from ST Hub to Roku in both directions (I recommend DHCP reservations so the IP doesn’t change)
  3. Enable multicast forwarding between networks

    My firewall is a Fortigate, I’m not sure if the multicast-ttl-notchange setting is required or not. That setting prevents the firewall from lowering the TTL on multicast packets as I’ve read some devices send out a mutlicast with a TTL of 1 which prevents forwarding. It’s working so I"m not gonna mess with it. :slight_smile:

Nice to see another fortinet user. Yes, the multicast-ttl-nochange is required to get mcast across vlans…tons of stuff set ttl to 1.

My roku and st hub are on my iot vlan so it just works but this is nice to know. I just spent the time to get casting from a separate vlan working the other day. Happy to share the details if someone wants it.

1 Like

This is important info, so thanks to you both for sharing.

The Edge platform doesn’t allow drivers to change the TTL parameter when creating network sockets, so there is that limitation. I’ve asked SmartThings to provide that option but it’s not a priority for them.

@TAustin What is the cycle time/interval expected before the Roku driver will identify and update an IP change on a Roku device? Say the address changes from 192.168.1.34 to 192.168.1.67, all other things on the network remain the same?

It should be running every 15 seconds to re-discover ‘lost’ devices. If it doesn’t seem to be finding it, try resetting the power on your Roku device.

Sweet! Took about 10 mins for the device to be fully functional in Smartthings on the new IP.

Thank you again for supporting these awesome drivers!

I’m doing some DHCP policy work so I can put all my Roku TVs within a specific IP range and then do some dynamic routing over a preferred ISP through the firewall but didn’t want to have to reconfigure all my Roku devices and automations in Smartthings.

1 Like

@TAustin anyone else reporting issues with Roku devices intermittantly not responding to on/off commands over the last couple of days?

I’m seeing some interesting results where I have routines setup to monitor power on time of a TV and then turn it off after it exceeds a certain timeframe… typically it is after 2 or 4 hours.

What I’m seeing in multiple TVs is that the routine appears to trigger and sends the off command but that command doesn’t actually make it to the TV.

I was able to replicated it manually were intermittently, if I press the on off key on the driver, the TV doesn’t respond, but if I try again 30 seconds later, it works.

I have been having intermittent connectivity to my Roku devices. Most times they show offline. I have given them static IPs when I set them up in ST, but I don’t know what else to check to troubleshoot…let me know some ideas to keep these online.

My Roku devices are falling off too. Most, I can delete and then rescan and they are found… But, it’ll be offline again later. One particular tv, can’t get it to come back.