[ST Edge] Driver for Intermatic Pool Control System (PE653/PE953)

FYI, I’m on iOS.

Awesome work, I’ve logged 2 issues on Github 1 I think might not be easy to fix with what you explained before, but we could use virtual Edge drivers, which ones do you recommend?

The Other one is a profile that removes solar. Also in the tile view why do I see tiles not in my profile?

I see Water temp (yes) Pump speed, no VSP Heater State no heater Heater setpoint no heater.

I’ve followed the posted procedures the best I can tell. I’m having some success but the 653 is missing options or cannot be configured for my pool configuration. Here are my issues any help much appreciated!:

  • The pairing instructions appear to have a lot of problems. I have some notes
  • The 653 responsiveness is slow. Settings don’t sync very quickly.
  • I can’t force or change a profile in settings. Stuck on the default.
  • I can’t select VSP for pump type. I see my systems speeds but I can only pick one or two speeds. When I select VSP app just doesn’t save it, won’t let me select it, or cursor spins and gives up. I can see my VSP speeds.
  • Shifting from config/operation hangs and lags.
  • I see network not available sometimes but action may work.
  • I have no need for solar temp, or freeze features (in south florida).
  • I can’t flip between pool/spa even though I have “both” selected in app. I need to shift actuators for valves to cause my heater temps to kick in and water to circulate correctly.
  • I can’t add the 953 remotes I have to ST. I have two of them.
  • I don’t have a booster/cleaner - the setting does adjust though.

I really don’t want to damage any of my equipment so any help the community can provide would be fantastic. Thank you!!

Is there a particular version of the firmware for the controller required to work? I enrolled via the channel, but no matter what I do, the controller only picks up the driver for the remote control (PE953) and not for the actual device (PE653)

Sorry for delays in responding. Busy time of the year for me.

I’m not using any of the community-made virtual device drivers, and haven’t seen that any of the authors have posted code where it can be reviewed, so I don’t really have anything to base on a recommendation on. It’s possible though that the virtual switches you can now create through the CLI will satisfy the Alexa linkage. Those run in the cloud (but so does the Alexa integration), so there’s a trade off.

Not guarantees that I’ll be able to get to this before August, but I’ll add it. Which tiles would you want to see on the dashboard for that profile? Right now all the dashboards are the same simply because I wasn’t sure which to put up there for the different configurations people are using. The dashboard is either small (1 tile) ot large (2 to 5 tiles).

I ended up with this [ST Edge] Virtual Things Edge Driver - #44 by Paul_Oliver
The main problem is having to create “follow status” automations, 2 per status, but work great and the intermatic controller like this is a LOOOT faster than in the cloud, before alexa operations had 5-10s delay, now there is no noticeable delay.

On the getting on this on August note, the fact that you are helping us keep this controller alive already great :slight_smile: .

So right now the only useful tile is Water T, I guess everyone has Outside T and depending on your settings Circuit 1 is always the pump and 3 pressure side cleaner, it’s a hard bargain, I guess it would be profile dependent?

The 653/953 hardware is ancient z-wave kit with heavy use of proprietary commands, so don’t expect blazing fast. If there are particular pain points where you’re seeing lag, then I can try to address them, but there are limits due to the hardware. I find the 953 control of the 653 to be laggy at times even when I have the two units right next to each other.

I’ve seen the VSP setting in another integration, and therefore added it to this one, but it’s definitely not present on every firmware version. Mine is 3.4 and similarly doesn’t accept the VSP setting, but my VSP works with it set to One Speed Pump.

You’ll need to be in config mode to swap profiles. Switching between config and operation modes may require force closing the ST app, and possibly clearing cache. This worked very well a few months ago, but more recent app updates have made it a bit clunky.

Most of the app errors that talk about network error or trouble connecting really mean that the device was “too slow” to update its status after you pushed a button in the app. This device is going to be on the slow end of responding due to its age and complexity, but I don’t have any way to change what the app considers to be “too slow”. I may be able to optimize some of the polling though.

What would you want included in the profile? Is there an existing one that nearly meets your need, with the exception of displaying solar? Since the freeze features are all on the config screen, those will remain there.

Do you have the expansion module (I thinks the product number is PE5043ME), or just the 653? Are you able to toggle Pool/Spa with the 953?

The gist of those instructions for pairing everything is that you:

  1. Add the 653 to ST
  2. Add the 953 to ST
  3. Add the 653 to the 953
    The order is important, since ST is the primary controller of your z-wave network. Both the 653 and the 953 need to have been reset before going through the process. Make sure you’re pairing in close proximity and check your “No room assigned” room to see if any devices popped up there.

I have firmware 3.4, so I can’t guarantee what will/won’t work outside of that, but I’ve tried to follow what was done in the past to support other versions/configurations. The firmware version really shouldn’t impact joining though, unless it caused your device to have a different fingerprint from what I’d expect.

Is the PE653 joining with a DTH? Or a different Edge driver? Or not at all?

I haven’t played with Rules much, but this would be the other option:

That’s exactly the challenge… This device is too configurable and the ST app is too rigid. Come up with your pick, and I’ll set that profile to match your preference.

The 653 joins as if it’s a 953, so it’s like I have 2 remote controls, and not 1 remote and 1 controller. I even try going into the driver settings to see if I can switch the driver for it to the 653, but it says “no other drivers available”. Almost as if the 653 driver didn’t register properly. I’ve even tried removing all the devices, uninstalling the drivers, and starting over, and no luck

It sounds like the 653 fingerprint isn’t being received properly by the ST hub. Are you pairing the 653 as close as possible (preferably within a few inches) to the ST hub?

The full explanation of what I believe is happening if you’re interested… A failed fingerprint shows up as 0000/0000/0000, while the 653’s correct fingerprint is 0005/5045/0653. The 653 driver currently can only be used with devices that match that fingerprint. Meanwhile, when the 953 is added to the ST z-wave network it always fails to fingerprint and shows up with 0000/0000/0000, so that’s what the driver for the remote is set to work with. If you’re unable to get your 653 to join properly then I may be able to work around it with a capability-based fingerprint.

I had problems with that first step too. I think mine said “unpair” or something like that and it all worked.

My SmartThings Panel in “favorites” started displaying status (iOS). But the status is often stale and does not match status when you click the panel to get into the detailed view. Not a big deal just FYI.

I modified my Automation of the buttons on the PE653. After a power failure the PE653 powers up with all buttons off. The pump remembers its last state before power failure. But my Automations turned it off when all buttons came up Off :). So now, if all buttons are off, my automation steps do nothing. To turn it off, If both Speed 1 (button 1) and Speed 2 (button 2) are ON I shut the pump off :).

So I have 2 bits for 4 states

10 = High Speed
01 = Low Speed
11 = Pump Off
00 = No-Op (don’t change speed)

This works flawless and almost instant. I can click the buttons on PE653 in any order and it always seems to do the right thing. I almost never need to pickup the PE953 which is primarly what I used it for.

I like to use high speed when swimming or adding chemicals to skimmer. Low speed 24/7 other wise. And Off when putting Solar cover on/off.

It’s programmed to go to low speed and turn on Circuit 3 for 15 minutes a day to add Chlorine to the pool. That also works flawless and the main reason I set this all up.

P.S. I always turn off power to the pump if serving the pump and not depend on automation to keep it off.

I send an SMS based on monitoring the 4 states of the two switches.

Sorry for the late response. I tried it again within a few inches and it was the same behavior. What would it take to get the capability based fingerprint working?

I’ve pushed out an update to the driver, which should hit hubs within the next 12 hours. If you have the CLI installed, you can also force a driver update immediately with smartthings edge:drivers:install. The new version is dated 2022-08-15T23:19:50.09859054.

New profile created - P_-SSSSS---WA_. Dashboard tiles for all profiles should now match the capabilities that each profile has. Hopefully the capabilities that I chose to display are useful ones.

This is now implemented. If you already have the PE653 joined with an Edge driver, you’ll hopefully now see the correct driver as an option to switch to in the app. If you do a fresh join, the PE653 will most likely join using the PE953 driver, and then you’ll need to do a driver swap.

Awesome work. Thank you very much. How do we at least send you a virtual beer as thanks for all this work?

It should have read do we have a way to at least send you a virtual beer :stuck_out_tongue:

I’ve just installed this Edge driver. Thanks for your great work on this! When I create Routines using the PE653, my only choice for Circuits 1, 3 and 4 is “On or Off” (I have a heater, so only 4 circuits). However, Circuit 2 gives me three choices On or Off, On and Off. Why don’t the other circuits have the separate On and Off choices? I really need them for my Routines to function correctly and to access the added Delay and Auto Off options.

If you’re using an iOS device then you’ve run into a known bug in the app. I can’t immediately find the topic where it’s been discussed, but it affects any multi-component device. You should go through the prompts in the app to report the bug to customer support.

If you have any Android devices then you should be able to use those to set up your routines, or I’ve seen people comment that they were able to use an Android emulator as a workaround.

Thanks for the very quick response! I am using an iOS device. I’ll try on Android. Thanks for the tip!

I just realized I probably wasn’t posting in the most pertinent thread, so at risk of cross posting, I’ll delete the other post:

I have gone through the instructions, Pairing, etc., and am having mixed results.
As someone pointed out, there are some inaccuracies in the pairing instructions which I will reflect my interpretations in the steps below:

  1. Loaded the edge drivers for 653 and 953 from the invitation page.
  2. on the 953 I chose remove device and hit the include button on the 653… success
  3. on the 953 I chose reset controller, reset network & config… success.
  4. from the ST app I clicked add device, then on the 653 pushed the include button… ST found the Intermatic Pool controller, added automatically, option to rename was present, I left it alone.
  5. on the 953 I chose Controller copy, receive network only… fail. After a couple minutes of “waiting for include” it finally times out with a “fail” message and returns to the default menu list. wash rinse repeat and no pairing of the 953.

I’ve tried subsequent steps with no success… battery removal, hitting the include button on the 653, etc… can’t get the 953 paired into the config… The ST app works to control the 653, pretty much. I say that as sometimes the circuit on button will spin for a long time with no relay click and I’ll get a network timeout error… but then after a minute or 2 the relay clicks… other times it clicks right away and the status is updated. Every time I go into the Intermatic device on ST I get “This device hasn’t updated all of it’s status information yet. Check again later”… this appears at other times as well while in the device UI.
This is on FW 3.4 on the 653 and the 953 shows a “34P” in the upper corner, which I believe reflects its FW.

Also I have the v2 hub about 1" from the 653 and the 953 during all of this.

I have created virtual switches for each of my implemented functions (Pool Pump, Pop-Ups, Water feature, Pool light) and they are all working via Alexa commands… just no 953 :frowning:

I believe that is the current way the app indicates that the device still has some null attributes. The app has a bit of a thing about those. It is quite common at the moment because the synthetic events that initialised the attributes on freshly joined devices have been temporarily disabled in the stock drivers.

1 Like