[ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

Hi, just finished about 10 hours of manual configuration for the mesh network and various door locks on a fairly large building. There was some lock repair, mainly on the schlages; however the philh30 drivers picked up everything just fine on all models.
The questions appear around my use of Enbrighten ZWave Plus Plug- In outlet. The family appears to belong to the GE/Jasco plug-in switch group.
Fingerprint is listed as: 0063-5052-3133. Profiled as a switch-binary. Also seems to be grouped in the 0063/5052/* family with the smartthings channel. Its function is mainly to build out the mesh network as a zwave plus on/off plug-in switch and repeater.
As mentioned I can not find that exact fingerprint in the smartthings edge drivers, nor with philh30 drivers published list and nor with Mariano’s. The Enbrighten picked up Mariano’s driver, switch plus child, upon inclusion. I left it alone. Think I need a driver here for full function -any ideas?
Further, of the 5 leviton’s (DZPA1) placed, 4 seem to act correctly - but one is giving me a reverse polarity, ie, OFF on controller is actually ON device. Its listed as 001D-3601-0001. Any advice or help here - how do I get the correct driver (picked up the standard edge driver) for that exact fingerprint?

Hi all,

I’ve got a GE smart dimmer switch (14294) and have installed this, but am not seeing options for buttons when I try to add a new routine under the “If” condition - does anyone have any ideas?

Hi. I have half a dozen Homeseer WD100+ with companions that used to support double and triple tap. ZWP is another name they’re sold under. Has anyone tried this driver with those, or tried something else that supports 2 and 3 taps?

The devices that work with this driver are documented in the first post. A little searching on this forum would have pointed you to a driver made for your device. If you need support then post there or create a new topic - this thread is specific to devices manufactured by Jasco.

1 Like

For some reason, ST assigned a Leviton DZPA1-2BW on/off switch to this driver, and as a dimmer switch. The relay “clunk” is definitely of a switch, so I’m not confused about it. I have a few others in the house that are correctly assigned as a zwave switch. I’m thinking back a few years now, I originally had a GE/Jasco plug in dimmer in this location that died, and I had just taken the shortcut of swapping the ZWave Network ID in the IDE to preserve automations.

Any option other than deleting/re-adding the device at this point? I’m assuming there’s no way to adjust the device fingerprint/force a relay profile.

If there is a driver that supports your device, you can change to that driver in the mobile app, the community developed ST API Browser+, or the ST Advanced Web App.

Yes I can change to it, but it still presents controls in the app as a dimmer, although it is a switch/relay.

What is the Mfg Code (fingerprint) for the device?

I think I can only see what ST thinks the fingerprint is (again, I believe this is the fingerprint of when the original Jasco was used for this device ID), not what it actually is. Maybe if I do a Zniffer (been putting that off) or is there some other way of actively querying the device itself? I can give you the fingerprint of what another device of the same model is…

Actually I think this is in the wrong thread, I’ll post this on the migration thread…

It’s a pretty easy thing to query a device fingerprint, but SmartThings has made the choice to only populate metadata when a device is first joined. All of those situations where people have all zeroes for a fingerprint and we say it was a bad join could be solved by querying the device if SmartThings would actually update its metadata. Only option to get the right fingerprint is to exclude and re-join. Forcing yours to be something it’s not would require a custom driver just for it.

2 Likes

has anyone been able to recover speed control in google home? jasco kindly replaced my older fan control that freaked out then died, but neither the new one, or the older model i still have, both with updated drivers do anything other than on/off anymore

1 Like

So, it seems the new Philips warm glow LED bulbs don’t dim like the old ones do. With the old ones, the switch could dim all the way down to 1% and it would still be lit, albeit dimly. The new ones cut out around 7-8%, which is super annoying.

It seems some GE/Honeywell/Jasco/Whatever dimmer support setting a minimum dim level, and based on another thread (Jasco dimmers support minimum dim and true switch mode), it seems to be based on firmware version rather than model number? And, it seems like this driver enables it based on model number, rather than firmware version?

One of the three dimmers I’m dealing with seems to have that option enabled (0063-4944-3339), while two do not (0063-4944-3031). I’m curious whether there is a way to make the two 0063-4944-3031 work with this option.

First question I have is how to find the “raw description” field that would contain the firmware version. It was in the old IDE, but doesn’t seem to be in the new “advanced” web interface, unless I’m missing something. And, of course, Samsung completely disabled the IDE, so I cannot figure out a way to get this info.

Any help appreciated. Thanks!

This is your device, model ZW3005 / 12724:
https://products.z-wavealliance.org/products/1197

Here’s the Jasco firmware repo, and I don’t see anything available for your model:

If you look for the z-wave logo on your device, I expect you’ll find it just says Z-Wave and not Z-Wave Plus, which will confirm that it’s part of the ancient generation of Jasco devices. If that’s the case, I’m pretty sure your device is incapable of receiving firmware updates. The device does what it does and will never do more.

To confirm the firmware version, I have a driver called Z-Wave Explorer that should be in this channel. If you swap the device to that driver it’ll show the firmware version (you may need to restart the ST app to get the display to update). Note that that driver doesn’t have any switch capabilities, and I’m not sure what will happen to any automations that include a device that you swap to that driver (ST used to delete them, but supposedly is better about that now). Also note that the firmware version stored by ST (and shown on the old IDE) is the firmware version that was installed when the device was first joined. That caveat only really matters if you’ve managed to update firmware on a device while it’s joined to ST (which is itself a challenge since ST doesn’t support z-wave firmware updates), but the Z-Wave Explorer should query the device and (eventually) show the correct firmware version.

If you’re convinced there are more configuration options for your device and want to try sending it commands that probably aren’t supported, you can swap to Mariano’s configuration driver and play around. If you need support while doing that, be sure to post in the topic for that driver.

My recommendation though… If you want your device to do more then you need to buy a more capable device.

Thanks so much for that helpful reply! I can confirm that the older switches do not support the command by using Mariano’s configuration driver. Interestingly, the firmware version reported by your explorer driver and the Mariano’s config driver are different. Your driver shows v3.35, and his shows v5.54.

As for automations, I only had automations of those switches via SmartLighting, and thankfully they were not affected by what I did. It seems if they’re in standard ST automations, it’s a different story.

At the time I bought these switches, they were they only thing available. Maybe one day I’ll switch them out for the Z-wave plus versions, but I hate doing electrical work, haha!

EDIT: Does anyone know if they’ve made it easier to switch out z-wave devices? I know they had the capability in the old app, but not in the new app. Any changes? Thanks!

Could the 5.54 have been something different, like z-wave protocol version? I have 5.54 on a few z-wave plus dimmers I bought in late 2020. I’m pretty sure those even shipped with an earlier firmware that I upgraded after Jasco started making firmware files publicly available. I’m assuming based on your fingerprint that yours would have to be a purchase in mid 2010s, maybe earlier. The 3.35 should be correct.

There are some cool new options out these days, especially from Inovelli and Zooz.

They haven’t. Deleting the old and adding the new are completely separate operations, no option for a z-wave replace. Many people use a virtual switch as a placeholder in their automations to make sure nothing gets messed up. Or keep the old switch in service while joining the new one.

It is a little easier now, as removing a device leaves the old device as a placeholder with a warning on the routine and the device itself. The virtual switch is no longer needed.

2 Likes

It definitely said firmware or fw version; I don’t remember for sure which. I suspect the v3.35 is the correct firmware version. You’re right on the time frame.

I’ll probably stick with the Jasco versions, as I’m comfortable with them, and I like all my stuff to match. I ordered a new pair of Ultrapro dimmers off Amazon, so I’ll install them soon.

That’s ashame. I hate when companies make things more difficult in their attempts to “upgrade” and “improve” things. I’ve been tempted more than once to move to another platform like Hubitat, but that would be a large hassle in itself. And, when it works, I do like the ST interface and platform. When it doesn’t work, I want to defenestrate the hub…

So, get this. It looks like I never had to replace the switches to begin with.

I put new switches in place, then did a force removal of the old ones and setup the new ones. All good, and all the options showed.

I did notice the old ones showed v5.4 on the back, and were also Z-Wave Plus; I thought this was weird. So anyway, I decided to add some smart dimmers in other rooms that didn’t have them. The old switches worked, so I figured I may as well. Once I set them up in the new rooms, I also had all the options, including minimum dim level.

I think I previously replaced switches in the original rooms due to ones that failed, but used the replace option that was there in the old app. Would this be the reason that ST still had the old data, and therefore caused the drivers to think it was a different switch?

EDIT: Now I’m thinking about it, it seems that Mariano’s configuration driver displayed the actual firmware version of the device, whereas your utility showed what ST thought it was?

Frustrating, but, oh well…

Yes. The old replace option didn’t update fingerprints. That didn’t matter in the past but the device fingerprint is now used to determine just about everything in the new Edge platform. The fingerprint you provided (0063-4944-3031) is ancient, so ST thinks you have ancient switches. The only way to get ST to see your device properly is to exclude and re-include the device.

I have 2 GE switches (both ancient) that are easy to check right now, and the version on the back of each is a hardware version. Neither have a firmware version printed on them.

@philh30 Could you please add Fingerprint 014F-5457-3033 - this is a generic Z-Wave Dimmer Wall Paddle Switch. Thank you!