[ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

Seems fixed now, was able to accept invite, enroll and install, will try to add back my ZW3010, I didn’t like how little steps there was when ramping up and down, not smooth unlike the Inovelli and Zooz

I have the UltraPro which is the exact same ZW3010, also only have fast and slow ramping, so there’s no advanced dimming rate adjustment in our firmware? It is reported by the FW itself or programmed into the driver?


Dim Rate Adjustments
Both the number of steps (or levels) that the dimmer will change and the timing of the steps can be modified to suit personal preferences. The timing of the steps can be adjusted in 10-millisecond intervals. As an example, the default setting for parameter 8 is “3”. This means that the lighting level will change every 30 milliseconds when the Dim Command is received. A value of 255 would mean that the level would change every 2.55 seconds. Combined, the two parameters allow dim rate adjustments from 10 milliseconds to 4.2 minutes to go from maximum-to-minimum or minimum-to-maximum brightness levels.

1. When Receiving a Z-Wave Dim Command

  • Parameter 7 (number of steps or levels)
  • Parameter 8 (timing of the steps)
  • Length: 1 Byte
  • Valid Values:
    • Parameter 7 (default = 1) Valid Values: 1-99
    • Parameter 8 (default = 3) Valid Values: 1-255

2. Manual Control Dimming (pressing the Dimmer’s button)

  • Parameter 9 (number of steps or levels)
  • Parameter 10 (timing of the steps)
  • Length: 1 Byte
  • Valid Values:
    • Parameter 9 (default = 1) Valid Values: 1-99
    • Parameter 10 (default = 3) Valid Values: 1-255

Ok I see it now, from Product Configuration Capabilities
Only shows fast/slow ramping

This was the case, it was up an running on 1/25, it was down for a couple days.

I recently bought some Feit 100w leds for a ceiling fan and they flickered like crazy with my original circa 2016 Z-wave GE dimmer at anything below 90%. I replaced it with the newest model GE dinner and the flickering went away completely. But when my routines turned the lights on in the morning the light would ramp up and then turn off around 40% and I had to manually turn the light off and back on which was super annoying. Switched to this driver, set the dim up/down to slowly, all problems went away. Haven’t switched all my switches to it (25+) but as I have issues I will.

Thanks @philh30 for your efforts. Once my EcoLink tilt sensors get migrated over I’ll use your masquerading driver for those and then my system will finally be complete how I want it setup.



I have a switch with fingerprint 0063-4952-3032. I switched it from ST’s stock Edge driver to your driver but association group settings are not showing up. When this device was on a DTH I was using a community version and was able to set association info so I know its firmware supports it.

Any ideas? I will also add that when the switch was auto converted to ST’s Edge driver it lost the association I had set up when I thought it should have retained it’s settings. Is it possible this switch is now just faulty (it otherwise works).

Try using the Z-Wave Device Config Mc from @Mariano_Colmenarejo to configure the association groups. Switch to his driver, change any settings you want, and then switch back to the GE driver from @philh30.


I’ll give that a go. Thanks.

UPDATE: That worked, thanks again.


Glad that worked for you in the short term. Maybe @philh30 can take a look and see why it’s not showing up in the settings with his driver.

1 Like

That looks like a very early model… Which association groups are you able to set?

Honestly, I’m not sure. I think the DTH settings used to say but the driver I just used didn’t indicate.


I seem to recall that in the custom DTH for the GE/Jasco dimmer/switch devices there was a setting for whether changing the dimmer level would turn the switch on or not. Is that something that could be added to the Edge driver?

Adding +1 to @Brannon-Z request for an Edge driver for the GE Enbrighten Z-Wave Plus Smart Plug with 2 USB Ports. Product Identifier: 28177/ZW4105

1 Like

@philh30 Thank you so much for writing these drivers. I loaded your driver for my GE/Jasco fan controller, as the ones Samsung pushed down to me wouldn’t integrate with Alexa for speed control. Now that I have your driver in place, I can ask Alexa to set the speed to low or high, no problem, but not medium. Says “I can’t set fan to that setting.” If it’s on low, I can say “Alexa, increase fan speed” and it changes to medium, but that’s a bit painful.

Please let me know if I didn’t do something correctly, or if possibly a fix is coming.

1 Like

So my GE fan controller hasn’t migrated yet and I’ve noticed the same behavior from Alexa. I can no longer tell her to set to Medium, only low and high. I can say 50%. Seems like this may be an Alexa issue and not the Driver.

It was working and stopped when it migrated to the stock Z-wave driver, immediately after changing to Phil’s driver it was working again. So I would say it’s a stock driver issue.

1 Like

Alexa requires the “dimmer” capability in order to control the fan level. So one might argue that it’s really more of an Alexa issue, although ST could easily add this same capability to their stock driver.

Was curious if you had implemented Zigbee Switch support for the Enbrighten 43078? It’s not loading a default edge driver

For more info on this model: In-Wall Smart Switch with Energy Monitoring (Decora Style) - CSA-IOT

n/m looks like you just work on zwave drivers

@Mariano_Colmenarejo does a lot of work in the Zigbee world. Check out his drivers.

Hi Phil,

I posted about my Jasco 14285 over here: https://community.smartthings.com/t/jasco-14285-40-amp-outdoor-switch-and-power-metering/243239/24 and was wondering if there is a way to increase the frequency of the reporting value for power. The minimum is 5 min.

The 5min reporting still doesn’t seem to be enough. The well pump runs for about a min or two max. I do get a trigger now and then if the timing is just right, but most times not.

What would my next steps be to try to get the driver to poll the device? Once I setup the SmartThings CLI, where do we go from there?