ST-Community-Installer fails with network connection error

So I’ve been trying to get the ST-Community-Installer to run, but I keep getting the error:

We’re having trouble connecting. Check your network connection and try again.

The thing is, the installer loads. For a second, I can see the Welcome screen, then it vanishes and that message pops up. I’ve included a screenshot.

Using the Android app version 1.7.47-22

It seems to work in the simulator, but that’s about it. Is this an old way to do things? All the tutorials on this, seem to use the ‘classic’ Smartthings app…

1 Like

Yeah, I bet this will only work with the Classic app.

Works fine for me using new app. Could try reinstalling the app and restarting phone too?

1 Like

I am getting the exact same issue as the OP. I’ve tried restarting the phone and force closing the ST app. If you figure out a solution, please post up. I’m new to ST and know just enough to be dangerous…

I tried this, to no avail. Not sure what the issue is ATM. I am still learning! :slight_smile:

Have tou enabled OAUTH for it ?

Yep. oauth is set up. Not sure what’s going on ATM, but for the moment. I managed to get other Device Types installed and working (that I was going to use the community installer for), so it’s less of an issue.

Thanks for the reply. :slight_smile:

Can confirm it is still not working. :woozy_face:

Classic or new app? If new app, are you running any malware blockers on your home network such as adguard?

Sorry, I am using the new S.T. app and not running any adblock or network security.

As the OP has stated, the ST-Comm Installer seems to start running in SmartApps then suddenly crashes as soon as the set-up screen loads.

have you linked your github account in IDE?

I do run Pi-Hole, but learned awhile ago to disable this when I troubleshoot issues.

Yes, I have got my GitHub a/c connected.

Also, I have tried disconnecting it and reconnecting it in IDE, bit it makes no difference.

I have tried wiping the partition cache in my phone but still, nothing seems to work.

tried running it in the classic app?

Just downloaded it, installed the classic version. Added the community-installer in the classic IDE log-in and tested it.

It works in the Classic app fine as you can see below, but not the new S.T. app version 1.7.47-22 :thinking:

last thing I can think to try … switch your mobile device to cellular data only (disable wifi), force quit the new app and open it and try community installer and see what happens. Other than that, you can use the classic app for the community installer. and post in the community installer thread so the development sees you are having issues.

For me it worked perfectly, just needed to enable oauth

I have the same issue. The new application gives me a network error. The ST-Community-Installer shows up but it’s not configured. If I try to configure it I see the “Welcome to the Community Installer” page for a moment and then I get the pop-up telling me there’s a network error and it kicks me out. The SmartThings Classic application works just fine. Now, after having successfully setup the ST-Community-Installer with the classic application, I’m able to use it in the new application.

Thanks. I’ll give that “work flow” a test and see if it works for me.

Just tried it and it did not work for me unfortunately