ST Arrival Sensor keeps dropping off

Yes this is another Arrival Sensor Post (sorry not sorry)

I have an arrival sensor attached to my dogs collar for various automation routines to run differently depending on if the dog is at home or if he is out with us.

Now when I first add the device it all seems to work fine for a day or two (changes status to away when he’s out and present when he is back), but after a day or so that all seems to change, the sensor just disconnects from the hub and never reconnects, I need to remove the device and add it back on again. And so the cycle repeats

I knew I would get drop outs as they are not the most reliable of devices and I coded for this in my automation. But it is rather frustrating that this is happening, anyone got any suggestions?

These devices can be very reliable when setup correctly.
Start here:


Then over here:

You can also try replacing the battery, not all batteries are created equal, regardless of how new they are.

Sometimes there is nothing you can do about it, some members have found they have a neighbor with high powered wifi blasting on the same frequency as their ST zigbee and diplomacy failed to resolve the issue.

Finally, you don’t have to remove a zigbee device to re-pair back to the hub. Just put the hub into discovery and push the button on the sensor a few times and it should pop back in.

What is considered a repeating device. I have window and door sensors in just about every room. Are these considered repeating or do they need to be mains powered. None of these devices drop offline.

I am thinking that it could be due to my dogs violent shaking whenever he stands up. So I have removed it and left it sitting at the side of my chair to see if it still disconnects. I might just attach it to his lead.

I still have it’s original battery. I’m guessing the one that’s provided from factory is decent. But I might try changing it anyway.

I did try just adding it back without removing it and the discovery mode finds the device but when I save it back it either is immediately offline or goes offline within a few seconds. So the only way I can get it back online is by removing it and adding it again.

The other thing I’ve noticed is that the “beep” isn’t working on it. Maybe it’s faulty?

How intelligent is your dog? Because some users like JD train them to activate an Echo Button… That would be more reliable when they come and go.
SY355

Love this idea, hadn’t thought of it, we have toilet bells on the back of the front door that we taught him to ring when he needed to go out rather than bark or scratch the door :). these might just work…

Battery powered devices don’t repeat, they are typically sleepy devices.
Only mains powered devices repeat, though some smart bulbs don’t.

Yes, it should beep you might want to contact support.

1 Like