SOLVED - Gremlins & My Unstable ST Network

If you get it to work let me know. I still have a tablet with v1 app and after last update cannot use it. It doesn’t even let me open a room. It crashes instantly…

Hmm. To be honest, I’m a little leery to do anything that could cause ST instability again. That last 11 days or so have been a horror show that I’m not too interested in repeating.

Nevertheless, I do have the v1 app installed on an iPad that I have used successfully to set which attribute of a device shows up on the Things list next to the device’s name even after moving my iPhone to app v2.

I have an Iris contact sensor in my beer fridge. I don’t often need to know if the fridge is open or closed, but I do want to know the temp inside the fridge. On Saturday last week, I used the v1 app to click on that little circle thingy - don’t know what that’s called - on the sensor’s screen so that temperature would show on my Things list instead of the open/closed status. I really wish this feature would come back to the app.

Andrew

1 Like

That’s what I’ve been trying to do too. As soon as I click the gear, the app crashes.

I am SOOOO happy that my system is now 100% normal. The last few months were very frustrating.
I actually never knew that there were so MANY happy users…I only read the blog complaints.

Like I mentioned I now have my life back. I am retired and I was spending a LOT of time trying to work out the random timing & sensor issues etc.
I tried to keep a simple setup (I thought), but I should have gone to Smart Lighting a long time ago.

I’m sure Shortcuts and using them to manage devices was the biggest part of my problem.

I am now ready to resume buying more devices!

Dick

1 Like

So, I kept my dashboard…but I removed all “old automations” where I triggered stuff from the device and its settings it self, and went to rule machine and smart lighting for majority of my apps.

Things are well.

Goes back to cleanup perhaps. But I still have my dashboard and well functioning system (in relative ST terms)

1 Like

Does this just have to do with the old version of the app?

Users with a V2 hub, do not have Shortcuts.
Users with a V1 hub may have Shortcuts, but they will loose them if they delete them. They cannot add more new shortcuts.
(That’s my understanding!)

I can confirm that I cannot restore my dashboards. They are gone gone gone. :frowning:

I have a v1 hub and app v1.7.3 (iOS) and was not able to add any dashboard shortcuts back. When I go to the Dashboard in the app and push the + button, nothing happens.

On the plus side, I was able to hit the gear thingy to change the default sensor attribute shown next to my device on the Things tab without the app crashing like @SBDOBRESCU is seeing happen.

1 Like

I was just grasping at anything that would make me want to turn my hub back on again

Yup, I noticed that it happens only on ST stock device types. Perhaps the latest update got rid of that capability.

You’re right that there’s a difference between V1 and V2 with regard to shortcuts, but it’s about the mobile app, not the hub.

Users who had a V2 hub and the V1 app had shortcuts. If they then updated to the V2 app, they still have their shortcuts,as long as they haven’t deleted all the devices for any one shortcut. But once they’ve deleted everything, the shortcuts are gone no matter what version of hub or app they have and they won’t be able to get them back.

Those who start with the V2 app, regardless of which hub, won’t have shortcuts. This would be true for someone who bought a used V1 hub today.

Lots of examples in the following thread, including screenshots:

Didn’t we have to delete everything to migrate to v2 hub?

Yes. But if you changed hubs before v2 of the app came out, which many of us did, you had the v2 hub and the V1 app. Wouldn’t happen now, though.

  1. I had 2 instances of Sharp Tools installed?? What the H___! I deleted 1 instance.

Thanks! Didn’t even notice there were two in mine. I’m sure it helped fixed a problem with me getting into routines to edit them.

Joshua Lyons clarified the double entry for me. Here is his response.
"This is expected if you have been using SharpTools for a while. The SmartApp that support SharpTools was officially published in 2016… as part of that, you probably recall going through a migration process in the SharpTools app. What this migration process was doing is moving you from the old unofficially published SmartApp to the new officially published SmartApp.

The legacy SmartApp would have left a slightly grayed out version of the SharpTools logo in your SmartApps list and the new version would be in full color.

1 Like

UPDATE:

Rock solid perfect operation since I deleted my Shortcuts.
A stable system has allowed me to:

  1. Activate my Smart Home Monitor with confidence that it will work properly. I even took a 3 day holiday and left the Monitor armed!
  2. Refine my Presence Detection. I don’t use ST Presense detection. Instead I use Tasker SSIDNEAR feature to issue the “Goodbye” and “I’m Back” routines. Tasker also displays a popup on my smartphone whenever ST has a Mode Change…confirms the change! My Leaving Home and Arriving Home is working quite well.

My home automation system now has a Security component which includes a strobe alarm, siren alarm, and IP camera!

Maybe it was removing the stuff in the dashboard that helped then. I don’t have a lot of problem with ST, but when I do it sure is frustrating and I don’t take a methodical approach to figuring out what’s wrong.

UPDATE#1: Gremlins Returned – Smart App conflicts:grimacing:
(Similar to what others have noted)
After deleting my shortcuts I had a period of rock solid operation. I soon started building my first Smart Lighting automations to replace settings in my defunct shortcuts. Before long, I began to experience failures with timed routines. I must have created more “crossed wires”!
I noticed that I now had Smart Lighting automations for Sunset-to-Sunrise lighting, AND After Dark automations with another Smart App…crossed wires? I removed 2 occurrences of the earlier smart app…and now use Smart Lighting for all my lighting automations. This appears to have solved one of my biggest gremlins … firing the Good Night routine. Whenever I have crossed wires, this seems to be the most effected routine.

UPDATE#2: Possible Gremlins – within Smart Lighting
While I was setting up my Smart Lighting automations, I noticed that my outdoor lights had BOTH motion automations and timed (sunset-to-sunrise) automations associated with the Same Devices. This looked like more potential gremlins. I changed my settings so that there are no conflicts between Timed vs Motion automations.

These same devices (outdoor lights) are assigned to my Smart Home Monitor. However the motion sensors are different. (security vs convenience). This does not appear to be a conflict.

I am going to post these updates before I finish monitoring the results. I will re-update after a few days.

C’mon guys. Schedule and routine is a known issue at ST backend. I have both dashboard and none dashboard at 2 different locations. Hub v1 and hub v2. It’s not the dashboard that’s causing the instability. If you like the dashboard then don’t delete it or it will be gone forever.

2 Likes

UPDATE#3: Stable Again after 3 days
I have returned to stable operation. 94% of my timed automations have worked properly…even Good Night. Of the 16 timed automations for the last 3 days, only one failed (“Lights off at 10pm” failed once in 3 occasions). Clearly my efforts to simplify lighting schedules and motion sensors have impacted MY performance. As I speculated in the beginning of this post, there may indeed be issues with ST servers, which might explain the single failure. But overall, this is a big improvement for me. Time will tell if this solves all my issues!
Also I do not miss my old shortcuts!
I might mention that from day 1 of my system, I have maintained a color-coded Excel spreadsheet for my ST configuration. It has given me a good visual representation of my system, and has helped me identify where my device conflicts may have occurred. I only have 18 devices.