SOLVED - Gremlins & My Unstable ST Network


(Dick) #1

V1 Hub - Android User
Like many others, I have experienced many symptoms of instability the last several months! I have been unable to determine if it’s my ST setup, or problems with the ST servers. I have come to the conclusion that it may be a combination of BOTH.

My symptoms have been:

  1. Timed Routines – failed to execute (e.g. Good Morning, Good Night, custom routines) … or they worked randomly.
  2. Timed devices – failed to execute (e.g. outlets) … or worked randomly.
  3. Sensors – failed to sense motion & turn on lights, etc. … or worked randomly.
  4. Sensors – failed in combination with smart apps (e.g. lights after dark).
  5. Tasker fired routines were ignored by ST … or worked randomly.

Then I realized that I still had Dashboard SHORTCUTS left over from my V1 ST App (android). Some of those shortcuts (Devices) had sensors attached, and timed events attached. These settings may have conflicted in some cases with similar settings attached to my THINGS and ROUTINES.

I decided to:

  1. Remove all SHORTCUTS on the Dashboard.
  2. Install the app Smart Lighting and use it to define Automations for timed devices etc. (Sorry, I’m a late comer to the party)
  3. I had 2 instances of Sharp Tools installed?? What the H___! I deleted 1 instance.
  4. Applied the “Done” reset to several Things, Routines etc.

My system operation improved immediately. Timed events are now working. Sensors are detecting motion during the day and after dark … correctly. Lights are operating as expected. I have backed-off on my Tasker fired events, since ST is now working.

I’m a little embarrassed. Did I do myself in? Did I cause “short circuits and crossed wires” in my ST network? Am I the gremlin? Time will tell… its still Early Days. I will wait awhile longer and observe operations.

UPDATE: I’ve got my life back! Things have worked perfectly for 48 hours!


(RH) #2

One of the first things I learned with ST, which I’ve only owned a short time, is that stuff you set up can “hide” in a few places creating conflicts. The best things ST could do is integrate the interface to the point when a Thing is deleted, or a routine is deleted, it clears all traces of it. If you delete something in the ST app, but a routine using that same thing resides say in Smart Rules, confusion ensues. Glad you got it working and I hope ST notes this potential issue that can only bug users an hurt ST’s reputation. Well done!


(Eric) #3

I am not willing to kill my dashboards, as only good morning fails for me. So I changed it to motion to start everything, and all is much better. I would be curious, though, if this helps anyone else!! Once those dashboards are gone…no coming back. lol

The ONLY thing I haven’t figured out yet is how to change the thermostat temperature at a specific time. All my timings in my house work well, just need to add that since that is not in the good morning routine…we prefer the house warmed up when we get up…not when ever we see first motion!! :smile:


(Dick) #4

I also got one of my Routines to work by adding Motion settings (later removed). But I am happier now without my Shortcuts. The THINGS display is sufficient along with my Sharp Tools display. I try to keep the system as minimal as possible. Shortcuts seem to be redundant…and can cause Crossed Wires!


(Eric) #5

Yeah, the rethinking you inspired me to do I think got me over that last hurdle…did Rule Machine to do my thermostat and removed some of the lighting automation from the old way and drop into Smart Lighting.

I think cleanup is just a good thing.

But my dashboard? My WAF would plummet. LOL


#6

Nope, never ever. I’ve got 235+ device and growing, I’m on hub v2, and have all the Dashboards (love them too). With the exception of the latest Android 2.0.8 app totally hosing up scrolling and a few other things, I’ve been a happy camper - EXCEPT for the UI.

I have a Parent/Child app for you that will do the trick. I have one child instance of it running for waking up and one for bedtime:

Parent:
https://raw.githubusercontent.com/constjs/SmartThings-Apps/master/Thermostat_Manager_Parent.app.groovy

Child:
https://raw.githubusercontent.com/constjs/SmartThings-Apps/master/Thermostat_Manager_Child.app.groovy

BTW, the times are set NOT to be at the top or bottom of the hour, but more like 10:04pm or 6:03am.


(Benji) #7

While there is still blame to lay with ST on a lot of issues, I do think this is exactly what the majority of problems people are having are related too and you’ve done the right thing. I have virtually no issues and my ST and related ecosystem is extremely stable, but of course I only came in with STv2 and thus started ‘fresh’. I only have a few SmartApps installed with only a couple of custom DTH.

Basically my goal is to do as much as I can with stock/official stuff with as little as possible, Smart Lighting takes most of the load. People moaned about the lack of V1–>V2 migration tool but I honestly feel everyone should have taken the opportunity to start fresh with minimalist approach and likely newer versions of SmartApps/DTH.

I don’t have as many devices as others so it was easier for me (50 or so devices) but I’m pretty certain even if it were 250/500/1000 I still like to start fresh, like a clean install of Windows instead of doing an OS upgrade, otherwise I feel dirty and reliability always takes a hit.


(Jason "The Enabler" as deemed so by @Smart) #8

I have to agree with everything you’ve said here. I started with the release of V2 and I built my system as I bought new devices. I had problem after problem, but still not as bad as most.

A few weeks ago my entire system went down “Error 104” in the IDE. I wiped the system and start from scratch. And you’re right, the entire system has been great since then and has actually been even better since the most recent upgrades.

Right now the only problem I’ve had is that Modes are still stupid. I’m currently using RM to change my modes and it’s working great. The only time I’ve had a failure to change modes is when I had the rule do something more than just change the mode.

I’m experimenting with the modes right now. I’ve decided that I want to use mode to add complexity and flexibility to my system. Before I was using a Virtual Switch as the mode. That worked great but I did not expand on it very much.

Plus I really like seeing the mode on the screen.


(Andrew) #9

This is interesting.

I, too, had shortcuts on my Dashboard that I used to trigger automations. On a lark, I deleted all my shortcuts. At first, there was no tangible difference in my ST setup, but after several hours, it seems like everything started working right again.

I’m not ready to declare success, or even to confirm that system performance is correlated with the presence of my shortcuts, but at least anecdotally it seems to be working.

I suppose the proof would be to re-install app V1 and restore some shortcuts to see what happens. I do have a copy of app v1 (I archive all my previously installed iOS apps in case I ever need to fallback), so this should be possible. I wonder…


(Bobby) #10

If you get it to work let me know. I still have a tablet with v1 app and after last update cannot use it. It doesn’t even let me open a room. It crashes instantly…


(Andrew) #11

Hmm. To be honest, I’m a little leery to do anything that could cause ST instability again. That last 11 days or so have been a horror show that I’m not too interested in repeating.

Nevertheless, I do have the v1 app installed on an iPad that I have used successfully to set which attribute of a device shows up on the Things list next to the device’s name even after moving my iPhone to app v2.

I have an Iris contact sensor in my beer fridge. I don’t often need to know if the fridge is open or closed, but I do want to know the temp inside the fridge. On Saturday last week, I used the v1 app to click on that little circle thingy - don’t know what that’s called - on the sensor’s screen so that temperature would show on my Things list instead of the open/closed status. I really wish this feature would come back to the app.

Andrew


(Bobby) #12

That’s what I’ve been trying to do too. As soon as I click the gear, the app crashes.


(Dick) #13

I am SOOOO happy that my system is now 100% normal. The last few months were very frustrating.
I actually never knew that there were so MANY happy users…I only read the blog complaints.

Like I mentioned I now have my life back. I am retired and I was spending a LOT of time trying to work out the random timing & sensor issues etc.
I tried to keep a simple setup (I thought), but I should have gone to Smart Lighting a long time ago.

I’m sure Shortcuts and using them to manage devices was the biggest part of my problem.

I am now ready to resume buying more devices!

Dick


(Eric) #14

So, I kept my dashboard…but I removed all “old automations” where I triggered stuff from the device and its settings it self, and went to rule machine and smart lighting for majority of my apps.

Things are well.

Goes back to cleanup perhaps. But I still have my dashboard and well functioning system (in relative ST terms)


(Stephen) #15

Does this just have to do with the old version of the app?


(Dick) #16

Users with a V2 hub, do not have Shortcuts.
Users with a V1 hub may have Shortcuts, but they will loose them if they delete them. They cannot add more new shortcuts.
(That’s my understanding!)


(Andrew) #17

I can confirm that I cannot restore my dashboards. They are gone gone gone. :frowning:

I have a v1 hub and app v1.7.3 (iOS) and was not able to add any dashboard shortcuts back. When I go to the Dashboard in the app and push the + button, nothing happens.

On the plus side, I was able to hit the gear thingy to change the default sensor attribute shown next to my device on the Things tab without the app crashing like @SBDOBRESCU is seeing happen.


(Stephen) #18

I was just grasping at anything that would make me want to turn my hub back on again


(Bobby) #19

Yup, I noticed that it happens only on ST stock device types. Perhaps the latest update got rid of that capability.


#20

You’re right that there’s a difference between V1 and V2 with regard to shortcuts, but it’s about the mobile app, not the hub.

Users who had a V2 hub and the V1 app had shortcuts. If they then updated to the V2 app, they still have their shortcuts,as long as they haven’t deleted all the devices for any one shortcut. But once they’ve deleted everything, the shortcuts are gone no matter what version of hub or app they have and they won’t be able to get them back.

Those who start with the V2 app, regardless of which hub, won’t have shortcuts. This would be true for someone who bought a used V1 hub today.

Lots of examples in the following thread, including screenshots: