[Solved] Arm Canary via Smartthings app

I am considering into purchasing a Smartthings hub, however I already have a Canary camera and a Wink hub. I was wandering if it is possible to use the “away” mode to activate my Canary via ifttt? And when I activate the “I am back” mode, the Canary goes off ?

If this is not possible, can I use a sensor to activate canary when triggered only when I set smarttthings to “away” mode ?

Do you think I need to create a SmartApp ?

I created a virtual switch in Smartthings to arm Smartthings and use the same virtual switch via IFTTT to arm my Canary camera. I have made a rule tied to the same virtual switch to turn off lights while we are gone for the day. I have the same rule set to turn on some lights if we are leaving after dark.

It seems to work fairly well with little lag. You can use the same method to have Smartthings and Wink “talk” via IFTTT and Wink shortcuts.


Thanks for your help @idahoski.

@idahoski can you explain in detail how you actually achieved this? I’m looking into this as well but can’t figure out how to achieve this!


Part 1

  1. Download the Wink app and create an account or sign in.
  2. Select “add a product” and then select “Canary” in the list.
  3. Follow the instructions in the app.
  4. Go to the “shortcuts” tab and select “new shortcut”.
  5. Name the shortcut whatever you want and set “shortcut action” to “privacy” mode.
  6. Repeat step 4 & 5 for each mode.

Part 2

  1. Go to https://graph.api.smartthings.com (US) or http://graph-eu01-euwest1.api.smartthings.com (UK)
  2. Sign in
  3. Go to the “My Devices tab”
  4. Select “New Device”
  5. Name it something like “Canary privacy mode”
  6. Set the “Device Network Id” to whatever you want
  7. Set the “Type” to “Simulated Switch”
  8. Select your location and hub.
  9. Repeat for each mode (privacy, disarmed and armed)

Part 3

  1. Go to https://ifttt.com
  2. Create an account or sign in
  3. Go to the “my recipes tab”
  4. Select “New recipe”
  5. Select the “this” to “smartthings”
  6. Select “switched on” and select one of the switch we created
  7. Select the “that” to “Wink:shortcuts”
  8. Select “activate shortcut” and select the shortcuts we created in the first steps
  9. Repeat for each mode.

Part 4

EDIT : you can also use CoRE for this step if you prefer

  1. On the smartthings app download the “smartlightings” smart app in Lights & Switched
  2. Create a New Lighting Automation
  3. Set “which lights do you want control” to two of the three create switches.
  4. Set “what do you wand to do” to “turn off”
  5. Set “how do you wand to trigger the action” to “switch turned on/off”
  6. Set “which switch” to the created switch that was not selected in step 3.
  7. Set “turn off lights when” to “turned on”
  8. Deactivate “turn on as well”
  9. Select Next and Done
  10. Repeat twice changing the controlled switches

If you want to to turn off lights while we are gone for the day and/or turn on some lights if we are leaving after dark you can use the same app to create other rules.

Now everything should work and you can set a routine to switch on one of the modes.

I hope this helped @snipes040


@TheCellMC Dude you are amazing! Thank you so very very much for taking the time to write all of this out and explain this in detail!

Now I don’t have to sell my smartthings! This is awesome, thank you again!!!

Awesome - this should make it so Echo can change Canary mode without having to tell it to trigger!


Thank you so much for this!

I was bugged by the fact that when I’d get home after dark & my hall lights would come on via ST, my Canary would notify me of activity because it was slower to detect my location & switch to home mode. This has fixed it perfectly. :grinning:

I am tring to armed and disarmed Canary with Smartthing. Is this still working?

It is still working for me. I have an extensive away routine that turns everything off, adjusts the HVAC and arms Canary through a virtual switch/IFTTT/Wink.

Occasionally, Wink seems to have a problem, so I have had to logout of Canary within the Wink app and re-add it. That has only happened 2-3 times over the last two years.

Just had to delete and setup the Canary in the Wink app again when it stopped responding for a few days. So glad I found this even though you posted it almost 2 years ago.

I’m wondering if this will still work after the news of not being able to use Wink without a subscription.

Same here. There was an update to the Wink Android app out of the Play store which I avoided and has since been removed but I doubt it will matter.

So this stopped working for me last week because of the Wink subscription.

It was great while it lasted.