Ifttt channel to change smart things mode to away if scout alarm armed and home if disarmed


(Dane) #1

Is there any ifttt channel to change smartthings mode to home or away when scout alarm armed or disamred? would be nice to do that.


(Tim Slagle) #2


(Dane) #3

would this link to the scout alarm?


(Tim Slagle) #4

that will help you integrate a mode change from a ifttt rule… i don’t know anything about scout alarm.


(Dane) #5

Scout Alarm already has an ifttt recipe for when arm away, does smarting shaving something to trigger than to turn to away mode??


(Tim Slagle) #6

You will need to follow the thread provided to add a virtual button to trigger hello home phrases with the code I linked in the same thread.

Use the existing trigger from IFTTT for Scout to make a STs action happen. The action you want to happen is in the thread i posted.


(Dane) #7

Ok need a little help manage to add your code and create a smart app and from there was able to see in smart things app, the only thing is your code forces me to select a switch , i don’t want to add any switch to turn on or off just need the mode to change home to away and vice versa. What do i do?


(Dane) #8

All I want to do is in ifttt tell scout if mode changes to away than in smartings change mode to away and vice versa, so understand your code but which virtual switch would be the best to handle this situation. Thanks.


(Tim Slagle) #9

Step 1.
Create a virtual switch in the IDE.
-Open the IDE (http://graph.api.Smartthings.com)
-Go to “my devices”
-Create a new device
-Name it and give it a unique device ID
-Device type is “Momentary Button Tile”

Step 2.
Install my code in the IDE by creating a new smart app
-Go to “my apps”
-New Smart App
-From Code
-Save and publish

Step 3.
Go to the smart app and install the app from the “my apps” section under the big “plus button” on the dashboard

Step 4.
Setup a rule on IFTTT to trigger the button you setup in the smartapp based on a scout alarm trigger.

Hope this helps


(Dane) #10

Ok, followed your directions, get to load the smart app, created the virtual switch, but seems am doing something wrong. As the virtual switch is showing up as Inactive and when I go to the smart app to create it, in the option where? the virtual switch is not showing. So cant chose that switch to run the action.


(Dane) #11

Ok my bad, i accidentally created a wrong device type changing that worked and now can see the switch, will try and see if the rule works now, thanks so much. That was really helpful.