Smartweather Station Tile Update showing totally wrong data

I think since yesterday, the Smartweather Station Tile Update has started showing summer like temperatures (81 deg F) at my location. The sunset and sunrise timings are also what I see in summer months. I have refreshed many times but it is just displaying incorrect information. Is there a way to fix?

I’m now using the Accuweather smartapp. Works well enough for my purposes.

1 Like

this is b.s. because the new method is not even remotely similiar to the old method and all apps will have to be completely rewritten… why was there no prior notification of this…

since you say it should work where can i find the new smartweather station tile… it is not listed in your stock device types that i can add

just added a new device with your stock smartweater tile and it is still broken, you never release a new version of the device type… please advice and fix asap

There was advance notification.


My weather tile started working couple of days after I posted this message. I am using Rboy app though. As far as I can tell, there was no update to the app. So, I am totally unsure why it works, but I am not complaining…:slight_smile:

found an alternate version as well, stock version samsung is distributing still doesnt. work. typical customer service break something and dont care and do nothing about

It stopped updating for me yesterday morning :frowning:


For me too …

Stopped for me as well:

  • [lastUpdate] 2019 Apr 02 Tue 2:11:51 PM
1 Like

Got it working again. Added my zip code to the Preferences section of the Device.

Hi, I have this issue as well, maybe a stupid question but where did you add your zip code I cant seem to find that?


Ah, I found the zip code field but it its still not working… It get my location name right but the weather is still wrong.

Oh well

1 Like

Did that before but it worked for day or two and stopped again :frowning:

The weather forecast stopped updating correctly for me as well on Monday, April 1. I did this as well, entered Canadian postal code, and it did not resolve the issue for me either.

1 Like

Started to work again, strange