SmartTiles v5.8: Deployed to Blue & Green Editions. Release notes, etc. (follow this Topic for updates...)

The, ummm, “operations” that are executed to bring up a dashboard are very different in these two situations:

  1. Previewing the dashboard in “web view” from within the SmartThings SmartApps preferences pages.

  2. vs Opening the Launcher URL in any external normal browser.

For root cause analysis, it is important to know with 100% confirmation whether or not these two different activities result in the exact same mis-behavior.

And… Determine: Is this the same for everyone experiencing the issue, and how widespread is the issue… And what is the difference in environment or configuration between those who have the problem and those who do not: shard? edition? (blue vs green), etc etc.

Very very few reports so far. Perhaps a good sign that this is isolated to a particular environmental or SmartThings Account condition(s)??

Na02 shard, 5.8 +50 green, Multiple browsers. Android 7.0.1 running ST app 2.3.1 build 211001.
Same error for both situation 1 and 2. Above screen shot is situation one. Below is 2

No… You misunderstand.

By scenario #2, I mean: using an existing Launcher URLnot fetching a NEW ONE from inside the SmartThings App!!!

What happens with AN EXISTING, previously WORKING, LAUNCHER URL COMPLETELY OUTSIDE THE SMARTTHINGS APP?

PS: The frustration isn’t aimed at you … just nobody has given me the above correct specific diagnostic yet.

My bad. No worries about the frustration. You are responding to an issue… on A sunday. Here is a pic of a link I have new using for about a year. Only required the occasional sign on to the ST IDE.

Thanks for the screen shot, Andrew

###But that is not a “Launcher URL”! :confounded:

A Launcher URL is of the form: http://smarttiles.me/?app=33998b6a-d945-4ae2-b043-dfa857ec9d42&shard=NA01&label=Security and Temperature Launcher

(And the Panel reached by that above URL is working just fine for me).

@tgauchat we are probably not explaining this well. From my original post in the Custom CSS thread

"…Launcher URL and Preview Browse for all of my panels from the app. It appears to be oauth invalid_token error. I can get to the dashboards from previously recorded URLs, just can’t get them from the app.

In other words I can access the dashboards from the Launcher URLs I had already saved somewhere. However, if I go thru the APP I can not get the Preview or Launcher URLs, just the errors. Obviously the new dashboard I just created is not saved and I can not get the URL from the APP.

Step by step:

  1. SmartThings APP > Automations > SmartApps > SmartTiles (Connect).
  2. Select any dashboard.
  3. Select View Dashboard & URL.
  4. Select Preview Browse. (name of dashboard) - Results oauth error (described above).
  5. Go back.
  6. Select Get launcher URL - Results oauth error (described above).

The support time frame has been noted for awhile, however just thought you would want to be aware. Knowing this I would at least like to be able to retrieve the last URL for the new dashboard I just added. The other dashboards I already have saved.

1 Like

Thank-you tremendously for this specific clarification. I have added a few words to make it even more clear.

Anybody reading this… Please let me know if you observe problems that are different from Bill.

1 Like

I’m not even using SmartTiles any longer but following this thread and just wanted to express how impressed I am Terry is trying to provide support on a Sunday, late for a product with a limited lifespan. Impressive.

Glad to be part of the ****Tiles family.

3 Likes

(And @Controlbreak):

###Possible Workaround for creating Launcher URL from a SmartTiles Dashboard
I have a possible workaround; since I don’t expect a quick solution from SmartThings:

.1. Goto https://graph.api.smartthings.com/location/list

.2. Select and Open your Location.

.3. Note your shard ID in the URL

  • graph.api = NA01
  • graph-na02 = NA02
  • graph-eu01 = EU1

.4. Open “Installed SmartApps”

.5. Find your child SmartTiles v5 Dashboard in the list of SmartApps / Other

.6. Open the child SmartApp for the desired Dashboard instance for which you don’t have a Launcher URL.

.7. Scroll to the bottom, find and copy the Application ID. It is not labeled:

.8. Use that ID to construct your Launcher URL as follows:

http://smarttiles.me/?app=app id from #4&shard=Your shard ID from #3&label=label of your choice


Example:
http://smarttiles.me/?app=98985afb-d82b-4abd-b99c-c53cc7bea61a&shard=NA01&label=Security and Temperature Launcher


####Please test and confirm that this works. I will then publish to our Knowledge Base.

Thanks!!!

3 Likes

Thank you again for the support! I will test this as soon as I can get out of my work firewalled world.

1 Like

That worked great for me! Thanks so much for your continued dedication and support, Terry. I had sent a support ticket on Sunday and you replied and directed me to this forum posting. I was very surpised by your quick reply and dedication, as I believe everyone has also been here on the forums. SmartTiles owes us nothing, so I thank you again!

The only thing worth noting is after you piece your URL together, I would logout of the IDE and then go to that URL which brings you to the “SmartTiles Launcher” page where you’ll launch it, login to the IDE and then land at your usual Tiles. I had some issues running the pieced together URL while logged into the IDE which I think I recall that always being an issue. Running two separate browsers is another solution.

EDIT:
One more easier solution, if you were not using the SmartTiles.me link like I wasn’t previously and used this link:
https://graph-na02-useast1.api.smartthings.com/api/smartapps/installations/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/ui?access_token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Simply remove the /ui?access_token=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx from the end of your link and just put /launch instead. That also worked for me.

Thanks!
Derek

1 Like

This format will fail if you are not already logged into the IDE/API web page.

Confirmed…This worked perfectly. I was able to get the new panel Launcher URL and finish what I started. Thank you for all of the help here and with ActionTiles.

Now, I will let SmartTiles run on the Gen 1 iPad until it no longer works and implement AT on other tablets moving forward.

1 Like

2nd confirmation @tgauchat thank you again.

Anyone who is questioning if ActionTiles will be worth it; just read this thread and see the support that comes with it. Should be more than enough of an answer for you.

2 Likes

Starting May 31 none of the smarttiles URL’s are working. They all result in

Invalid app parameter: ""
Invalid or missing shard parameter: “”

ERROR
Please check parameters

I have verified that my URL is good. I have checked my api.smartthings.com codes and constructed the URL as advised and still get these errors. It does not recognize shard=NA01

This is the URL I"m using http://SmartTiles.me/?app=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx&shard=NA01&label=Home

I have verified the app string is correct and I tried the main app string and the “home” appstring. It worked yesterday morning, yesterday evening after work I get the errors.

Same here on new browser tabs or windows and I notice it redirects to actiontiles.com. However, I still have it running on an old iPad that apparently hasn’t refreshed. I think I’ll leave that one alone to see how long it runs.

Maybe this is the eventuality @tgauchat mentioned.

1 Like

We will fix this as soon as possible.

Existing SmartTiles installations are to remain working for a while.

1 Like

Excellent, that saves me from having to deploy a new tablet quickly. Thanks @625alex.

Can we assume you will give us some advanced notice when SmartTiles eventually retires?

Yes, of course. We will issue advanced warning.