SmartThings Community

SmartThings Text-To-Speech for Sonos (playText) not working?

The last time I checked (2 hours back), the problem still exists. Haven’t heard of any update.

I’d really like to get this working.

@slagle Any update? Can you confirm at least where the problem is…i.e. Amazon, SmartThings, etc?

I have a ticket for this. No updates yet, but I can’t fix it :frowning:

I’ll go poke some people today.

5 Likes

Please do poke some people.
I’m finally getting a home audio solution in place using DLNA and Squeezebox renderers… I’d like to get things working with the notifications again.

Please poke anyone you can. Sonos integration has been huge for our family since we put in our SmartThings. I talked to support a while back and was told hmm basically. Our back to school would be going so much smoother with this integration back.

@slagle

Just saw the announcement about Samsung speaker integration. But is the text to speech still not working?

Hello, anyone out there? This is a key integration and something I have been using for a long time before your last update broke it.

My TTS is still wonky. sometimes it works, sometimes it doesn’t. custom messages other than those that appear to already have been created, definitely do not work.

When sent support an e-mail about this a few weeks ago, it sounded like they were working with Sonos to resolve.

“Thanks for writing in! So it sounds like you’re actually running into a very weird bug with our Sonos integration… Our engineers have contacted Sonos and we are working on the issue…”

I’m not sure it has anything to do with Sonos. The TTS feature works with many different speakers, none of which seem to be able to play anything that wasn’t already cached.

Exactly… ST uses some TTS service, and thats where the problem lies.

Any updates, @slagle?

Maybe any new platform features should be released with an accompanying expiration date so that we know how long we can use it before it stops working.

I kid, I kid…

sorta.

2 Likes

Hi @slagle , some update about fix the textToSpeech() function ?

We’re making progress. :smile:

4 Likes

I hope thats true, cuz i never got to use sonos to its full extent since i bought it couple of weeks back… Any ETA??

@pstuart and @slagle worked through this and found a possible workaround - Edit - Spoke too soon. No workaround here.

Edit: Credit to Tim. I watched.

2 Likes

Going to watch this later to see what’s what, but for now the burning question is:

How do I get a mini @pstuart on MY desktop?

2 Likes

What’s interesting is that I use this with absolute success daily for door open events. And it works flawlessly. Not one of the smart apps seemed to work anymore but this has never let me down

I use this modified sonos device type https://github.com/tonesto7/MySmartThings/blob/master/DeviceTypes/Sonos%20Device%20with%20Speech.groovy
and the iOS app SmartRules

1 Like

If you’re playing something that has been spoken before, it works flawlessly. The issue appears when you try to get it to say a phrase that ST has not yet cached. Say, for example, “The purple rhinoceros honks in the jungle”. (…i hope…)

@pstuart’s workaround might have done the trick, I just need to re-arrange some power connections tonight in order to test it. Alexa stole my DLNA speaker’s power outlet and she’s not about to give it back!

Mini pstuarts are on the agenda. It should be in a matter of weeks. Probably with the launch of pstuart v2

Seriously. I was shocked when @slagle suggested casting the string toString() and bam, that worked.

True credit goes to Tim for the idea for the fix.

Wonder what else is plagued by this type issue.