SmartThings temperature automation limit is 40°C

SmartThings app just updated on my iPhone. Version 1.6.67. After the update, when I try to add or edit an automation that changes the temperature on my thermostat, it only allows inputs ranging 0-40. That’s good and all for Celsius but doesn’t work for Fahrenheit. I have a Honeywell T6 Pro z-wave thermostat. Please fix this bug.

Well holy cow. It looks like something changed because this wasn’t happening to me either, until now. Mine are Centralite Pearl thermostats.

EDIT: This is happening only when including the thermostat in Automations or Scenes.

1 Like

Tagging @Brad_ST @garrett.kranz


Do you have a support ticket regarding this? We haven’t been able to replicate the issue and getting mobile app logs could help.

@Brad_ST I have as part of my incident with STHM reporting incorrect states on several devices. Ticket number 1209633 has app logs from just a few days ago.

1 Like

Just to bump this, I created an account solely to search for a solution to this. New the SmartThings in general, but it didn’t feel right. iOS device with most recent version of app.

I am experiencing this same issue - also on iOS. The app and IDE show Fahrenheit, but automations appear to be restricting to a Celsius temperature range (0-40). I have opened a ticket as well 1227564.

I also made a video of this happening, which I sent but may be useful to see happening - Smartthings App Using Celsius for Automations but in Fahrenheit For Everything Else - YouTube

It may just be a coincidence - but mine just started working correctly.

I tried creating a scene and noticed the degrees were in Fahrenheit correctly. Then I went to automations again and they were correct as well. I do not know if opening scene creation fixed it or it was just a coincidence, but maybe that can help someone.

Mine also works now. Not sure if there was an app update or not.

No go yet for me. I just tried again a few minutes ago. Are you guys using a stock DTH, or custom?

Has anyone been able to figure this problem out? I tried creating a scene as mentioned but the temperature options just show in Celsius. I have a Nest thermostat and a SmartThings button that I’m trying to use as temperature sensors for automations and I only get the Celsius option for both.

I purchased an Aeotec MultiSensor 6 and installed it yesterday. If I use the default device handler then the same problem happens. However, if I use the manufacturer recommended device handler then the options in the automations show in Fahrenheit.

I contacted SmartThings support but was told in a round about way that this is a known issue but there are no known fixes at this time. I directed them to this string and they viewed the video that Hiram_Davis posted. They created ticket number 1246789 for me and said that they would also reference the other ticket numbers listed in the string. However, the first message in this string was on June 19th so I don’t have a lot of confidence that anyone at SmartThings is actively working on a solution. Therefore if anyone has figured out a workaround it would be greatly appreciated.

It’s that time of year to turn the heater on and I’m having the same issue did you ever get a solution?

As of this time I have not been able to find a solution. Since the time I posted my message I believe there have been a couple of ST App updates but this particular problem wasn’t one of the bugs they resolved. It’s very frustrating.

Argh, thanks for the response

OK I’m having the same issue, I believe as most of you. All my sensors are in Fahrenheit when you go into the devices. When I start an automation and select the sensor and temperature the only choice I have is Celsius. How is it that Samsung can do updates and not troubleshoot this prior to releasing an update? Is there a workaround for this and why is Samsung so quiet. This is like one of the most basic things that we use smart things for. I really don’t want to have to convert everything to Celsius. It’s such a pain in the ass

I was having the same problem. I believe I may have found a work around. I logged into Groovy IDE and found the device. The I added a temp offset of 1 degree and it started working in Fahrenheit. Perhaps you can simply offset it in the app as well.