SmartThing HUB IDE 2FA (Two Factor Autentication)?

I logged onto my HUB IDE page and after entering my ID and password I was told to enter the 6 digit code shown on my Samsung tablet. Luckily my tablet was handy but usually it’s not. Can anyone tell me how to turn this ‘feature’ off? I wouldn’t mind if it used my phone for 2FA, but my tablet isn’t going to work.


A little further down, on the login page you can choose to send an SMS to your phone instead of the tablet

1 Like

you cant turn it off. ive gone bonkers trying to turn it off. i contacted st support which basically brushed me off, but pointed me to samsung. when i logged into my samsung account there is no option to turn it off. about the only thing you can do when you do the 2-step auth process is to tic/check the box to skip 2-step auth next login.

1 Like

This page, where?

@Awestun I went here: Samsung Account and my Samsung table was listed as a 2FA device, I turned it off and we’ll see what happens.

First you enter the email and password.

when you accept this other appears, click “verify with text message”, below and do not ask for double authentication on this device again, as it says @Awestun

that just turns it off on the tablet. he was asking about turning it off when he logs into the smartthings IDE.

im starting to think when you throw a samsung tablet in your mix that they automatically turn on 2-step auth for everything. as i sure didnt turn it on for smartthings auth, but it happened around the time i got a samsung tablet.

Yes, This appears too when login to IDE smartthings account.

When mark “skip double verification on this device the next login”, it works until you delete the browser cookies.

1 Like