Smart Lights not turning off

I have a few smart lights that are suppose to come on with motion between sunset and sunrise… I notice if they are on when sunrise happens they don’t shut back off… is this suppose to happen? Is it not running again (To turn them off) because it passed the sunrise?

Yup, Smart Lighting is not multiconditional app. Trigger is motion, exclusion is sunset/sunrise,lux, mode etc. If the exclusion changes while your lights are on, the lights will stay on.

If you want a lot more flexibility and running locally isn’t a requirement, you should try the SmartApp CoRE. Even though it’s still an Alpha Version, I’ve found it more stable than SmartLighting.

1 Like

I add another instance to smart lighting to turn off the lights 1 minute after Sunrise.


I like that idea. I was hoping that it was something broke on my end and not the smartlighting… ugh

It was like that since day one of smart lighting. I also like using CoRE as well. It’s going to be an awesome smartapp for sure but for now i like some of my lights to run locally so smart lighting is the only option.

1 Like

That behavior is by design, there is no return to initial state when the rules execution window expires. If you want to ensure local execution, create another SmartLighting rule to turn off your motion lights at sunrise. This will ensure that they all turn off.