Slow Zwave and now Samsung Zigbee Devices too

Hello everyone!

We are continuing to experience slow response times (> 5 mins!) in our zwave mesh on a v2 ST hub. I just added three zwave outlets 10-12 feet from the hub and they respond in 4-5 minutes each.

I have tried all of the suggested solutions to try (mesh repair/analysis, removing unused devices, moving the hub/devices, etc) and nothing seems to change how fast the hub sends commands. This all started in our old house after a hub update in early 2020 and now continues in our new house (on the opposite side of the US). I have put a device right next to the hub and we still get 2-5 minute delays from the hub on devices 6 inches away from it. I know there is some type of fix (or whatever ST people are calling it) in beta right now but this solution is making these products unusable. Any other thoughts about this?

Also, on perhaps an unrelated (?) topic, all of our Samsung/SmartThings motion sensors and buttons (4 buttons, 8 motion sensors) have gone offline. I’ve replaced batteries and reconnected some of them and they only stay connected for about 20 mins and then drop off - regardless of distance from the hub (6 inches to 100ft: the same behavior). It’s the strangest thing.

Of course on both subjects above the SmartThings tech support is no help at all. They really are a waste of time for me and a waste of money for the SmartThings organization.

Any help would be greatly appreciated.

As a former field tech, the first thing I would try in this circumstance is a different hub in the same physical location to see if maybe the problem is just that specific hub device. But I know that may not be practical.

1 Like

Hey @JDRoberts … I just saw your reply here and if you think my post is redundant please let me know.

So what you are describing sounds like (and is acting exactly like the last time I experienced) issues with communications in your ZWave mesh. But, lets see if we can figure out what’s going on. When you ran the mesh repairs what errors showed and what interventions did you do?

You also mention issues with your ST sensors dropping off - those are Zigbee so we can use them to differentiate if it’s a ZWave (protocol) problem or a ST platform problem. Are the ST sensors also slow to respond when they’re not dropping off?

As to this:

Not for this - that’s most likely a separate issue. That particular item relates to cloud v. local processing - enabled by the 35.x firmware and an upcoming settings change. While it DOES significantly improve responsiveness for specific devices, if the ZWave mesh itself is the issue it wont matter if it’s local or cloud processing, the message still doesn’t make it to the end device. We have to fix comms and routing before you gain those benefits.

1 Like

Regarding zwave, here are my notes:

  1. I have run the mesh repair about every few days since the zwave problem started. The only error I’ve gotten is a failure to update a ghost device labeled “[3F]”. I created the device using its ID to attempt to delete it but every time I run the mesh repair it shows up again. I did this 15 times (Yes, 15). I’ve contacted support and they haven’t been able to help me delete it. That is the only mesh repair error I get.

  2. When we moved into this house in November 2020 I had only one zwave device and it would respond somewhere between about 30 seconds to 3 minutes. That was the only device on our hub at the time. This was somewhat expected because the zwave problem started in our old house in early 2020 (perhaps late 2019?).

  3. I’ve tested against the event logs: When doing zwave tests I have reviewed the event logs. One issue that only crops up with zwave: both ON and OFF commands are sent with ALL on, off, dim commands. For example, if I send an ON to an outlet, the hub also sends an OFF command. When I set a dim level, the hub will send and OFF and an ON and the dim value. So, for example, if I brighten a Leviton plug-in dimmer 20%, the hub will send ON, dim, OFF, ON, etc. - all in the same command. Sometimes, especially with GoControl and Leviton devices, they respond to all of the commands in sequence.

  4. Range - distance of devices to the hub - has no effect on response times. I have tested this with in-wall devices, outlets, dimmers, Leviton modules, Jasco/GE, etc.

  5. Some days zwave is fast, nearly instant. Some days like yesterday, it’s over 5 minutes: I installed new outlets and was sitting in the room testing them. When they didn’t respond I pretty much forgot about them. Then suddenly after 5 mins or so they all started responding to my commands. It was “crazy house!” there for a while.

  6. To be clearer about what wrote regarding the beta… I was referring to this notice regarding the Feb 16th update: SmartThings Status - SmartThings Hub 2015 (v2) and 2018 (v3) Firmware Update The zwave fix, however, was not mentioned in the release statement.

As for the zigbee Samsung devices (I only have buttons and motions sensors)… I’ve submitted a support request to SmartThings. So far their support has been a black hole. We’ll see how it goes.


1 Like

Got it - unfortunate, you’ll need support help if you’ve already tried deleting it. (@vlad - more ghosts we can’t delete or keep reappearing - just like my account)

Still a bit long on the 3 minute side. When mine is workign right I RARELY get more than 10 second waits. anything beyond 30 seconds should be considered a problem even for a cloud device. 30 seconds is an eternity in computer time.

Don’t overthink that tone- it’s going to do what the DTH tells it to do.

Generally wont - the distances we’re talking dont matter much from a timing perspective. If distance matters you have a very badly performing repeater device. This sounds like that ghost is eating your lunch or the cloud delay is killer for you.

Yep - just reinforces the ghost is causing errors in your mesh or the cloud side is just reaaaaaaaly nonresponsive for you. My bet is the ghost and ensuing mesh weirdness. That’s the only time I ever got over 3 minute response times.

I know what you were referring to - I’m in the beta. The 35.x firmware update enables local automations on your hub IF: 1: you have the 35.x firmware 2: you have the configuration setting to enable it turned on in your Location (you get this by joining the beta) 3: your devices have to support local automation by using default, builtin SmartThings DTH’s that are loaded into your hub. Fortunately for you the GE devices can use ZWave Switch or Zwave dimmer as appropriate and qualify. That said, I wouldn’t worry about the beta quite yet. I really think there’s something boofed in your mesh - and would really try to press on support about that ghost that won’t go away. Reason - the insanely long delay, and cloud responsiveness has actually improved for me and a few people I talk to regularly about this. (When it’s not ‘down’ but that’s another story - assume we said, when it’s working)