Single button controller / Iris SmartButton alternative


(adam) #1

Im currently using 2 Iris SmartButtons to control a zwave switch and zwave outlet that are not easily accessible. Simply put, the Iris devices are finicky at best, and at times dont work at all. Are there any alternatives?


#2

Depends on the use case, but there are quite a few options:

Battery-operated Z wave and Zigbee switches do tend to go to sleep if they haven’t been used for a while. So sometimes people who use them every day don’t see a problem where someone who only uses it once a month will. ( I suspect this may have to do with the amount of “active” history that smart things keeps. )

So if the buttons are used infrequently, you may want to consider one of the mains powered options instead. Or go for a tablet controller like SmartTiles in a web browser.

Again, it all comes down to the exact details of these case.


(adam) #3

So what wakes it up? Sometimes I use it often, sometimes I dont. I generally reports temperature on that button but now thats stopped for almost a week. Battery isnt reporting dead.


#4

What wakes it up is a button press.

The problem is that there’s been a lot of different problems lately, and it gets hard to troubleshoot.

There are many different possible factors. The device being asleep because it hasn’t been pressed for a while is one. Other granted, if it reports temperature that shouldn’t happen as often but it still can.

Several people have reported Zigbee problems in the last couple of weeks. Most of them find they get fixed if they unplug the hub (including removing batteries) for at least 15 minutes and then plug it back in. You shouldn’t have to do this, but it looks like some hubs may just get stuck after a firmware update.

Sometimes, of course, it’s range so the question is how far is the button from the hub and what’s the nearest zigbee repeater.

Sometimes it’s just a Mystery. I have a zigbee bulb which is within one hop of the hub and has worked great for several months and last night it just didn’t work. The log showed the correct information going back-and-forth but The light didn’t come on when it was supposed to. I didn’t do anything with it, or anything else on the network, and tonight it worked just fine again.

So I don’t really know what to say. I do know that the sleepy device issue is one multiple members have reported and that have affected multiple battery operated devices, including this one. But if that doesn’t seem like it fits, we just have to start looking at the other possibilities.

The sleepy device issue is easy to check. Just use the device at least once a day for a few weeks. If you never have the double press issue, then it probably is the button going to sleep. Some people aren’t bothered by that – – they just push the button again. But that’s not always a fit for a particular use case.

I wish I could be more helpful.


#5

Oh, regarding batteries-- it’s not a rechargeable battery by any chance is it? Those have a different power consumption curve than alkaline batteries and battery reporting is usually not accurate for them.