SimpliSafe Alarm Integration (cloud to cloud)

By the way, I see it’s labeled to “fix buttons”. Does that mean I should be seeing options in SmartThings to turn the alarm on/off? If so, I haven’t seen that yet. I’ve installed latest DTH and will test with my SharpTools rules. Thanks.

Not until SmartThings allows the creation of custom buttons again :frowning:

New version published to GitHub

  • Improvements to MFA login and Polling

I am using the latest DTH. I think, but maybe subject to further testing, that it is reading the current state of the alarm and acting accordingly with my SharpTools Rules. As mentioned earlier, my rule tests to see if the alarm is already off before issuing an alarm off code so that we don’t get repeated announcements from SimpliSafe indicating that the alarm is off.

However, and I don’t know that this is related to the DTH per se, but I think there’s a delay in updating the alarm status. If use the SS app to turn it on or off, sometimes there’s a lag before SmartThings sends a notification that the smart home monitor has changed to on/off.

Which is weird that I’m getting these notices at all because I don’t have the SmartThings Home Monitor installed on the new app. I also deleted the home monitor from the old app, including from the IDE, before migrating to the new app (which I did mostly manually, anyway, but then at the end, I clicked the migrate button).

And just now the DTH/Rule didn’t work properly. My stepson came used a lock keypad to get back in the house, which triggers the alarm off rule, and even though the alarm was already off, SS announced “alarm off”. Nuts.

However, I have a Tasker profile/task that checks the alarm all night long, every 15 minutes, to turn the alarm on if it’s off. I don’t get announcements during the night that the alarm is being turned on, so for some reason Tasker seems to be reading the current state of the alarm (through it’s integration with SharpTools). Oh well, I guess I’ll need to keep experimenting.

By the way, when the DTH reports the current state of the alarm, does it report it in lower case or all caps? I ask cause I think this is why my SharpTools Rule is not reading the current state correctly but my Tasker Profile/Task is. When I flash the current state in Tasker, it’s OFF or HOME rather than “off” or “home”. I think SharpTools is case specific, whereas Tasker is not. I once had this issue with another DTH and added “lower case” somewhere. I’m no programmer, and someone suggested it in this community how to do it, or else I wouldn’t have known how. :-). Thanks.

1 Like

Latest version has been corrected to report in all lowercase. Previously it would report different for SS v2 and SS v3, it’s now standardized to use lowercase.


So, I’m testing this. I installed the new DTH. Took a little while for SmartThings to update. I know this because Tasker was still reporting states in all caps. Eventually, when I ran my Tasker task it reported lowercase “off”. To test this in SharpTools, I turned on my SimpliSafe Switch in SmartThings and SharpTools armed the alarm. I then turned off the alarm using the SS app. It took about 5 minutes before the status of the alarm changed. I know this because for some reason SmartThings reports that the home monitor status has changed to off (even though I don’t have home monitor installed and I uninstalled it from the classic app and the IDE, so it seems to be a remnant of when I once had it installed in the new ST app, but that’s a different issue). Anyway, I’ve been trying to turn off my SimpliSafe switch to see if the SharpTools Rule will check the status correctly, but I keep getting network errors from SmartThings. I’ve rebooted my phone. Tried without WiFi on. Nothing seems to work. Must be an issue with the SmartThings server. Again. Sheesh. Anyway, I’ll keep trying later and report how it works. Thanks.

LATER: I think we have success! I had to reboot my Hub to control my switch, but after turning off the alarm using the SimpliSafe app, I then turned off the switch in SmartThings and the alarm didn’t announce “off” again so my IF statement in my SharpTools rule must have worked! Yay! Thanks.


I was using this integration for years with my old Simplisafe Version 2. I sold that house last year, left the system there and recently purchased a new Simplisafe V3 for my new home. I have also migrated over to the new Smartthings app since moving so all of my prior experience was with Smartthings Classic. I have installed the new Device Handler and App. I added my username, password, and selected SS3. I got an MFA email and approved the log in. The device in my Smartthings app never goes beyond “checking status…” I still see my old system on my Simplisafe web app even though it is no longer active. Could this be causing my issue? I tried to get the location removed by Simplisafe and they told me to just hide it.

I get this error in my Smartthings logs while it’s trying to log in: Illegal character in path at index 52:, ######/ @line 191 (poll)

That could be the issue, the Driver can only support one location so it may be trying to poll your old ID. You can either get SimpliSafe to remove the location from your account, or hardcode the location ID you want to use.

Thanks. I called SimpliSafe again and got someone in retention that said they would remove my old system entirely from my account but that it takes 3 days. I wouldn’t even begin to know how to hard code in my location ID. Hopefully this works.

Thank you for all of this work. I spent a few hours today reading through most of this very long thread. I have tried the latest version in Github (posted Nov 15, 2020) as well a version created by ssilence5. It seems the Nov 15, 2020 version is the first to attempt the MFA. I am still unable to get or set the alarm status in ST all.

  1. First, I am not sure which version of the ST Hub I own. I am not sure how to figure this out. But given there are only 3 choices, I tried all 3.
  2. I have also tried both the ST apps. Which should I be using?
  3. I see other people posting logs. Where do I see these in the app?
  4. I received 4 MFA emails with different IPs. I’m not sure why, but I verified all 4 of them.
  5. Any other ways to test this?

Thank you again. I really would like to get this working. I also see that Hubitat is something you are newly supporting. I checked the site and they are out of stock. I would be willing to get a new hub and dump SmartThings if I can get this integration to work with my Simplisafe alarm system. Any other trouble-shooting ideas?

After more time and playing with this my new status is:

  1. Using the “Classic” app, I can now see the status of my Simplisafe alarm. Win!
  2. Using the Classic app, I can also arm the system. Win!
  3. I removed and rediscover devices with Alexa. She sees the device.
  4. Alexa sees the device as a “Contact sensor”. The status is “Closed”.
  5. When I create an Alexa Routine, the contact sensor device is not available. It is shown in the “unsupported” list of devices where my cameras are shown. Alexa cannot do something with a camera in a routine, and she cannot change a contact sensor from closed to open.

The whole reason I am trying to get this integration to work is so I can add a step to my “Goodnight” routine to also arm my system. Even after getting the integration to work as designed (it appears) I still not achieve this.

Am I understanding correctly?

Attempted to update from GitHub repo and the smartapp published but the device handler will not update. It skips due to error. Is this load option no longer available? Thanks,

I found it easier to update manually. I copied the code from GitHub and pasted it into the SmartThings IDE. Maybe try this? The code still works and works in the new app.

Circling back on this as I did not see a response and I just got a second simplisafe now. Where do I get the location ID (not in URL anymore that I can see) and where do I hardcode it?

Been using this integration for awhile with no issues until I got the second one. Great integration and was stable (until I messed with it)

Thanks again!

The app makes a call and gets the first location ID associated with your account. You could hard-code in your location ID for the account you want to use but I’m not sure how visible it is in the new web app.

I don’t have multiple accounts so I’m not able to test, but you can try playing around with

 String tsid =
		state.subscriptionId = tsid.substring(1, tsid.length() - 1)

Or if you are able to locate your ID, just set it

state.subscriptionId = 12345

Ok, step closer thanks to @tobycth3.
I was able to get my 2 subscriptionIDs by uncommenting your section on line 403 “Subscription ID1: $state.subscriptionId”
Went to active logging and found the 2 IDs. Mine were distinctly different and the lower number was my first simplisafe. Also confirmed by setting it to either and seeing the error or not seeing a state error in the log by adding/inserted line 404 with:

I still cannot get the SHM and simplisafe to sync events again but still looking at it. Wanted to get that out there for anyone else who is looking at more than one system integration.

Is there a way to confirm if the SS smartapp is running or getting events. I cannot see it logging anything in the IDE live logging. I also do not see any SHM events in the logging which I think I should when I change states. Can anyone confirm this? Thanks

Hey everyone,

This is an awesome integration. I have been looking for something like this for a long time. I got it working for my SS3 system but I am running into some issues.

I can only set the alarm to off. I do not have an option to set it to home or away. Does anybody have a recommendation on how to fix this? Attached is an screenshot of what the device looks like. The “Strobe”, “Siren and strobe” and “Siren” buttons under the alarm type do not appear to do anything but the “Off” button does work.

Unfortunately this is a known issue with the new SmartThings app. They no longer allow custom device types with the new app so only the standard buttons they provide will show up. Hopefully soon they will provide a better alarm template or allow custom buttons again.

1 Like

Thanks for the quick reply @tobycth3 Do you know if it is possible to set the alarm to away or home from a piston? I just gave it a try but again it looks like I can only set it to off. I am assuming pistons have the same limitation as the buttons in the new ST app.