Serious issues with MESHED Wifi routers and SmartThings

project_router

(Baivab) #1

Meshed routers offering Wifi are relatively new to hit the market. I was wondering why my meshed router is not working as expected. I tried with 2 vendors and both started suffering from mesh issues. What I mean is the meshed access points started to “die” on me. In parallel I noticed certain sensors I possess started to behave erratically. Finally, after much research I came to realize my smart things Zigbee is working on channel = 20 and there’s no way to change it. There’s an overlap with the vendor router’s meshed protocol being used. This is more like an FYI. After moving ST to a different location coupled with forcefully changing router’s channels these issues disappeared. Of course, with ST team it’s now +3 years but still nada from them w.r.t. ability to offer switching Zigbee channels.


#2

They have announced their own Samsung mesh Wi-Fi product, Samsung connect Home, which is due out later this year and is supposed to have a built-in SmartThings option.

Obviously that doesn’t help any current customers, but it shows some awareness of the issue.

If you have a V2 hub, it is supposed to be possible to Force a change in the zigbee channel but only by doing a complete factory reset. And you can’t specify what channel you want to switch to, you might even get the same one again. You just have to keep doing it until you get something that will work for you.

If you already have an existing set up, that would be a huge amount of work, but if you have mesh WiFi and you buy a new SmartThings hub, you could spend the time upfront to make sure you’re on a good zigbee channel.

Not a lot of help, I know, but at least it is an option.


(Baivab) #3

For anyone who has the same problem or stumbles on this:

Using the developer portal of SmartThings - home page one can find the Zigbee channel.
Then:

  • If ZigBee uses channel 15 (802.15.4), force Wifi router to channel 11 (802.11)
  • If ZigBee uses channel 20, force Wifi router to channel 1
  • If ZigBee uses channel 25 or 26, force Wifi router to channel 1 or 6.
    If Wifi router has 5 GHz. bandwidth channels, no need to change anything for that bandwidth. Above applies only to 2.4 GHz.I am hearing some vendors are planning to backhaul the mesh using 5 GHz., which if applicable should not cause any of the above problems.

#4

As a rule of thumb, we usually recommend using Wi-Fi channel 11 with Zigbee channel 11. These two are actually as far apart from each other as you can get, and then it’s easy to remember. Of course that assumes you have a choice.

For those who are interested in details, the existing FAQ has a link to a chart of the exact overlap between Wi-Fi and Zigbee. :sunglasses:


#5

Also, there seems to be some confusion: 802.15.4 does not refer to Zigbee channel 15.

802.15.4 is the IEEE technical standard for the protocol used for the physical layer that zigbee and Thread use. It doesn’t have anything to do with the problem that you are seeing, which involves the actual frequency that the radio is broadcasting on.

WiFi and zigbee both broadcast in the 2.4 GHz band, which is why they overlap. (Z wave in contrast broadcasts in the US in the 908.42 MHz band and uses a proprietary standard.)

http://searchmobilecomputing.techtarget.com/answer/The-difference-between-ZigBee-and-IEEE-802154


(Andrea Bianco) #6

EERO soon to be updated / released