Secondary controller (StaplesConnect) cannot control locks or Zigbee devices


(Mike) #1

I used Staples Connect for a couple of years until I got fed up with the lack of support. I am very satisfied that I finally made the jump to SmartThings, but like most people in my boat, I am missing the Lutron support.

I planned to work around that issue by adding StaplesConnect as a secondary controller for SmartThings and it worked pretty well, but only for Z-Wave devices.

  1. All of my ST Z-Wave devices showed up in SC, including my Z-Wave deadbolts, but nothing else showed up. Is that expected?

  2. I can control all of my Z-Wave lights/switches/outlets from within SC without issues, but I cannot control my deadbolts at all. When I look at the device info from within SC, I noticed that “isControllable” is set to FALSE, but I don’t quite know what that means or if it’s an issue, but it looked strange to me. My goal is to be able to use a Lutron Pico Remote in SC to control my deadbolt–is that doable (with any secondary controller), or is there something in the protocols that is preventing this?

  3. I had planned to trick ST into “using” the Pico Remotes with this scheme, but it does not work. Should it work, or am I hitting protocol limitations?

  • Configure SC to turn my bedroom light on when a Lutron button is pressed. Works well
  • Configure Dim With Me in ST to adjust a couple of other lights when the bedroom light is turned on/dimmed/turned off. It seems like this portion of the scheme is what’s breaking down and I’m guessing it’s because SC is not reporting the states of the lights back to ST. Is there any sort of workaround? Maybe ST can poll the devices?
  1. Should I be able to add new Zigbee devices to SC? I realize that this is a better question for Staples, but they are utterly worthless. In general, do secondary controllers prevent themselves from adding new devices? When I try to add a new Zigbee device, it immediately returns and tells me no devices were found. Searching for a new Z-Wave device results in an error similar to “not master.” I can add Lutron remotes no problem.

Thank you!


(Bruce) #2

When you added SC as a secondary controller, that was only for z-wave. Z-wave locks engage in a secure handshake with the hub when included. I think for security purposes a secondary controller may not control them, as it doesn’t have the secret handshake.


(Stuart Buchanan) #3

@bravenel hit the cause on the head, however I do not know about SC but with my Openhab as a secondary controller I can have it send a http request to a ST smartapp which will open a lock


(Mike) #4

Is there a concept of Zigbee secondary controllers as well, and if so, do they allow adding new devices? I believe the answer is yes since I have an Aeon Minimote connected as, what I believe is, a secondary controller, and it works to control Zigbee devices. So now I have to wonder why SC bombs out so quickly when I try to add new Zigbee devices, but I’m figuring I’ll try a factory reset out it, re-add it as a secondary, and see if I get better results.

Thanks for taking the time to look at/reply to my thread! Having a real community is not overrated.


#5

ZigBee Home Automation, which is what SmartThings uses, does not allow for secondary controllers. (Proprietary ZigBee, such as that used by Control4, may add this feature, but it is not available for SmartThings.)

What you are seeing with the Aeon minimote is something entirely different, what SmartThings calls a “button controller.” The Aeon Minimote is a zwave device that does not communicate directly with any ZigBee device. Instead, it sends the request to the SmartThings hub via zwave, which then turns around and sends it to the ZigBee device via ZigBee. But there is still only one ZigBee controller–the one inside the SmartThings hub.

The Aeon minimote can also act as a secondary ZWAVE controller to the SmartThings zwave network, which allows it to include new Zwave devices, but only new zwave devices. Not ZigBee.


#6

For your original questions, you cannot at present get SmartThings to recognize the Pico remote in any fashion. However, if you also use the Staples Connect, you can create parallel control paths so that the Pico can turn off a zwave light that is also controllable through SmartThings. It’s very important that you not read too much into that–a lot of the controls are one way and statuses are not necessarily updated. Note that the Pico is communicating ONLY with the Staples unit, so it can only control devices that are paired with it. Which means no virtual switches, no mode changes, etc. And it doesn’t give SmartThings control of the Lutron devices that are connected to Staples.

@KingPumpkin is a community member who has both Staples Connect and SmartThings and has used the Staples Connect as a secondary zwave controller to SmartThings. See:


(Mike) #7

I believe that my solution would be very simple if I had a way to send a message from SC to SmartThings, but I need to be honest and admit that StaplesConnect is a total joke and was a waste of money. I am reaping what I sowed! I figure what I’ll do is just sell off my Pico remotes and buy Connected Bulb remotes with the money.

Thanks for the help everybody.


(Alan Brown) #8

I spent many hours trying to set up three z-wave controllers with security enabled. At the time I had SC, Wink and an OpenHAB z-wave stick. I failed often before I succeeded. Some day I will write it all up, but the issue is to ensure that you join the secondary controller using a secure add AND (very important) they two controllers are very close to each other. The secure add exchanges keys at a very low transmit power level so it cannot be snooped. After I joined wink to SC, I was able to control door locks and garage doors with both wink and SC.

Then came openHAB, that was a little trickier. I needed to use a specially updated version of the zwave driver and I needed to know the secure key. In theory if you start with a random key for openHAB you can easily secure add SC and Wink. But I already had a viable security key, I just did not know what it was. It was fairly easy to grab using a Windows box (safely booted in a VM so it could do no damage) connected to the z-wave USB key and using the zensys tools https://aeotec.freshdesk.com/support/solutions/articles/6000110204-zensys-tool again using a secure add and then looking carefully through the output for the key.

Now secure adding to SC is rather counter-intuitive. I asked it to add a garage door opener and then proceeded to connect a controller in learn mode.

Then came ST. I “discovered” that many of my pains that had forced me into a 3 controller situation were fixed using ST. So (now being a relative expert at adding more controllers) I walked the ST hub up to the SC and did a secure add. The ST did add to the network and I could control all of my non secure devices, but I saw a secure add error in the logs and it did not cache away the security key and will not control secure devices. I tried it twice just in case and it failed the same way both times. I have not been back to spend hours and hours trying to debug that.

Now I am sure I could do the reverse and transfer the primary controller to ST, re-add the secure devices and then secure add the SC, Wink and openHAB back in - but I am tired. Very tired of broken-ware, and re-architecting the system to work around deficiencies and bugs.

But I too keep my SC around to manage the Lutron Caséta pico remotes that are so very nice. I do hope to retire openHAB (once I have figured out what to do with my iTach devices and my serial connected alarm system). And I can hardly wait to retire the wink. But currently it locks the unlocked front door when it has been unlocked for an hour and it is still my interface from Amazon Echo - which I can move to ST easily enough - but there is not enough time in the day.

But you can control secure devices from more than one controller - with care.