Schlage won't reset nor connect to ST

So went to set smart things the other day with the new wifi and cannot for the life of my get my schlage lock to reset or reconnect to my st hub. I have pulled the power like suggested held the schlage button and re entered the programming code after 4 of the 6 buttons the red x comes up. I’ve also tried moving my hub right next to the lock as well as tried excluding it through z-wave. I’m lost and about to take a baseball bat to this thing

Here is the usual suggestion from @rboy

  1. Reset your lock to factory defaults
  2. Reboot your hub
  3. Bring your lock within 5ft of the hub
  4. Exclude your lock
  5. Pair your lock

When excluding or pairing the lock, start the process from the ST app, then enter the programming code + 0 from the lock

1 Like

That’s the problem I can’t get it to exclude or even reset with any of the codes it’s like it’s not fully resetting. I unplug it with the schlage button pressed and then I get 3 green check mark flashes and I punch in the programming code and it blinks red like it didn’t reset

Any other idea? Bought a repeater and cannot get the schlage lock to reset even with the hub a foot away

tagging @RBoy

You may want to check the programming code. After a hard reset the lock reverts to the factory default programming code.

Yeah thats what I’m trying to get it to do is revert back and it won’t even let me punch in the factory programming codes or user codes. Gonna try and get ahold of schlage today because I can’t enter any of my user codes or the factory

The same thing happened to one of my locks after it went offline and i deleted the lock from smartthings. After factory resetting & zwave exclusion - it would only join insecurely in the new app, but did not control the lock. The only thing that worked was adding the lock in the Classic app. It joined immediately with no issues.

I’ve noticed that difference sometimes too where it pairs with the Classic app but has issues with the new app pairing. I suspect it may be something to do with the latency and how the new app works causing it to possibly timeout. Try it after about 6 hours mid week and I tend to see better results.

Ended up calling schlage and went through everything that was going on with the lock and they just ended up sending me a new one. The new one does have an added button for pairing and deleting that made it much easier then before

Yes that’s the ZP (Z-Wave Plus) model which has slightly better battery life as well amongst other features. You may want to check out this enhanced DTH to take advantage of the lock features (and fixes for some firmware issues).