Scene that turns stuff off

I am a new ST user but long time HA user of vera products. I created a scene that turns my upstairs off the scene is named upstairs. This works as desired however when asking alexa to turn off upstairs i get - upstairs does not support that.

When I say turn on upstairs (which is really off) it works. Is it as simple as making a scene with everything on. Then say turn off upstairs?

In vera they had a change state feature when building a scene so on/off with alexa worked.

Any suggestions would be appreciated.

SmartThings scenes are just a snapshot of a moment in Time. They don’t have an “off.“

So you would have two scenes. One that turned everything on. One that turned everything off.

At our house, we say “activate {scene name}” instead of “turn on” and that seems to work well for us.

So “Alexa, activate bedtime” turns some lights on, some lights off, and the TV off. :sunglasses:

Another alternative is not to use a smartthings scene, but rather use an Alexa group. Alexa allows you to put devices into more than one group, so you can set up whichever ones you want. Then you could say “Alexa, turn on upstairs” and it would work. As would “Alexa, turn off upstairs.”

Personally, I tend to only use scenes when I have a situation where I want some devices on and some devices off, or devices set to different dim levels. But whatever works for you.



Thanks so much for the fast reply. I am not sure I knew about activate. I have been using more alexa groups but when “fixing” alexa issues the groups have disappeared. Maybe after my ST leaving curve is over I can start using groups more.

On a similar subject, The ST and alexa integration is disappointing that I can’t control what gets integrated into alexa from ST. So I have many duplicates because of existing integrations with alexa (ecobee, bond, etc) I found some info on renaming and disabling in alexa append that helped

1 Like